Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336564 - =media-libs/nas-1.9.3: "nasd" executable is built without LDFLAGS
Summary: =media-libs/nas-1.9.3: "nasd" executable is built without LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2010-09-09 08:28 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2014-02-16 16:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (nas-1.9.2:20100908-174801.log,325.50 KB, text/plain)
2010-09-09 08:28 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-09-09 08:28:08 UTC
See attached build log.

(Please do not complain about the need for looking at the build log until you can provide an easy way to open bugs with the correct data picked out of a tinderbox log. Thanks.)
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-09-09 08:28:22 UTC
Created attachment 246573 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2012-01-20 22:02:10 UTC
I've added some arguments to the emake call in the ebuild:

SHLIBGLOBALSFLAGS="${LDFLAGS}" for libaudio build
EXTRA_LDOPTIONS="${LDFLAGS}" for everything else

But couldn't figure this one out:

 * QA Notice: Files built without respecting LDFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/bin/nasd

NeedPatch! :)
Comment 3 Samuli Suominen gentoo-dev 2014-02-16 16:29:57 UTC
from build.log of nas-1.9.3-r1:

x86_64-pc-linux-gnu-gcc -o nasd -O2 -pipe -march=native -frecord-gcc-switches   -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu  -L../lib/audio -L/usr/lib64 -L/usr/lib64    dia/libdia.a dda/voxware/libvoxware.a os/libos.a        

looks like this is already been fixed, not sure how, but it is...
Comment 4 Samuli Suominen gentoo-dev 2014-02-16 16:32:13 UTC
this could be a problem with parallel make, I see in your log the nasd executable is built at src_install() due to earlier errors in src_compile() ?
can you still reproduce anykind of LDFLAGS ignorance w/ 1.9.3-r1 ? if you can, please reopen
Comment 5 Samuli Suominen gentoo-dev 2014-02-16 16:33:29 UTC
i see now that fix for bug 446598 also fixed this one