Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336388 - sys-fs/e2fsprogs-1.41.11 resize2fs offline ext4 without resize_inode eats filesystems
Summary: sys-fs/e2fsprogs-1.41.11 resize2fs offline ext4 without resize_inode eats fil...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2010-09-07 21:02 UTC by Christopher Head
Modified: 2011-09-27 19:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Head 2010-09-07 21:02:06 UTC
I somehow ended up with an (otherwise perfectly usable) ext4 filesystem with the resize_inode flag cleared. I decided to grow it a bit, and ended up doing so by means of an offline resize2fs. This ate half my filesystem, leaving thousands of errors for e2fsck to clean up (fortunately all the lost files were from one large app, which I reinstalled). Later I tried doing an online resize of the same filesystem to grow it a bit more; this outright failed with a message saying that resizing filesystems without resize_inode was not supported. I then made a new filesystem with resize_inode set, copied in the files, and everything worked fine.

Maybe resize2fs shouldn't be expected to resize filesystems without the resize_inode flag. If that's the case, it should fail cleanly in the offline case just like it does in the online case, rather than eating half the filesystem.

Reproducible: Always

Steps to Reproduce:
Comment 1 Christopher Head 2010-09-07 21:02:42 UTC
# emerge --info sys-fs/e2fsprogs
Portage (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11.2-r0, 2.6.35-gentoo-r4 x86_64)
                        System Settings
System uname: Linux-2.6.35-gentoo-r4-x86_64-Intel-R-_Core-TM-_i5_CPU_750_@_2.67GHz-with-gentoo-1.12.13
Timestamp of tree: Sun, 05 Sep 2010 18:15:03 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       3.4.6-r2, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm AdobeFlash-10 AdobeFlash-10.1"
CFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/ibormuth /var/lib/layman/sunrise /usr/local/portage"
USE="X acpi amd64 bzip2 cairo caps cli crypt cvs cxx dbus dillo double-precision dri ecap fortran git gmp gtk hal hpn icap-client iconv idn imap java jce jpeg latex mercurial mmx modules multilib ncurses nls nonfsv4 nptl nptlonly opengl pam png pppd readline reflection sdl session spell spl sse sse2 ssh ssl startup-notification subversion svg symlink sysfs thunar truetype unicode vim-syntax xinerama xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" QEMU_SOFTMMU_TARGETS="x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XFCE_PLUGINS="menu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 

                        Package Settings

sys-fs/e2fsprogs-1.41.11 was built with the following:
USE="(multilib) nls" 
Comment 2 SpanKY gentoo-dev 2010-09-14 13:08:41 UTC
i dont see any notes in the 1.41.12 release to indicate this was fixed ...
Comment 3 SpanKY gentoo-dev 2010-12-29 06:49:25 UTC
release notes for 1.41.14 indicate this should be fixed