Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336087 - kde-base/pykde4-4.4.5 fails to compile with dev-python/sip-4.11
Summary: kde-base/pykde4-4.4.5 fails to compile with dev-python/sip-4.11
Status: RESOLVED DUPLICATE of bug 332503
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-05 13:45 UTC by Steve Warren
Modified: 2010-09-05 23:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,10.70 KB, text/plain)
2010-09-05 13:47 UTC, Steve Warren
Details
environment log (environment,247.76 KB, text/plain)
2010-09-05 13:48 UTC, Steve Warren
Details
emerge --info (emerge.info,4.35 KB, text/plain)
2010-09-05 14:58 UTC, Steve Warren
Details
build log (pykde4-4.4.5build.log,10.34 KB, text/plain)
2010-09-05 15:55 UTC, barrie backhurst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Warren 2010-09-05 13:45:21 UTC
kde-base/pykde4-4.4.5 fails to compile with dev-python/sip-4.11

[  3%] Built target compile_python_files
[  4%] Generating sip/khtml/sipkhtmlpart0.cpp, sip/khtml/sipkhtmlpart1.cpp, sip/khtml/sipkhtmlpart2.cpp, sip/khtml/sipkhtmlpart3.cpp, sip/khtml/sipkhtmlpart4.cpp, sip/khtml/sipkhtmlpart5.cpp, sip/khtml/sipkhtmlpart6.cpp, sip/khtml/sipkhtmlpart7.cpp             
                                                                                       
sip: /var/tmp/portage/kde-base/pykde4-4.4.5/work/pykde4-4.4.5/python/pykde4/sip/kdecore/typedefs.sip:737: Mapped type has already been defined in another module
make[2]: *** [python/pykde4/sip/akonadi/sipakonadipart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
sip: /var/tmp/portage/kde-base/pykde4-4.4.5/work/pykde4-4.4.5/python/pykde4/sip/kdecore/typedefs.sip:737: Mapped type has already been defined in another module
make[2]: *** [python/pykde4/sip/dnssd/sipdnssdpart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/all] Error 2
sip: /var/tmp/portage/kde-base/pykde4-4.4.5/work/pykde4-4.4.5/python/pykde4/sip/kdecore/typedefs.sip:737: Mapped type has already been defined in another module
make[2]: *** [python/pykde4/sip/kdecore/sipkdecorepart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kdecore.dir/all] Error 2
sip: /var/tmp/portage/kde-base/pykde4-4.4.5/work/pykde4-4.4.5/python/pykde4/sip/kdecore/typedefs.sip:737: Mapped type has already been defined in another module
make[2]: *** [python/pykde4/sip/kdeui/sipkdeuipart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kdeui.dir/all] Error 2
sip: /var/tmp/portage/kde-base/pykde4-4.4.5/work/pykde4-4.4.5/python/pykde4/sip/kdecore/typedefs.sip:737: Mapped type has already been defined in another module
make[2]: *** [python/pykde4/sip/khtml/sipkhtmlpart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_khtml.dir/all] Error 2
make: *** [all] Error 2
emake failed
 * ERROR: kde-base/pykde4-4.4.5 failed:
 *   Make failed!
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 6388:  Called kde4-meta_src_compile
 *   environment, line 3920:  Called kde4-base_src_compile
 *   environment, line 3583:  Called cmake-utils_src_compile
 *   environment, line 1762:  Called _execute_optionaly 'src_compile'
 *   environment, line  673:  Called enable_cmake-utils_src_compile
 *   environment, line 2131:  Called cmake-utils_src_make
 *   environment, line 1781:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 * 
 * If you need support, post the output of 'emerge --info =kde-base/pykde4-4.4.5',
 * the complete build log and the output of 'emerge -pqv =kde-base/pykde4-4.4.5'.
 * The complete build log is located at '/var/tmp/portage/kde-base/pykde4-4.4.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/pykde4-4.4.5/temp/environment'.
 * S: '/var/tmp/portage/kde-base/pykde4-4.4.5/work/pykde4-4.4.5'

 * Messages for package kde-base/pykde4-4.4.5:

 * ERROR: kde-base/pykde4-4.4.5 failed:
 *   Make failed!
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 6388:  Called kde4-meta_src_compile
 *   environment, line 3920:  Called kde4-base_src_compile
 *   environment, line 3583:  Called cmake-utils_src_compile
 *   environment, line 1762:  Called _execute_optionaly 'src_compile'
 *   environment, line  673:  Called enable_cmake-utils_src_compile
 *   environment, line 2131:  Called cmake-utils_src_make
 *   environment, line 1781:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 * 
 * If you need support, post the output of 'emerge --info =kde-base/pykde4-4.4.5',
 * the complete build log and the output of 'emerge -pqv =kde-base/pykde4-4.4.5'.
 * The complete build log is located at '/var/tmp/portage/kde-base/pykde4-4.4.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/pykde4-4.4.5/temp/environment'.
 * S: '/var/tmp/portage/kde-base/pykde4-4.4.5/work/pykde4-4.4.5'

Reproducible: Always
Comment 1 Steve Warren 2010-09-05 13:47:09 UTC
Created attachment 246122 [details]
build log
Comment 2 Steve Warren 2010-09-05 13:48:12 UTC
Created attachment 246124 [details]
environment log
Comment 3 Steve Warren 2010-09-05 14:58:53 UTC
Created attachment 246156 [details]
emerge --info
Comment 4 barrie backhurst 2010-09-05 15:55:28 UTC
Created attachment 246159 [details]
build log

I have the same problem and believe it to be related to bug 332503 which is resolved but only for pykde4-4.5 in the kde overlay
Comment 5 Steve Warren 2010-09-05 16:28:53 UTC
(In reply to comment #4)
> Created an attachment (id=246159) [details]
> build log
> 
> I have the same problem and believe it to be related to bug 332503 which is
> resolved but only for pykde4-4.5 in the kde overlay
> 
The related patch ( Applying pykde4-4.4.92-build-fix-sip.patch ) is also in portage for pykde4-4.4.5. After looking at bug 332503 it appear that this happens several lines further into the compile process.
Comment 6 barrie backhurst 2010-09-05 22:49:31 UTC
I have now applied the patch from bug 332503(in addition to the existing patch) and confirm that it solves the problem and emerges OK
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-05 23:22:07 UTC

*** This bug has been marked as a duplicate of bug 335203 ***
Comment 8 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-05 23:23:00 UTC
fail
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-05 23:23:10 UTC

*** This bug has been marked as a duplicate of bug 332503 ***