Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 335763 - sys-kernel/genkernel should ensure CONFIG_SYSFS_DEPRECATED is disabled
Summary: sys-kernel/genkernel should ensure CONFIG_SYSFS_DEPRECATED is disabled
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2010-09-03 09:37 UTC by Roland Tapken
Modified: 2012-01-24 23:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Tapken 2010-09-03 09:37:12 UTC
Newer versions of udev don't support systems compiled with CONFIG_SYSFS_DEPRECATED / CONFIG_SYSFS_DEPRECATED_V2. But "genkernel" enables these options:

$ grep SYSFS_DEPRECATED /usr/src/linux/.config
CONFIG_SYSFS_DEPRECATED=y
CONFIG_SYSFS_DEPRECATED_V2=y

Result: The system will not start up using a kernel compiled this way because many entries in /dev are missing.

I've could reproduce this on linux-2.6.30-gentoo-r4. A newer kernel (linux-2.6.34-gentoo-r6) seems to not have this problem.

Reproducible: Always

Steps to Reproduce:
1. Have an older kernel version (e.g. 2.6.30)
2. Update udev - it complains about CONFIG_SYSFS_DEPRECATED(_V2)
3. Start "genkernel" to rebuild the kernel

Actual Results:  
Kernel compiled with CONFIG_SYSFS_DEPRECATED and CONFIG_SYSFS_DEPRECATED_V2, prohibiting the system from stating up because some device entries (/dev/sd*, etc) are missing.

Expected Results:  
Get a kernel compiled without these flags.

sys-fs/udev-151-r5
sys-kernel/genkernel-3.4.10.906

I've set "Severity" to "Major" because if you don't find out that the kernel created with genkernel will be compiled using these flags your system will not be able to boot. Maybe this even should be categorized as "Critical" since udev-151 is marked as stable?
Comment 1 Roland Tapken 2010-09-03 09:43:52 UTC
Portage 2.1.8.3 (hardened/linux/amd64/10.0, gcc-4.3.4, glibc-2.11.2-r0, 2.6.33-grml64 x86_64)
=================================================================
System uname: Linux-2.6.33-grml64-x86_64-QEMU_Virtual_CPU_version_0.10.0-with-gentoo-1.12.13
Timestamp of tree: Fri, 03 Sep 2010 03:00:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.5.4-r3, 2.6.5-r3, 3.1.2-r4
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       3.4.6-r2, 4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=athlon64"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch usersandbox"
GENTOO_MIRRORS="ftp://mirror.netcologne.de/gentoo/"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 bash-completion berkdb bzip2 cli cracklib crypt cxx dri gdbm gpm hardened iconv justify mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pic pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode urandom xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Samuli Suominen gentoo-dev 2012-01-23 00:19:47 UTC
Still a problem for number of arches as per:

ssuominen@null /tmp/genkernel-3.4.23.1 $ grep -r DEPRECATED *
arch/alpha/kernel-config:CONFIG_SYSFS_DEPRECATED=y
arch/sparc64/kernel-config:CONFIG_SYSFS_DEPRECATED=y
arch/x86/kernel-config:CONFIG_SYSFS_DEPRECATED=y
arch/ppc/kernel-config:CONFIG_SYSFS_DEPRECATED=y
arch/ia64/kernel-config:CONFIG_SYSFS_DEPRECATED=y

Raising severity since this results in unbootable systems
Comment 4 Sebastian Pipping gentoo-dev 2012-01-24 23:30:37 UTC
+*genkernel-3.4.24 (24 Jan 2012)
+
+  24 Jan 2012; Sebastian Pipping <sping@gentoo.org> +genkernel-3.4.24.ebuild:
+  Bump to 3.4.24
+