It was possible to conduct a XSS attack using error messages in PHP backtrace.
For 3.x: versions before 3.3.6 are affected.
Arches, please test and mark stable:
Target keywords : "alpha amd64 hppa ppc ppc64 sparc x86"
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin
2.11.x before 18.104.22.168 and 3.x before 22.214.171.124 allow remote attackers
to inject arbitrary web script or HTML via vectors related to (1)
db_search.php, (2) db_sql.php, (3) db_structure.php, (4)
js/messages.php, (5) libraries/common.lib.php, (6)
libraries/dbi/mysqli.dbi.lib.php, (9) libraries/db_info.inc.php, (10)
libraries/sanitizing.lib.php, (11) libraries/sqlparser.lib.php, (12)
server_databases.php, (13) server_privileges.php, (14)
setup/config.php, (15) sql.php, (16) tbl_replace.php, and (17)
Third time's the charm... We have yet another XSS fixed in 3.3.7.
Remaining arches, please go on stabilizing in bug 336462. Thanks.
Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in
phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web
script or HTML via vectors related to a PHP backtrace and error messages
(aka debugging messages), a different vulnerability than CVE-2010-3056.
Affected ebuilds were removed from the tree.
This issue was resolved and addressed in
GLSA 201201-01 at http://security.gentoo.org/glsa/glsa-201201-01.xml
by GLSA coordinator Tim Sammut (underling).