Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 334467 - dev-util/boost-build does not respect LDFLAGS
Summary: dev-util/boost-build does not respect LDFLAGS
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2010-08-25 15:57 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2012-08-19 18:23 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (boost-build-1.42.0:20100825-152409.log,6.11 KB, text/plain)
2010-08-25 15:57 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-25 15:57:03 UTC
See attached build log.

(Please do not complain about the need for looking at the build log until you can provide an easy way to open bugs with the correct data picked out of a tinderbox log. Thanks.)
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-25 15:57:14 UTC
Created attachment 244573 [details]
Build log
Comment 2 Gef 2010-09-06 12:59:02 UTC
Hi Diego,
On an ~amd64 system here, I cannot reproduce that bug. The build does not exhibit any QA warning, and the log clearly shows that {LD,C}FLAGS are appended where the sould be. Any hint on what I should do to reproduce ?
Comment 3 Tiziano Müller gentoo-dev 2012-08-19 18:23:00 UTC
Rechecked, can't reproduce. But I replaced the workaround by a patch and added verbosity flags showing that our LDFLAGS get respected.