Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 333001 - net-misc/wicd-1.7.0 doesn't support Python 2.7
Summary: net-misc/wicd-1.7.0 doesn't support Python 2.7
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jeremy Olexa (darkside) (RETIRED)
URL: https://bugs.launchpad.net/wicd/+bug/...
Whiteboard:
Keywords:
: 347475 (view as bug list)
Depends on:
Blocks: python-2.7
  Show dependency tree
 
Reported: 2010-08-16 12:39 UTC by Nickolas Grigoriadis
Modified: 2011-03-26 00:10 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
wicd 1.7 latest (wicd-1.7.9999.ebuild,2.83 KB, text/plain)
2010-11-29 18:57 UTC, Joel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nickolas Grigoriadis 2010-08-16 12:39:57 UTC
wicd 1.7.0 doesn't support Python 2.7
More info at: https://bugs.launchpad.net/wicd/+bug/602825

Reproducible: Always

Steps to Reproduce:
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-07 15:50:26 UTC
From the upstream bug, let's get a patch together that removes the offending code. Will you volunteer to test this out since I don't have py-2.7?
Comment 2 Nickolas Grigoriadis 2010-09-08 02:23:47 UTC
Yes, I'll do the testing.
Comment 3 Nickolas Grigoriadis 2010-10-06 17:45:49 UTC
The https://bugs.launchpad.net/wicd/+bug/602825/+attachment/1673953/+files/wicd-no-deepcopy.patch

patch works. but I needed to change the line 38 of wicd/configmanager.py to read:

RawConfigParser.__init__(self, allow_no_value=True)

allow_no_value parameter was only added on Python 2.7

The patch to add 2.7 support will break older compatibility.
Is is possible to make the code conditional based on python version?

Regards,
Nick
Comment 4 Wicher Minnaard 2010-10-09 07:16:38 UTC
Confirming this patch works over here, too, but not without the allow_no_value parameter from Nickolas.
I don't think the code should be conditional (py2.6/py2.7) at runtime, since one installs wicd for a specific python version. Maybe it's better to make the epatch line in the ebuild conditional, in such a way that the patch only gets applied when installing wicd for python 2.7.
Comment 5 Jakub Caban 2010-11-29 11:48:42 UTC
Version 1.7.1b2 released upstream supports Python-2.7 and works here on amd64 without problems. Bump is the matter of ebuild renaming.
Comment 6 Joel 2010-11-29 18:47:04 UTC
(In reply to comment #5)
> Version 1.7.1b2 released upstream supports Python-2.7 and works here on amd64
> without problems. Bump is the matter of ebuild renaming.
> 

Could you please upload an ebuild? I've been trying with no luck :(
Comment 7 Joel 2010-11-29 18:56:48 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Version 1.7.1b2 released upstream supports Python-2.7 and works here on amd64
> > without problems. Bump is the matter of ebuild renaming.
> > 
> 
> Could you please upload an ebuild? I've been trying with no luck :(
> 

Forget that. I'm uploading it right now
Comment 8 Joel 2010-11-29 18:57:13 UTC
Created attachment 255859 [details]
wicd 1.7 latest
Comment 9 Xavier Miller gentoo-dev 2010-11-30 08:10:19 UTC
Hello,

This ebuild works for me with python-2.7.1. The curses and X User Interfaces work too.

Comment 10 François Périchon 2010-11-30 18:06:06 UTC
This ebuild worked correctly with my python 2.7.1 install and solved my problem too.
Comment 11 Emmanuel Andry 2010-12-01 19:25:51 UTC
Any hope to see it on portage soon ? I think a lot of users should be in trouble since python 2.7.1 is unmasked...
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-01 19:39:24 UTC
+*wicd-1.7.1_beta2 (01 Dec 2010)
+
+  01 Dec 2010; Jeremy Olexa <darkside@gentoo.org> +wicd-1.7.1_beta2.ebuild:
+  Quick version bump to add the beta to ~arch for python-2.7 support,
+  mainly. (bug 333001).

Thanks for testing/feedback.
Comment 13 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-01 20:12:59 UTC
*** Bug 347475 has been marked as a duplicate of this bug. ***
Comment 14 Saleh Alsanad 2011-03-26 00:10:53 UTC
I confirm that the ebuild worked with me