Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 33259 - an ebuild for htlatex / tex4ht would be nice
Summary: an ebuild for htlatex / tex4ht would be nice
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Text-Markup Team (OBSOLETE)
Keywords: EBUILD
Depends on:
Reported: 2003-11-11 15:20 UTC by Peter Simons
Modified: 2004-08-19 01:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

TeX4ht ebuild (tex4ht.tar.bz2,2.85 KB, application/x-tbz)
2004-04-24 07:40 UTC, Maarten Wisse
TeX4ht ebuild r1 (tex4ht-20040211-r1.ebuild,1.41 KB, text/plain)
2004-04-24 08:14 UTC, Maarten Wisse
TeX4ht ebuild r2 (tex4ht-20040211-r2.ebuild,1.45 KB, text/plain)
2004-04-26 05:44 UTC, Maarten Wisse
tex4ht ebuild, no needed files directory (tex4ht-20040616.ebuild,1.88 KB, text/plain)
2004-06-16 15:07 UTC, Richard Seymour

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Simons 2003-11-11 15:20:00 UTC
In case anybody who knows ebuilds better than I do is interested in LaTeX, there
is a great package available, which is as of now not supported in Gentoo:

It would be very nice to have an ebuild for that package, since it allows for
writing real XML documens in LaTeX, among other things.

Reproducible: Always
Steps to Reproduce:
Comment 1 Maarten Wisse 2004-04-24 07:38:43 UTC
Attached is an initial ebuild for TeX4ht. I'm willing to act as a package maintainer for this, if that is appreciated. I've quite a bit experience with TeX4ht, see under `Software'. This site is actually made with TeX4ht. There are still some glitches in the ebuild:

1. the package doesn't have a version number. With a new release, Gurari simply overwrites the old. This makes it impossible to ascertain the version of the package. I've asked Gurari to change the name of the package to tex4ht-<date>.zip.

2. The environment file tex4ht.env is now taken from filesdir. I've to try out whether it works to take it from the distribution and sed the dir names.

3. I'm not sure of the dependencies. Previously, I used to install this manually, so I've all the requirements fulfilled, but I'm not sure others have as well.
Comment 2 Maarten Wisse 2004-04-24 07:40:31 UTC
Created attachment 29957 [details]
TeX4ht ebuild
Comment 3 Maarten Wisse 2004-04-24 08:14:20 UTC
Created attachment 29963 [details]
TeX4ht ebuild r1

Source uri problem solved.
Comment 4 Maarten Wisse 2004-04-26 05:44:02 UTC
Created attachment 30078 [details]
TeX4ht ebuild r2

Kpathsea support added to handle platform specific searchpaths more
Comment 5 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-04-26 08:06:12 UTC
Hi, thank you for submitting the ebuild and contacting to the upstream author about source filename. Your ebuild works fine but it would need some fixes before I add it to the Portage tree.  1. It doesn't have ebuild header (Copyright assignment to Gentoo Technologies Inc., see /usr/portage/skel.ebuild for example). We ask every ebuilds' submitters to add it (Otherwise we cannot include it to official tree)  2. LICENSE should be one of existing filenames in /usr/portage/licenses. In this case, it should be "LPPL-1.2" (version number is necessary)  3. KEYWORDS must contain platforms which you tested it on. (If you test it on all arches that you wrote, that's fine) Also, ~alpha appears twice.  4. src_unpack() isn't needed. It defaults to unpack zip file.  5. einfo "..." in src_compile() should be die "...", otherwise portage won't stop even when compilation fails.  It would be appreciated if you rewrite and reattach the ebuild.  
Comment 6 Richard Seymour 2004-06-16 15:07:09 UTC
Created attachment 33397 [details]
tex4ht ebuild, no needed files directory

This tex4ht-20040616.ebuild uses sed to fix the environment file.  It also
fixes the permissions on the ht-fonts directory.  I also fixed the 5 points
outlined above.  Hopefully this will get in, it puts out really nice mathml and output!	

Here's a little example of what it can do: for an example (works in firefox
0.8).  I think the minimal errors (cosine to the 4th looks weird) are more on
my end.  The export really surprised me though, it's very nice.

Let me know if this doesn't look good.
Comment 7 Peter Simons 2004-06-18 11:46:59 UTC
Just to provide some feedback: I have tested the latest ebuild on x86 and it worked just fine.
Comment 8 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-08-18 08:50:49 UTC
Sorry fot the delay. I've just added it to CVS. Thanks to all of you.
Comment 9 Maarten Wisse 2004-08-19 01:27:21 UTC
Sorry for not having responded to previous questions. I don't know how it could happen, but I'm pretty sure that I didn't receive notifications of comments added to this bug. Thanks for repairing problems and adding it to Portage