Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 332395 - sys-fs/zfs-fuse-0.6.9-r1 doesn't respect CC/CFLAGS/LDFLAGS value
Summary: sys-fs/zfs-fuse-0.6.9-r1 doesn't respect CC/CFLAGS/LDFLAGS value
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Low normal (vote)
Assignee: Christian Parpart (RETIRED)
URL:
Whiteboard:
Keywords:
: 337321 (view as bug list)
Depends on:
Blocks: ldflags 358697
  Show dependency tree
 
Reported: 2010-08-12 08:05 UTC by Marcin Mirosław
Modified: 2012-02-26 17:58 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild (zfs-fuse-9999.ebuild,1.58 KB, text/plain)
2010-09-09 14:15 UTC, Marcin Mirosław
Details
CC/CFLAGS/LDFLAGS patch (9999_cc_cflags_ldflags.patch,1.90 KB, text/plain)
2010-09-09 14:15 UTC, Marcin Mirosław
Details
CC/CFLAGS/LDFLAGS patch (9999_cc_cflags_ldflags.patch,1.90 KB, text/plain)
2010-09-10 11:06 UTC, Marcin Mirosław
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Mirosław 2010-08-12 08:05:48 UTC
I set CC=clang in make.conf (also made export CC=clang ) but zfs-fuse still compiles using gcc.

scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
gcc -o cmd/stat/common/timestamp.o -c -pipe -Wall -std=c99 -Wno-switch -Wno-unused -Wno-missing-braces -Wno-parentheses -Wno-uninitialized -fno-strict-aliasing -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DTEXT_DOMAIN=\"zfs-fuse\" -DNDEBUG -DLINUX_AIO -Ilib/libuutil/include -Ilib/libnvpair/include -Ilib/libumem/include -Ilib/libzfscommon/include -Ilib/libzfs/include -Ilib/libsolcompat/include -Ilib/libavl/include -Icmd/stat/common cmd/stat/common/timestamp.c



Reproducible: Always




emerge --info
Portage 2.1.8.3 (hardened/linux/x86/10.0, gcc-4.4.4, glibc-2.11.2-r0, 2.6.32-hardened-r10 i686)
=================================================================
System uname: Linux-2.6.32-hardened-r10-i686-Pentium-R-_Dual-Core_CPU_E6300_@_2.80GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 12 Aug 2010 07:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache collision-protect distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/"
LANG="pl_PL"
LC_ALL="pl_PL.ISO-8859-2"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-6"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/gnustep /usr/portage/local/layman/steev /usr/portage/local /usr/local/portage/miro/staging /usr/local/portage/miro/portage"
SYNC="rsync://trumpetti.atm.tut.fi/gentoo-portage/"
USE="acl acpi adns aio apache2 ares bash-completion bcmath berkdb bzip2 caps cgi chroot clamav clamdtop cli cracklib crypt cups curl custom-cflags cxx dkim dri dsn enscript exiscan exiscan-acl fam fastcgi force-cgi-redirect gdbm gnutls graphite hardened iconv idn imap iproute2 ipv6 libssh2 logrotate lzo maildir mmap mmx modules mudflap ncurses network-cron nls nptl nptlonly objc objc++ objc-gc openmp openssl pam pcre perl pic pppd profiling python readline reflection sctp server session sharedmem sieve spell spl srs sse sse2 sse3 ssl ssse3 subversion suhosin sysfs syslog threads threadsafe tools unicode urandom vhosts vim vim-pager vim-syntax x86 xattr xml xorg zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1     emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m       maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon auth_digest authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user cache cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif status unique_id usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" NGINX_MODULES_HTTP="access auth_basic browser charset fastcgi gzip limit_req limit_zone map proxy referer rewrite stub_status upstream_ip_hash userid" RUBY_TARGETS="ruby18" USERLAND="GNU" XTABLES_ADDONS="geoip ipset psd tarpit" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Samuli Suominen gentoo-dev 2010-09-03 16:20:10 UTC
When you run scons on zfs-fuse, it also runs autotools based ./configure on by itself too.  Also, LDFLAGS is entirely ignored and CFLAGS half of the time.

It's a build system nightmare.
Comment 2 Marcin Mirosław 2010-09-09 14:14:25 UTC
I made very dirty patch which solves problem with CC, CFLAGS, LDFLAGS.
I'm attaching live ebuild, i've "fixed" in it problem with zfs-fuse on hardened-sources (pax mark), i've add "die message".
Btw, i've succesfully build zfs-fuse with clang.
Comment 3 Marcin Mirosław 2010-09-09 14:15:19 UTC
Created attachment 246593 [details]
ebuild
Comment 4 Marcin Mirosław 2010-09-09 14:15:51 UTC
Created attachment 246594 [details]
CC/CFLAGS/LDFLAGS patch
Comment 5 Marcin Mirosław 2010-09-10 11:06:11 UTC
Created attachment 246686 [details]
CC/CFLAGS/LDFLAGS patch

small fix
Comment 6 Samuli Suominen gentoo-dev 2010-09-14 21:03:00 UTC
*** Bug 337321 has been marked as a duplicate of this bug. ***
Comment 7 Leho Kraav (:macmaN @lkraav) 2011-03-11 04:31:18 UTC
in the meanwhile zfs-fuse 0.7.0 has been released.
Comment 8 Marcin Mirosław 2011-03-13 13:24:36 UTC
Version 0.7.0 still doesn't respect those flags. I filled bug #358697 with request for version bump.
Comment 9 Marcin Mirosław 2011-03-16 11:10:07 UTC
patch is valid for zfs-fuse 0.7.0
Comment 10 Samuli Suominen gentoo-dev 2012-02-26 17:58:03 UTC
Closing since zfs-fuse was removed from tree. But adding bug 358697 to Blocks: -line since if the package is reintroduced to tree, this one should get fixed too.