Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 332285 - x11-drivers/xf86-video-virtualbox does not respect LDFLAGS
Summary: x11-drivers/xf86-video-virtualbox does not respect LDFLAGS
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 430586 (view as bug list)
Depends on:
Blocks: ldflags 394757
  Show dependency tree
 
Reported: 2010-08-11 16:31 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2015-10-22 02:13 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (xf86-video-virtualbox-3.2.8:20100811-113430.log,92.48 KB, text/plain)
2010-08-11 16:31 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-11 16:31:13 UTC
See attached build log.

(Please do not complain about the need for looking at the build log until you can provide an easy way to open bugs with the correct data picked out of a tinderbox log. Thanks.)
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-11 16:31:34 UTC
Created attachment 242449 [details]
Build log
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2011-01-07 19:19:31 UTC
Should be fixed with x11-drivers/xf86-video-virtualbox-4.0.0
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2011-01-08 17:29:47 UTC
Still not fixed... reopening.
Comment 4 Faustus 2011-12-14 23:18:18 UTC
A solution that *should* apparently work is adding
  TEMPLATE_VBOXGUESTR3EXE_LDFLAGS += $(LDFLAGS)
to files/xf86-video-virtualbox-3-localconfig (copied to LocalConfig.kmk by the ebuild).

For some reason, however, it doesn't work, and I am not knowledgeable enough about kBuild to find out why.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2014-03-04 00:39:55 UTC
*** Bug 430586 has been marked as a duplicate of this bug. ***
Comment 6 Rick Farina (Zero_Chaos) gentoo-dev 2015-10-22 02:13:47 UTC
I don't see this error in any current versions