Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 331987 - Merge -council and -project mailing lists
Summary: Merge -council and -project mailing lists
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: Mailing Lists (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Infrastructure
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-10 07:56 UTC by Tomáš Chvátal (RETIRED)
Modified: 2011-11-13 21:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal (RETIRED) gentoo-dev 2010-08-10 07:56:10 UTC
Please merge -council mailinglist into -project one as was decided on last council meeting.

Thanks
Comment 1 solar (RETIRED) gentoo-dev 2010-08-12 05:38:15 UTC
I semi object to this idea. I don't think the current council should toss away years of the council mailing list cuz the current one fails to see the value in having separate mailing lists.
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2010-08-12 06:03:42 UTC
(In reply to comment #1)
> I semi object to this idea. I don't think the current council should toss away
> years of the council mailing list cuz the current one fails to see the value in
> having separate mailing lists.
> 

I don't think the old archives should go away. What the merge means is closing -council for new posts and moving all subscribers to -project that are not already there.
Comment 3 solar (RETIRED) gentoo-dev 2010-08-12 07:10:48 UTC
Note: What I say/said is me as a dev or former council-guy. Not infra related in anyway.I'm just commenting. Sorry for any grammar typos.

All one has to do is take a look at the history of the -project list and see it often has nothing to with the council directly, but functions as a general planned or current ChangeLog of Gentoo itself. IE: lots of overhead for non official council things. http://archives.gentoo.org/gentoo-project 
Granted most if not all of -council should subscribe to -project.

But it is of my asshole, elbow and opinion as a user of Gentoo first and then as a dev that a -council should keep a mailing list where it sends the most basic of it's plans to hold meetings and the such, finial decisions and so on when times that the alias or project is suitable.

I know it's a tad more of a PITA for everybody to have one extra filter in his/her mail clients, but I think you can probably solve most of you want with setting the ReplyTO: field to the -project list.

If as a user and I had a deep concern about Gentoo I would feel much better if I could post that to the council mailing list vs project list, as -project with it's overhead goes not guarantee it's getting to the right people automatically.
Comment 4 Petteri Räty (RETIRED) gentoo-dev 2010-08-12 07:28:54 UTC
(In reply to comment #3)
> Note: What I say/said is me as a dev or former council-guy. Not infra related
> in anyway.I'm just commenting. Sorry for any grammar typos.
> 

Also the right place to comment is when the decision is prepared not when the executing body is asked to do it so we can keep the bugs about actually executing the thing.
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2011-06-09 07:25:11 UTC
Is this still needed?
Comment 6 Petteri Räty (RETIRED) gentoo-dev 2011-06-09 07:32:13 UTC
(In reply to comment #5)
> Is this still needed?

If people can for example still post to gentoo-council then yes.
Comment 7 Petteri Räty (RETIRED) gentoo-dev 2011-07-10 19:34:47 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Is this still needed?
> 
> If people can for example still post to gentoo-council then yes.

And seems they can:
http://archives.gentoo.org/gentoo-council/msg_c10943a5e96c8d8bea3ac25868d3c282.xml
Comment 8 Ulrich Müller gentoo-dev 2011-07-15 23:11:35 UTC
Reassigning, as requested by darkside in #-infra.

Could we please postpone any action until the new council has expressed its opinion on this matter?
Comment 9 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2011-07-15 23:17:52 UTC
If council does want to keep this request.
Please specify answers the following:
- post-merge, how should mails to -council be handled? (I suggest SMTP-level bounce since the address will not be valid anymore)
- What should be done with the subscribers that are only on -council and not on -project?
Comment 10 Petteri Räty (RETIRED) gentoo-dev 2011-07-16 08:13:42 UTC
(In reply to comment #8)
> Reassigning, as requested by darkside in #-infra.
> 
> Could we please postpone any action until the new council has expressed its
> opinion on this matter?

I am not aware of any rule giving individual council members the ability to hold majority decisions so this should be thought as a valid request until ruled otherwise. If we allowed holding for re-votes them in theory a council member could keep decisions on hold indefinitely by continuously requesting re-votes.

(In reply to comment #9)
> If council does want to keep this request.
> Please specify answers the following:
> - post-merge, how should mails to -council be handled? (I suggest SMTP-level
> bounce since the address will not be valid anymore)

I think this is for infra to decide.

> - What should be done with the subscribers that are only on -council and not on
> -project?

See comment 2. Probably would be good to also send them a mail informing them about it.
Comment 11 Ulrich Müller gentoo-dev 2011-07-16 10:23:13 UTC
(In reply to comment #10)
> I am not aware of any rule giving individual council members the ability to
> hold majority decisions so this should be thought as a valid request until
> ruled otherwise. If we allowed holding for re-votes them in theory a council
> member could keep decisions on hold indefinitely by continuously requesting
> re-votes.

There was no activity on this bug since August 2010, so obviously people don't consider this as urgent. Therefore I really wonder why you are pushing the issue just now. What problems would be caused by postponing it until after the next council meeting?
Comment 12 Petteri Räty (RETIRED) gentoo-dev 2011-07-16 12:48:21 UTC
(In reply to comment #11)
> 
> There was no activity on this bug since August 2010, so obviously people don't
> consider this as urgent. Therefore I really wonder why you are pushing the
> issue just now. What problems would be caused by postponing it until after the
> next council meeting?
>

s/people/infra/ (but I could have helped by reminding). I would have liked to see this happen months ago but it wasn't a priority for me as the list wasn't used as decided. Now you are using the list again so it matters for people posting to the proper mailing lists.
Comment 13 Petteri Räty (RETIRED) gentoo-dev 2011-08-17 21:08:46 UTC
Infra it was voted again in the last meeting to proceed here so this should finally be implemented:

http://www.gentoo.org/proj/en/council/meeting-logs/20110809-summary.txt
Comment 14 Tony Vroon gentoo-dev 2011-09-13 19:14:31 UTC
(In reply to comment #9)
> If council does want to keep this request.
> Please specify answers the following:
> - post-merge, how should mails to -council be handled? (I suggest SMTP-level
> bounce since the address will not be valid anymore)

SMTP-level bounce is a fine solution, thank you.

> - What should be done with the subscribers that are only on -council and not on
> -project?

Could we have the affected number of subscribers please?
Comment 15 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2011-10-11 19:52:35 UTC
(In reply to comment #14)
> (In reply to comment #9)
> > If council does want to keep this request.
> > Please specify answers the following:
> > - post-merge, how should mails to -council be handled? (I suggest SMTP-level
> > bounce since the address will not be valid anymore)
> 
> SMTP-level bounce is a fine solution, thank you.
> 
> > - What should be done with the subscribers that are only on -council and not on
> > -project?
> 
> Could we have the affected number of subscribers please?

-council is 160
-project is 394

If we merge, 54 people are subscribed to council but not project (assuming I invoked comm correctly.)
Comment 16 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-11-13 19:38:09 UTC
Please send an email to all gentoo-council ml subscribers with the following text to explain that the ml was closed, that subscribers will be added to the gentoo-project ml and how to unsubscribe from the ml.


Dear gentoo-council ml subscriber,

you are receiving this email because the gentoo-council ml[1] has been closed
and all members not subscribed to the gentoo-project ml[2] were subscribed to
that ml.
The Gentoo Council[3] decided on its 20100809 meeting[4] and again on this
term on the 20110809[5] meeting to close this mailing list and to move all
discussions regarding council to the gentoo-dev ml for technical matters and
to the gentoo-project ml otherwise. Gentoo bug 331987[6] was created to close
this ml. The emails from the gentoo-council ml will remain available through
gentoo-archives[7].
If you do not wish to be subscribed to the gentoo-project ml, as explained on
the mailing lists page[7], all you need to do is to send an empty email to
the gentoo-project+unsubscribe@lists.gentoo.org email from your subscribed
email address and reply to the confirmation email.

 [1] - http://archives.gentoo.org/gentoo-council/
 [2] - http://archives.gentoo.org/gentoo-project/
 [3] - http://www.gentoo.org/proj/en/council/
 [4] - http://www.gentoo.org/proj/en/council/meeting-logs/20100809-summary.txt
 [5] - http://www.gentoo.org/proj/en/council/meeting-logs/20110809-summary.txt
 [6] - https://bugs.gentoo.org/show_bug.cgi?id=331987
 [7] - http://archives.gentoo.org/
 [8] - http://www.gentoo.org/main/en/lists.xml

For the Gentoo Council,

Jorge Manuel B. S. Vicetto
<jmbsvicetto@gentoo.org>
Comment 17 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-11-13 21:20:14 UTC
Done.