Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 331965 - net-proxy/squid-3.1.6 https broken with -ipv6
Summary: net-proxy/squid-3.1.6 https broken with -ipv6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Network Proxy Developers (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 332771 333073 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-09 23:45 UTC by Leonid Kabanov
Modified: 2010-08-17 19:22 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
modified patch for 3.1.6 (squid-ipv4.patch,4.32 KB, patch)
2010-08-10 12:37 UTC, Leonid Kabanov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kabanov 2010-08-09 23:45:08 UTC
In squid-3.1.6 https are broken when ipv6 is disabled. When I try to open https link I get these errors in cache.log:

2010/08/10 06:23:59| comm_open: socket failure: (97) Address family not supported by protocol
2010/08/10 06:24:02| comm_open: socket failure: (97) Address family not supported by protocol
2010/08/10 06:24:18| comm_open: socket failure: (97) Address family not supported by protocol
2010/08/10 06:24:20| comm_open: socket failure: (97) Address family not supported by protocol

I debug a little and found that getOutgoingAddr return '::' for outgoing address so comm_openex try to open ipv6 socket. 
Temporary solution for most users - set tcp_outgoing_address in squid.conf to ipv4 address.
Comment 1 Eray Aslan gentoo-dev 2010-08-10 05:26:15 UTC
Can you please check if the following patch fixes your problem?
http://treenet.co.nz/projects/squid/patches/squid-3.1.6-icap-default-socket.patch
Comment 2 Leonid Kabanov 2010-08-10 06:25:53 UTC
I try this patch but it doesn't help. I think it do something with 'ICAP' feature but my useflag icap-client is disabled. 
Comment 3 Stuart Hickinbottom 2010-08-10 07:49:57 UTC
I'm having this same issue - no IPv6 in the kernel, squid-3.1.6 build with -ipv6, same errors in the cache.log as reported by Leonid.

I applied the patch suggested in comment#1 (to a local modified ebuild) and I also see no change - the same errors are appearing in cache.log.

That also seems to be the experience of upstream at the moment (http://www.spinics.net/lists/squid/msg49141.html).

In the short term I think I'll have to mask that version of the ebuild.
Comment 4 Leonid Kabanov 2010-08-10 12:37:34 UTC
Created attachment 242239 [details, diff]
modified patch for 3.1.6

http://bugs.squid-cache.org/show_bug.cgi?id=3011
Comment 5 Alin Năstac (RETIRED) gentoo-dev 2010-08-12 06:29:44 UTC
Fixed in -r1, thanks!
Comment 6 Stuart Hickinbottom 2010-08-13 07:47:08 UTC
Yep - the -r1 update fixes it for me also, thank you very much.
Comment 7 Alin Năstac (RETIRED) gentoo-dev 2010-08-16 06:33:15 UTC
*** Bug 332771 has been marked as a duplicate of this bug. ***
Comment 8 Alin Năstac (RETIRED) gentoo-dev 2010-08-17 19:22:16 UTC
*** Bug 333073 has been marked as a duplicate of this bug. ***