Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 331851 - net-im/pidgin[perl] does not respect LDFLAGS
Summary: net-im/pidgin[perl] does not respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo net-im Herd
URL: http://developer.pidgin.im/ticket/12638
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2010-08-09 16:38 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-10-25 10:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (pidgin-2.7.2-r1:20100808-234121.log,537.87 KB, text/plain)
2010-08-09 16:38 UTC, Diego Elio Pettenò (RETIRED)
Details
updated patch (pidgin-2.7.3-ldflags.patch,1.50 KB, patch)
2010-08-16 14:05 UTC, Markos Chandras (RETIRED)
Details | Diff
pidgin-2.7.3-ldflags.patch (pidgin-2.7.3-ldflags.patch,1.38 KB, patch)
2010-09-02 12:56 UTC, Peter Volkov (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-09 16:38:03 UTC
See attached build log.

(Please do not complain about the need for looking at the build log until you can provide an easy way to open bugs with the correct data picked out of a tinderbox log. Thanks.)
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-09 16:38:23 UTC
Created attachment 242061 [details]
Build log
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2010-08-12 11:09:40 UTC
Markos, looks like the patch you applied does not fix the issue:

*pidgin-2.7.2-r1 (05 Aug 2010)

  05 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
  +pidgin-2.7.2-r1.ebuild, +files/pidgin-2.7.2-ldflags.patch:
  Respect LDFLAGS wrt bug #329557

... or could you help me to undestand what it fixes?
Comment 3 Peter Volkov (RETIRED) gentoo-dev 2010-08-12 11:11:12 UTC
Ah, I see it fixes one binary... Could you fix another too, please? :) I'll post patch upstream after that. )
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2010-08-13 19:54:38 UTC
I can't reproduce it with 2.7.3 :-/
Comment 5 Peter Volkov (RETIRED) gentoo-dev 2010-08-16 12:51:51 UTC
(In reply to comment #4)
> I can't reproduce it with 2.7.3 :-/

Could you try with the following USE:

USE="dbus eds gstreamer gtk ncurses networkmanager nls perl prediction sasl spell startup-notification xscreensaver -debug -doc -gadu -gnutls -groupwise -idn -meanwhile -python -qq -silc -tcl -tk -zephyr -zeroconf"

?
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2010-08-16 14:05:25 UTC
Created attachment 243217 [details, diff]
updated patch

Could you please try this patch? Seems to work for me
Comment 7 Peter Volkov (RETIRED) gentoo-dev 2010-08-19 07:05:02 UTC
nope. Unfortunately with new patch it's the same. :(
Comment 8 Peter Volkov (RETIRED) gentoo-dev 2010-09-02 12:56:56 UTC
Created attachment 245732 [details, diff]
pidgin-2.7.3-ldflags.patch

Markos, could you try this patch and tell me if it works for you?
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2010-09-03 13:36:02 UTC
It works fine
Comment 10 Peter Volkov (RETIRED) gentoo-dev 2010-09-15 13:55:28 UTC
Forwarded upstream. I'll add this patch with next version bump. I'm sure it will not take long time to wait.
Comment 11 Peter Volkov (RETIRED) gentoo-dev 2010-10-25 10:54:28 UTC
Fixed in 2.7.4.