Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 331585 - x11-libs/libqxt-0.6.0-r1: Multiple QA issues
Summary: x11-libs/libqxt-0.6.0-r1: Multiple QA issues
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard: [qting-edge]
Keywords: InOverlay
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2010-08-08 00:15 UTC by Markos Chandras (RETIRED)
Modified: 2010-08-20 09:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras (RETIRED) gentoo-dev 2010-08-08 00:15:32 UTC
This bug was filed via: http://gentoo.petteriraty.eu/stable.rss

Please stabilize =x11-libs/libqxt-0.6.0-r1
Comment 1 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-08-08 02:21:13 UTC
This is a first-time stabilization at least for x86. Please fix the following QA issues:

 * Messages for package x11-libs/libqxt-0.6.0-r1:

 * QA Notice: Pre-stripped files found:
 * /usr/lib/libQxtGui.so.0.6.0
 * /usr/lib/libQxtNetwork.so.0.6.0
 * /usr/lib/libQxtCore.so.0.6.0
 * /usr/lib/libQxtBerkeley.so.0.6.0
 * /usr/lib/qt4/plugins/designer/libQxtDesignerPlugins.so
 * QA Notice: The following files contain insecure RUNPATHs
 *  Please file a bug about this at http://bugs.gentoo.org/
 *  with the maintaining herd of the package.
 * /usr/lib/qt4:/var/tmp/portage/x11-libs/libqxt-0.6.0-r1/work/libqxt/lib usr/lib/libQxtGui.so.0.6.0
 * /usr/lib/qt4:/var/tmp/portage/x11-libs/libqxt-0.6.0-r1/work/libqxt/lib usr/lib/libQxtNetwork.so.0.6.0
 * /usr/lib/qt4:/var/tmp/portage/x11-libs/libqxt-0.6.0-r1/work/libqxt/lib usr/lib/libQxtCore.so.0.6.0
 * /usr/lib/qt4:/var/tmp/portage/x11-libs/libqxt-0.6.0-r1/work/libqxt/lib usr/lib/libQxtBerkeley.so.0.6.0
 * /usr/lib/qt4:/var/tmp/portage/x11-libs/libqxt-0.6.0-r1/work/libqxt/lib usr/lib/qt4/plugins/designer/libQxtDesignerPlugins.so
Comment 2 Davide Pesavento gentoo-dev 2010-08-09 09:43:51 UTC
Just from a quick look at the ebuild, shouldn't eqmake4 come *after* ./configure ?
Also, the ebuild should inherit multilib instead of eutils.
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2010-08-09 10:26:07 UTC
UnCC arches till we fix the ebuild

Davide, configure script runs qmake libqxt.pro -recursive

However, if I use

    eqmake4 ${PN}.pro \
        QXT_INSTALL_DOCS="/usr/share/doc/${PF}" \
        QXT_INSTALL_FEATURES="/usr/share/qt4/mkspecs/features " \
        -recursive

it seems like -recursive is not respected at all. Any thoughts?
Comment 4 Davide Pesavento gentoo-dev 2010-08-09 10:32:20 UTC
Try swapping the order of arguments so that -recursive comes before the two variables assignments, but after ${PN}.pro
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2010-08-09 10:34:22 UTC
Nope
Comment 6 Davide Pesavento gentoo-dev 2010-08-13 22:35:04 UTC
Ah! It relies on the cache! The configure writes various config values to .qmake.cache which is usually read by qmake at the beginning of the parsing. However eqmake4 always disables the cache when calling qmake, thus breaking the above procedure!

Unfortunately -nocache seems to have priority over -cache, so this issue is not fixable in the ebuild :(
Comment 7 Davide Pesavento gentoo-dev 2010-08-14 14:26:02 UTC
Nevermind, I've found a solution. I'll push an updated ebuild to qting-edge later.
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2010-08-14 14:36:31 UTC
(In reply to comment #7)
> Nevermind, I've found a solution. I'll push an updated ebuild to qting-edge
> later.
> 

Excellent. Please attach your patch here when you are ready so we can fix the ebuild on tree
Comment 9 Davide Pesavento gentoo-dev 2010-08-19 22:35:55 UTC
Sorry for the delay, I noticed some other issues with the current 0.6.0-r1 ebuild in portage that I wanted to fix, and I've been very busy in the last few days so it took quite some time to properly fix everything.

I just committed a rewritten live ebuild to qting-edge and subsequently revbumped 0.6.0 applying the same improvements there too. Please read the git commit message for details.

Don't forget the new patch and the updated metadata.xml when moving 0.6.0-r2 to portage! :)
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2010-08-19 23:12:11 UTC
Thank you very much Davide

I will try to review the new ebuild and commit it to portage as soon as possible
Comment 11 Markos Chandras (RETIRED) gentoo-dev 2010-08-20 09:27:09 UTC
+*libqxt-0.6.0-r2 (20 Aug 2010)
+
+  20 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+  +libqxt-0.6.0-r2.ebuild, metadata.xml:
+  Revbump to fix issues reported on bug #331585. New use flags, Adjusted
+  qt-assistant dependency, switched to qt4-r2 and EAPI=3, use systems'
+  qdoc3, fix arguments when crypt use flag was enabled. Many thanks to
+  Davide Pesavento <davidepesa@gmail.com> for his work, patches,review and
+  testing
+