Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 330991 - x11-drivers/xf86-video-nouveau: X freezes
Summary: x11-drivers/xf86-video-nouveau: X freezes
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-03 09:15 UTC by kavol
Modified: 2010-09-28 11:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg logs from some of the freezes (xorglogs.tgz,23.07 KB, application/octet-stream)
2010-08-03 09:17 UTC, kavol
Details
.config (.config,55.92 KB, text/plain)
2010-08-29 06:23 UTC, kavol
Details
dmesg (dmesg,108.41 KB, text/plain)
2010-08-29 06:41 UTC, kavol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kavol 2010-08-03 09:15:45 UTC
Hi,

recently (don't know exactly since which update) my X started to freeze quite often. The system is okay, I can ssh onto it, but everything dealing with X just hangs - I can't even use Ctrl+Alt+Fx to switch to text console.

Killing and trying to start X server again does not help, the screen is stuck, I have to reboot the whole system.

Reproducible: Sometimes

Steps to Reproduce:
There's no exact reproducer. It happened several times when trying to scroll a page in Konqueror using the mouse wheel, once after trying to switch to another desktop, once without any action (I left for a while and found it frozen after getting back), etc.



I guess this report would fit nicely into some upstream bugzilla, but I really do not know which component causes this - is it the kernel, X server, nouveau?
And it happens to me just with Gentoo, running Fedora with nouveau seems fine ...

$ emerge --info
Portage 2.1.8.3 (default/linux/amd64/10.0/no-multilib, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.34-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5_CPU_750_@_2.67GHz-with-gentoo-1.12.13
Timestamp of tree: Tue, 03 Aug 2010 08:30:01 +0000
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="cs"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac alsa amd64 berkdb bzip2 cli cracklib crypt cups cxx dbus dri encode exif ffmpeg flac fortran gallium gdbm gif iconv jingle jpeg jpeg2k kde kerberos kvm lzma mad mikmod mmx mng modules mp3 mp4 mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png pppd python qt3support qt4 readline reflection scrobbler sdl session spell spl sse sse2 ssl ssse3 svg symlink sysfs tiff truetype unicode usb vorbis x264 xcomposite xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"                                                  
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 kavol 2010-08-03 09:17:32 UTC
Created attachment 241223 [details]
Xorg logs from some of the freezes
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2010-08-03 15:37:47 UTC
I don't see a bug, just a problem you have no resolution for. Please reopen this bug report once 1) you have gone through our usual support channels <http://forums.gentoo.org/> or perhaps <irc://chat.freenode.net/#gentoo>, 2) you have found a genuine bug that we can fix.
Comment 3 kavol 2010-08-03 19:15:43 UTC
(In reply to comment #2)
> I don't see a bug,

then go see an optician :-)

this one looks very similar (particularly that comment #18): https://bugzilla.redhat.com/show_bug.cgi?id=538563#c18
- and it seems that Fedora developers see it clearly there is *some* bug ...

but this one happens on Gentoo (and Fedora seems okay for me), so I'm here and not contributing to that one (+ that one is for Intel and this for nVidia)

> just a problem you have no resolution for.

yeah, of course, if I had a resolution, I'd have sent the patch to the maintainers of the software that causes the problem, not bothering your excellency ...

> Please reopen this bug report once 1) you have gone through our usual support
> channels <http://forums.gentoo.org/> or perhaps <irc://chat.freenode.net/#gentoo>,

a) since when the forum or irc channel serve as an bugtracker?

b) you fail clearly state that fact in the docs, or even the Gentoo www front page

so ... please do not close this bug for "not following the protocol" until

1) the b) is fixed

or 2) you at least report bug for fixing b) (and put me on CC)

> 2) you have found a genuine bug

yes, I have found a bug, see above

> that we can fix.

not sure if you can fix it ...

but at least you can properly triage it and pass it to the appropriate people

I'm not a C programmer, I won't do the developers job of reading the included backtrace of the problem - if you can't understand the backtrace either maybe you can ask help at your preferred support channel ;-) but I'm not seeking support, I'm reporting a bug
Comment 4 Wormo (RETIRED) gentoo-dev 2010-08-08 21:20:46 UTC
The similar Intel video infinite-loop bug reports you ran across ended up having a fix involving drm -- both userspace libdrm and drm kernel drivers. Please check your dmesg to see if there are any messages from drm kernel driver.
Comment 5 Wormo (RETIRED) gentoo-dev 2010-08-08 21:32:37 UTC
Sorry if I overlooked it, but I don't see where you mentioned version numbers of possibly involved packages: xorg-server, nouveau X driver, libdrm, mesa. Also mention whether it is integrated nouveau kernel modules or external modules from nouveau-drm package (if so what version?)

These bugs can be very specific to kernel and libdrm versions, so it would also be interesting to see a comparison of the working versions installed in your fedora vs the misbehaving versions installed in your gentoo.
Comment 6 kavol 2010-08-10 11:30:15 UTC
(In reply to comment #4)
> Please check your dmesg to see if there are any messages from drm kernel
> driver.

ok, I'll report back next time this happens

(In reply to comment #5)
> Sorry if I overlooked it, but I don't see where you mentioned version numbers
> of possibly involved packages: xorg-server, nouveau X driver, libdrm, mesa.

x11-base/xorg-server-1.8.2
x11-drivers/xf86-video-nouveau-0.0.16_pre20100615
x11-libs/libdrm-2.4.20-r1
media-libs/mesa-7.8.2

> Also mention whether it is integrated nouveau kernel modules or external
> modules from nouveau-drm package (if so what version?)

I use the kernel module - I've followed the settings at http://en.gentoo-wiki.com/wiki/Nouveau

(yeah, I know this is not officially supported and I'm not complaining - I'm just trying to test and report problems before they will have the chance to hit the users of "stable" ... well, it is not that unlikely that the problem is already present in "stable", for example, if we find it is libdrm's fault, the version 2.4.20-r1 was marked amd64 more than three weeks ago ...)

> These bugs can be very specific to kernel and libdrm versions, so it would also
> be interesting to see a comparison of the working versions installed in your
> fedora vs the misbehaving versions installed in your gentoo.

note that I boot Fedora from USB stick hence having x86 instead of x86_64 for more compatibility with netbooks, if that matters ...

xorg-x11-server-Xorg-1.8.2-2.fc13.i686
xorg-x11-drv-nouveau-0.0.16-7.20100423git13c1043.fc13.i686
libdrm-2.4.21-2.fc13.i686
mesa-dri-drivers-7.8.1-8.fc13.i686

and the kernel is
kernel-PAE-2.6.33.6-147.2.4.fc13.i686

(well, interesting, how this can work if the abovementioned wikipage says I need at least 2.6.34? - some custom patching of the older version in Fedora?)
Comment 7 Wormo (RETIRED) gentoo-dev 2010-08-10 19:14:47 UTC
(In reply to comment #6)
> (In reply to comment #4)
> > Please check your dmesg to see if there are any messages from drm kernel
> > driver.
> 
> ok, I'll report back next time this happens

Hm, could also check your /var/log/syslog from last week to see if any drm kernel messages got saved there... 
Comment 8 kavol 2010-08-11 10:44:12 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #4)
> > > Please check your dmesg to see if there are any messages from drm kernel
> > > driver.
> > 
> > ok, I'll report back next time this happens
> 
> Hm, could also check your /var/log/syslog from last week to see if any drm
> kernel messages got saved there... 

not sure if there is the full output which goes to dmesg, but I've tried to grep previous messages (I don't have /var/log/syslog) for 'drm' and seems there is nothing related to the X freeze, just the initialisation:

...
Aug  2 09:37:32 kavol kernel: [   20.772164] [drm] nouveau 0000:07:00.0: nouveau_channel_alloc: initialised FIFO 3
Aug  3 10:30:17 kavol kernel: [    0.551664] [drm] Initialized drm 1.1.0 20060810
Aug  3 10:30:17 kavol kernel: [    5.078992] [drm] nouveau 0000:07:00.0: Detected an NV50 generation card (0x0a8280a2)
Aug  3 10:30:17 kavol kernel: [    5.082567] [drm] nouveau 0000:07:00.0: Attempting to load BIOS image from PRAMIN
Aug  3 10:30:17 kavol kernel: [    5.153370] [drm] nouveau 0000:07:00.0: ... appears to be valid
Aug  3 10:30:17 kavol kernel: [    5.153372] [drm] nouveau 0000:07:00.0: BIT BIOS found
Aug  3 10:30:17 kavol kernel: [    5.153373] [drm] nouveau 0000:07:00.0: Bios version 70.18.2d.00
Aug  3 10:30:17 kavol kernel: [    5.153374] [drm] nouveau 0000:07:00.0: Pointer to BIT loadval table invalid
Aug  3 10:30:17 kavol kernel: [    5.153376] [drm] nouveau 0000:07:00.0: TMDS table revision 2.0 not currently supported
Aug  3 10:30:17 kavol kernel: [    5.153378] [drm] nouveau 0000:07:00.0: Found Display Configuration Block version 4.0
Aug  3 10:30:17 kavol kernel: [    5.153379] [drm] nouveau 0000:07:00.0: Raw DCB entry 0: 01000302 00020030
Aug  3 10:30:17 kavol kernel: [    5.153381] [drm] nouveau 0000:07:00.0: Raw DCB entry 1: 02000300 00000000
Aug  3 10:30:17 kavol kernel: [    5.153383] [drm] nouveau 0000:07:00.0: Raw DCB entry 2: 02011362 0f220010
Aug  3 10:30:17 kavol kernel: [    5.153384] [drm] nouveau 0000:07:00.0: Raw DCB entry 3: 01022310 00020010
Aug  3 10:30:17 kavol kernel: [    5.153385] [drm] nouveau 0000:07:00.0: Raw DCB entry 4: 0000000e 00000000
Aug  3 10:30:17 kavol kernel: [    5.153387] [drm] nouveau 0000:07:00.0: DCB connector table: VHER 0x40 5 16 4
Aug  3 10:30:17 kavol kernel: [    5.153389] [drm] nouveau 0000:07:00.0:   0: 0x00001030: type 0x30 idx 0 tag 0x07
Aug  3 10:30:17 kavol kernel: [    5.153390] [drm] nouveau 0000:07:00.0:   1: 0x00102161: type 0x61 idx 1 tag 0x08
Aug  3 10:30:17 kavol kernel: [    5.153392] [drm] nouveau 0000:07:00.0:   2: 0x00000200: type 0x00 idx 2 tag 0xff
Aug  3 10:30:17 kavol kernel: [    5.153398] [drm] nouveau 0000:07:00.0: Parsing VBIOS init table 0 at offset 0xD0E7
Aug  3 10:30:17 kavol kernel: [    5.195431] [drm] nouveau 0000:07:00.0: 0xD43D: Condition still not met after 20ms, skipping following opcodes
Aug  3 10:30:17 kavol kernel: [    5.216401] [drm] nouveau 0000:07:00.0: 0xD441: Condition still not met after 20ms, skipping following opcodes
Aug  3 10:30:17 kavol kernel: [    5.216427] [drm] nouveau 0000:07:00.0: Parsing VBIOS init table 1 at offset 0xD66C
Aug  3 10:30:17 kavol kernel: [    5.226379] [drm] nouveau 0000:07:00.0: Parsing VBIOS init table 2 at offset 0xE13E
Aug  3 10:30:17 kavol kernel: [    5.226389] [drm] nouveau 0000:07:00.0: Parsing VBIOS init table 3 at offset 0xE173
Aug  3 10:30:17 kavol kernel: [    5.270994] [drm] nouveau 0000:07:00.0: Parsing VBIOS init table 4 at offset 0xE326
Aug  3 10:30:17 kavol kernel: [    5.270998] [drm] nouveau 0000:07:00.0: Parsing VBIOS init table at offset 0xE38B
Aug  3 10:30:17 kavol kernel: [    5.291262] [drm] nouveau 0000:07:00.0: 0xE38B: Condition still not met after 20ms, skipping following opcodes
Aug  3 10:30:17 kavol kernel: [    5.291279] [drm] nouveau 0000:07:00.0: 0xC01A: parsing output script 0
Aug  3 10:30:17 kavol kernel: [    5.291282] [drm] nouveau 0000:07:00.0: 0xC01A: parsing output script 0
Aug  3 10:30:17 kavol kernel: [    5.291292] [drm] nouveau 0000:07:00.0: Detected 512MiB VRAM
Aug  3 10:30:17 kavol kernel: [    5.487116] [drm] nouveau 0000:07:00.0: 512 MiB GART (aperture)
Aug  3 10:30:17 kavol kernel: [    5.487867] [drm] nouveau 0000:07:00.0: Allocating FIFO number 1
Aug  3 10:30:17 kavol kernel: [    5.500178] [drm] nouveau 0000:07:00.0: nouveau_channel_alloc: initialised FIFO 1
Aug  3 10:30:17 kavol kernel: [    5.501758] [drm] nouveau 0000:07:00.0: Detected a TMDS output
Aug  3 10:30:17 kavol kernel: [    5.501760] [drm] nouveau 0000:07:00.0: Detected a DAC output
Aug  3 10:30:17 kavol kernel: [    5.501761] [drm] nouveau 0000:07:00.0: Detected a TMDS output
Aug  3 10:30:17 kavol kernel: [    5.501762] [drm] nouveau 0000:07:00.0: Detected a DAC output
Aug  3 10:30:17 kavol kernel: [    5.501764] [drm] nouveau 0000:07:00.0: Detected a DVI-I connector
Aug  3 10:30:17 kavol kernel: [    5.501785] [drm] nouveau 0000:07:00.0: Detected a HDMI connector
Aug  3 10:30:17 kavol kernel: [    5.501800] [drm] nouveau 0000:07:00.0: Detected a VGA connector
Aug  3 10:30:17 kavol kernel: [    5.680361] [drm] nouveau 0000:07:00.0: allocated 1280x1024 fb: 0x40250000, bo ffff880136797a00
Aug  3 10:30:17 kavol kernel: [    5.682290] [drm] nouveau 0000:07:00.0: 0x7489: parsing clock script 0
Aug  3 10:30:17 kavol kernel: [    5.685151] [drm] Initialized nouveau 0.0.16 20090420 for 0000:07:00.0 on minor 0
Aug  3 10:30:23 kavol kernel: [   20.464021] [drm] nouveau 0000:07:00.0: Allocating FIFO number 2
Aug  3 10:30:23 kavol kernel: [   20.478504] [drm] nouveau 0000:07:00.0: nouveau_channel_alloc: initialised FIFO 2
Aug  3 10:30:23 kavol kernel: [   20.575925] [drm] nouveau 0000:07:00.0: Allocating FIFO number 3
Aug  3 10:30:23 kavol kernel: [   20.590285] [drm] nouveau 0000:07:00.0: nouveau_channel_alloc: initialised FIFO 3
Aug  4 21:14:31 kavol kernel: [124933.720352] [drm] nouveau 0000:07:00.0: Allocating FIFO number 4
...
Comment 9 kavol 2010-08-13 11:47:31 UTC
it happened again and now there is interesting output in dmesg ...

note tham meanwhile there was nouveau update to x11-drivers/xf86-video-nouveau-0.0.16_pre20100807

[13641.815151] BUG: unable to handle kernel NULL pointer dereference at 0000000000000028
[13641.815156] IP: [<ffffffffa003ba57>] ttm_bo_pci_offset+0x67/0x90 [ttm]
[13641.815163] PGD 134866067 PUD 134ffd067 PMD 0 
[13641.815166] Oops: 0000 [#1] SMP 
[13641.815167] last sysfs file: /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/idProduct
[13641.815169] CPU 3 
[13641.815170] Modules linked in: tun dm_mod nouveau cdc_ether usbnet firewire_ohci ttm drm_kms_helper firewire_core cfbcopyarea cfbimgblt crc_itu_t cfbfillrect
[13641.815177] 
[13641.815180] Pid: 3643, comm: X Tainted: G        W  2.6.34-gentoo-r1 #1 P55M Pro/To Be Filled By O.E.M.
[13641.815181] RIP: 0010:[<ffffffffa003ba57>]  [<ffffffffa003ba57>] ttm_bo_pci_offset+0x67/0x90 [ttm]
[13641.815185] RSP: 0018:ffff8801340eb8d8  EFLAGS: 00010206
[13641.815187] RAX: 0000000000000000 RBX: ffff8801340ebb68 RCX: ffff8801340eb900
[13641.815188] RDX: ffff8801340eb8f0 RSI: ffff8801340ebb68 RDI: ffff8801335800e8
[13641.815190] RBP: ffff8801340eb8d8 R08: ffff8801340eb8f8 R09: 0000000000000002
[13641.815191] R10: 0000000000000100 R11: 00000000dd95f000 R12: ffff8801335800e8
[13641.815193] R13: ffff8801340eb9e8 R14: 0000000000000002 R15: 0000000000000000
[13641.815195] FS:  00007f56dda39840(0000) GS:ffff880001ac0000(0000) knlGS:0000000000000000
[13641.815196] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[13641.815198] CR2: 0000000000000028 CR3: 0000000134b62000 CR4: 00000000000006e0
[13641.815199] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[13641.815201] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[13641.815203] Process X (pid: 3643, threadinfo ffff8801340ea000, task ffff8801367227c0)
[13641.815204] Stack:
[13641.815205]  ffff8801340eb938 ffffffffa003eb51 ffff880134ee0230 00000000d0000000
[13641.815207] <0> 0000000000000000 000000000d950000 0000000000000246 ffff88000d8b7e00
[13641.815209] <0> ffff8801340ebb68 0000000000000000 ffff8801335800e8 0000000000000000
[13641.815212] Call Trace:
[13641.815216]  [<ffffffffa003eb51>] ttm_mem_reg_ioremap+0x41/0xd0 [ttm]
[13641.815220]  [<ffffffffa003f30b>] ttm_bo_move_memcpy+0x9b/0x540 [ttm]
[13641.815228]  [<ffffffffa0069240>] ? nouveau_fence_wait+0x60/0xd0 [nouveau]
[13641.815233]  [<ffffffffa0069004>] ? nouveau_fence_unref+0x24/0x40 [nouveau]
[13641.815238]  [<ffffffffa006889c>] ? nouveau_bo_move_m2mf+0x43c/0x570 [nouveau]
[13641.815244]  [<ffffffffa0068a49>] nouveau_bo_move+0x79/0x550 [nouveau]
[13641.815247]  [<ffffffff810d6229>] ? unmap_mapping_range+0x119/0x130
[13641.815250]  [<ffffffffa003cad8>] ttm_bo_handle_move_mem+0x128/0x3c0 [ttm]
[13641.815254]  [<ffffffffa003db83>] ttm_bo_move_buffer+0x113/0x130 [ttm]
[13641.815257]  [<ffffffffa003dc32>] ttm_bo_validate+0x92/0x130 [ttm]
[13641.815262]  [<ffffffffa00695c7>] validate_list+0xa7/0x2c0 [nouveau]
[13641.815268]  [<ffffffffa006a68c>] nouveau_gem_ioctl_pushbuf+0x62c/0x1140 [nouveau]
[13641.815272]  [<ffffffff8126fffd>] drm_ioctl+0x1bd/0x480
[13641.815277]  [<ffffffffa006a060>] ? nouveau_gem_ioctl_pushbuf+0x0/0x1140 [nouveau]
[13641.815281]  [<ffffffff81106048>] vfs_ioctl+0x38/0xd0
[13641.815283]  [<ffffffff8110667a>] do_vfs_ioctl+0x8a/0x5a0
[13641.815285]  [<ffffffff81106c11>] sys_ioctl+0x81/0xa0
[13641.815289]  [<ffffffff8148fb49>] ? do_device_not_available+0x9/0x10
[13641.815291]  [<ffffffff81028cab>] system_call_fastpath+0x16/0x1b
[13641.815293] Code: 44 38 0c a8 01 75 1d 45 85 c9 74 10 a8 08 75 0c f6 46 22 01 74 0e 66 0f 1f 44 00 00 31 c0 c9 c3 0f 1f 40 00 48 8b 06 49 c1 e2 07 <48> 8b 40 28 48 c1 e0 0c 48 89 01 48 8b 46 10 48 c1 e0 0c 49 89 
[13641.815310] RIP  [<ffffffffa003ba57>] ttm_bo_pci_offset+0x67/0x90 [ttm]
[13641.815313]  RSP <ffff8801340eb8d8>
[13641.815314] CR2: 0000000000000028
[13641.815317] ---[ end trace 4eaa2a86a8e2da24 ]---
Comment 10 kavol 2010-08-14 07:06:38 UTC
(In reply to comment #9)
> it happened again and now there is interesting output in dmesg ...

disregard this - it seems to be another problem (with the same symptomes, I could ssh into the machine) ... a few minutes ago, I've experienced another freeze, and there is nothing interesting in dmesg
Comment 11 Wormo (RETIRED) gentoo-dev 2010-08-17 01:50:40 UTC
Ok well you've tried long enough to collect kernel messages; now it's time to let the maintainers take a look and request further info as needed -- assigning to xorg/libdrm maintainers and cc-ing nouveau maintainer
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-08-17 15:53:23 UTC
Can you try with a more recent kernel? For example gentoo-sources-2.6.35-r1 (but not 2.6.35.2, which is seriously broken)
Comment 13 Rémi Cardona gentoo-dev 2010-08-18 21:38:42 UTC
Please get back to us.

Thanks
Comment 14 kavol 2010-08-28 07:42:42 UTC
(In reply to comment #12)
> Can you try with a more recent kernel? For example gentoo-sources-2.6.35-r1
> (but not 2.6.35.2, which is seriously broken)

ok, I've tried 2.6.35-gentoo-r4

also the nouveau driver got updated meanwhile -
x11-drivers/xf86-video-nouveau-0.0.16_pre20100819

but today it happened again - and it was after trying to scroll a page in Konqueror with mouse wheel, it seems to be the action which triggers the problem most often

at the end of Xorg log there is the same error:

[171278.406] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[171278.406] 
Backtrace:
[171278.450] 0: /usr/bin/X (xorg_backtrace+0x28) [0x461018]
[171278.450] 1: /usr/bin/X (mieqEnqueue+0x1eb) [0x45b4bb]
[171278.450] 2: /usr/bin/X (xf86PostMotionEventP+0xc8) [0x46cdd8]
[171278.450] 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7fcf0283c000+0x40bf) [0x7fcf028400bf]
[171278.450] 4: /usr/bin/X (0x400000+0x6b477) [0x46b477]
[171278.450] 5: /usr/bin/X (0x400000+0x111029) [0x511029]
[171278.450] 6: /lib/libpthread.so.0 (0x7fcf06e87000+0xf010) [0x7fcf06e96010]
[171278.450] 7: /lib/libc.so.6 (ioctl+0x7) [0x7fcf05ec6b97]
[171278.450] 8: /usr/lib/libdrm.so.2 (drmIoctl+0x23) [0x7fcf0447ceb3]
[171278.450] 9: /usr/lib/libdrm.so.2 (drmCommandWrite+0x1b) [0x7fcf0447d13b]
[171278.450] 10: /usr/lib/libdrm_nouveau.so.1 (0x7fcf03e3e000+0x31ed) [0x7fcf03e411ed]
[171278.450] 11: /usr/lib/libdrm_nouveau.so.1 (nouveau_bo_map_range+0xff) [0x7fcf03e4139f]
[171278.451] 12: /usr/lib/libdrm_nouveau.so.1 (0x7fcf03e3e000+0x2449) [0x7fcf03e40449]
[171278.451] 13: /usr/lib/libdrm_nouveau.so.1 (nouveau_pushbuf_flush+0x187) [0x7fcf03e40817]
[171278.451] 14: /usr/lib64/xorg/modules/libexa.so (0x7fcf037db000+0x9a51) [0x7fcf037e4a51]
[171278.451] 15: /usr/lib64/xorg/modules/libexa.so (0x7fcf037db000+0xa62a) [0x7fcf037e562a]
[171278.451] 16: /usr/bin/X (0x400000+0xd61cb) [0x4d61cb]
[171278.451] 17: /usr/lib64/xorg/modules/libexa.so (0x7fcf037db000+0xb8c5) [0x7fcf037e68c5]
[171278.451] 18: /usr/bin/X (0x400000+0xd5bda) [0x4d5bda]
[171278.451] 19: /usr/bin/X (0x400000+0xcad9d) [0x4cad9d]
[171278.451] 20: /usr/bin/X (0x400000+0x53b1c) [0x453b1c]
[171278.451] 21: /usr/bin/X (0x400000+0x24c25) [0x424c25]
[171278.451] 22: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7fcf05e1bbbd]
[171278.451] 23: /usr/bin/X (0x400000+0x247d9) [0x4247d9]

I don't see anything relevant in dmesg/messages (except for the ssh authorization, the last messages are 10 minutes older than the freeze)

there is one thing new, now after X restart, the screen is not stuck with the last picture, but it gets garbled ... I still need to do reboot (hardware reset), I can't get back to text console or do anything locally
Comment 15 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-08-28 20:52:15 UTC
Please also attach kernel config and dmesg output.
Comment 16 kavol 2010-08-29 06:23:27 UTC
Created attachment 245199 [details]
.config
Comment 17 kavol 2010-08-29 06:41:39 UTC
Created attachment 245200 [details]
dmesg

(not after the freeze)
Comment 18 Robin Lutz 2010-09-25 23:11:08 UTC
here is the bug in the freedesktop bugzilla:

https://bugs.freedesktop.org/show_bug.cgi?id=26980

as a summary:
they need to do some microcode reverse engeneering to see what is causing the problem. (these newer cards have a microcontroler that is taking care about powermanagement)

and the "[mi] EQ overflowing." thing is only a result of a result of a result of the issue. maybe you have another bug. this is for NVA3+ cards (see the freedesktop bugzilla for details)
Comment 19 kavol 2010-09-28 11:09:54 UTC
(In reply to comment #18)
> here is the bug in the freedesktop bugzilla:
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=26980

thanks that's it!

so this is in nouveau, really not Gentoo specific => upstream

(hm, I don't see any field here to fill in the external bug reference?)