Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 330123 - stabilize =media-sound/ncmpcpp-0.5.4
Summary: stabilize =media-sound/ncmpcpp-0.5.4
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Jeroen Roovers (RETIRED)
URL: http://unkart.ovh.org/ncmpcpp/
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2010-07-27 21:45 UTC by Mike Limansky
Modified: 2010-12-15 20:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Limansky 2010-07-27 21:45:19 UTC
Please stabilize =media-sound/mpd-0.5.4. The ebuild is in tree for a more than month, and there are no bugs. Also, as you can see from the project page, the previous versions can delete user data:

"ATTENTION: Feature, that allows you to physically remove directories from your disk while being in browser is BROKEN IN ALL VERSIONS < 0.5.4 and may, under some random circumstances, cause UNWANTED DELETION OF OTHER FILES. It needs to be manually enabled in configuration file though, so if you don't use it, you're fine. Otherwise you should upgrade to 0.5.4 or higher version immediately."

Reproducible: Always

Steps to Reproduce:
Comment 1 Samuli Suominen gentoo-dev 2010-07-27 22:33:07 UTC
odd bug. mpd-0.15.8 is current stable, closing...
Comment 2 Mike Limansky 2010-07-28 06:40:01 UTC
Hi,

  Why the bug summary was changed? I raise the bug about ncmpcpp, no mpd. I am sorry if I make a mistake in description and write mpd instead of ncmpcpp, but the summary was right, and the link is correct.
Comment 3 Mike Limansky 2010-07-28 06:42:12 UTC
hm.. I've checked bug activity.. seems like I have to sleep more.. sorry.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2010-07-28 12:21:07 UTC
Arch teams, please test and stabilise:
=media-sound/ncmpcpp-0.5.4
Target KEYWORDS="amd64 hppa x86"
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2010-07-28 12:32:06 UTC
Raising Severity because of the possibility of data loss.
Comment 6 Thomas Kahle (RETIRED) gentoo-dev 2010-07-28 13:20:47 UTC
Archtested on x86. Everything fine. A minor beautification would be bug 330219, but that should not block stabilization. 
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2010-07-28 13:40:16 UTC
Stable for HPPA.
Comment 8 Christian Faulhammer (RETIRED) gentoo-dev 2010-07-29 08:12:12 UTC
stable x86, thanks Thomas
Comment 9 Alex Alexander (RETIRED) gentoo-dev 2010-07-29 08:28:31 UTC
amd64 stable, closing.