Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 329871 - media-video/vlc-1.1.1 - /bin/grep: /usr/lib64/libpng12.la: No such file or directory
Summary: media-video/vlc-1.1.1 - /bin/grep: /usr/lib64/libpng12.la: No such file or di...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 333673 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-26 06:39 UTC by Anish
Modified: 2010-08-20 18:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,105.97 KB, text/plain)
2010-07-26 06:40 UTC, Anish
Details
environment (environment,160.95 KB, text/plain)
2010-07-26 06:41 UTC, Anish
Details
info (info,txt,4.04 KB, text/plain)
2010-07-26 06:41 UTC, Anish
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anish 2010-07-26 06:39:55 UTC
* ERROR: media-video/vlc-1.1.1 failed:
 *   died running emake, base_src_make
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 4243:  Called base_src_compile
 *   environment, line  836:  Called base_src_make
 *   environment, line  874:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "died running emake, $FUNCNAME";
 * 
 * If you need support, post the output of 'emerge --info =media-video/vlc-1.1.1',
 * the complete build log and the output of 'emerge -pqv =media-video/vlc-1.1.1'.
 * The complete build log is located at '/var/tmp/portage/media-video/vlc-1.1.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-1.1.1/temp/environment'.
 * S: '/var/tmp/portage/media-video/vlc-1.1.1/work/vlc-1.1.1'
Comment 1 Anish 2010-07-26 06:40:40 UTC
Created attachment 240181 [details]
build.log
Comment 2 Anish 2010-07-26 06:41:03 UTC
Created attachment 240183 [details]
environment
Comment 3 Anish 2010-07-26 06:41:23 UTC
Created attachment 240185 [details]
info
Comment 4 Anish 2010-07-26 06:42:32 UTC
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.11.2-r0, 2.6.34-gentoo-r2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.34-gentoo-r2-x86_64-Intel-R-_Core-TM-_i3_CPU_M_330_@_2.13GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 26 Jul 2010 05:15:03 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -msse4 -mcx16 -msahf"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=core2 -msse4 -mcx16 -msahf"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.twaren.net/Linux/Gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cleartype cli consolekit corefonts cpudetection cracklib crypt cups cxx dbus djvu dri dts dvd dvdr embedded emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm gstreamer gtk hal iconv ipv6 java jpeg jpeg2k kde lame laptop lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg msn mudflap multilib musepack mysql ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd prediction python qt3support qt4 quicktime rar readline reflection sdl session speex spell spl sql sse sse2 ssl ssse3 ssse4 startup-notification svg symlink sysfs tcpd theora tiff truetype type1 udev unicode usb vcd vorbis webkit x264 xcb xml xorg xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2010-07-26 11:13:14 UTC
Looks like some packages on your system still think libpng-1.2 is the next big thing, while libpng has in the mean time been upgraded to 1.4. Please run lafilefixer and then revdep-rebuild to get rid of the old references. There is no bug.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2010-08-20 18:09:34 UTC
*** Bug 333673 has been marked as a duplicate of this bug. ***