Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 329517 - dev-lang/python-2.6.5-r3: regression from r2 in urllib2 auth basic logins
Summary: dev-lang/python-2.6.5-r3: regression from r2 in urllib2 auth basic logins
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-23 02:37 UTC by Mark Karpeles
Modified: 2010-10-27 12:42 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Karpeles 2010-07-23 02:37:23 UTC
The problem in http://bugs.python.org/issue8797 seems to be happening with dev-lang/python-2.6.5-r3. Downgrading to dev-lang/python-2.6.5-r2 fixes the issue.

Reproducible: Always

Steps to Reproduce:
Confirmed with mercurial:
1. Fetch a repository with a limited number of revisions
2. go in the repository dir
3. hg pull to get the rest of the revisions
Actual Results:  
$ hg pull
http authorization required
realm: Mercurial Dev
user: *
password: 
pulling from (url)
searching for changes
abort: authorization failed

Expected Results:  
$ hg pull
http authorization required
realm: Mercurial Dev
user: *
password: 
pulling from (url)
searching for changes
adding changesets
adding manifests
adding file changes
added 21 changesets with 20 changes to 2 files
(run 'hg update' to get a working copy)

Tested on two gentoo boxes with mercurial-1.6.
Comment 1 Jory A. Pratt gentoo-dev 2010-07-24 03:19:31 UTC
This is officially breaking packages such as wicd and others.
Comment 2 Jory A. Pratt gentoo-dev 2010-07-25 19:19:54 UTC
*** Bug 329683 has been marked as a duplicate of this bug. ***
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-09 17:58:20 UTC
And we have fun again, with blind backports...
Comment 4 Brian Harring gentoo-dev 2010-08-09 18:15:49 UTC
Question is, what's the level of impact for pruning 2.6.5-r3?  Note this is not my preferred option either, but if it's breaking mainline versions we've got issues.
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-09 18:20:48 UTC
It was stable for security bug #325593 ... rather than pruning we need a -r4 that only fixes the security issue and not backports the hell of the rest of stuff, and then ask an immediate stable to arch teams.
Comment 6 Brian Harring gentoo-dev 2010-08-09 19:00:39 UTC
(In reply to comment #5)
> It was stable for security bug #325593 ... rather than pruning we need a -r4
> that only fixes the security issue and not backports the hell of the rest of
> stuff, and then ask an immediate stable to arch teams.

2.6.5-r2 uses python-gentoo-patches-2.6.5-r5.tar.bz2, which includes as it's first a patch a file named 00_all_branch_backports.patch ...

Scanning what's on the mirrors, python-gentoo-patches-2.6.5-r3 is the earliest I can find, and that too includes the 00_all-branch_backports, weighing in at a hefty 223k.  Delta wise, it's a comparably managable 2k insertions, 935 deletions- w/ roughly half of that contained in tests.
Comment 7 Jory A. Pratt gentoo-dev 2010-08-12 17:53:45 UTC
*** Bug 332393 has been marked as a duplicate of this bug. ***
Comment 8 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-08-13 15:55:14 UTC
The change in urllib2 is a partially incompatible bug fix, not regression. This change is included in Python 2.7 and will be included in Python 2.6.6, which will be released in next week. Reverse dependencies need to be adapted to new behavior of urllib2.
Comment 9 Christoph Junghans gentoo-dev 2010-08-18 14:56:32 UTC
This patch for mercurial should solve the issue:
http://hg.intevation.org/mercurial/crew/rev/6c51a5056020

It will come with mercurial 1.6.3
Comment 10 Christoph Junghans gentoo-dev 2010-08-30 19:13:49 UTC
fixed in mercurial-1.6.3 (at least for me)
Comment 11 Dirkjan Ochtman gentoo-dev 2010-10-27 12:42:53 UTC
This has been fixed in 2.6.6, so this can be closed.