Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 328965 - net-misc/nxserver-freenx doesn't play well with openssl-1.0.0a
Summary: net-misc/nxserver-freenx doesn't play well with openssl-1.0.0a
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-19 14:40 UTC by Helmut Jarausch
Modified: 2010-07-19 20:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Jarausch 2010-07-19 14:40:26 UTC
After upgrading to openssl-1.0.0a I had to re-emerge net-misc/nxserver-freenx
and net-misc/nx. After that I couldn't connect to my remote machine via nxclient.
After many, many tries and googling I've found out that in /etc/nxserver/node.conf the command
# The tool to generate md5sums with
#COMMAND_MD5SUM="openssl md5"

doesn't work anymore. If I replace this with
COMMAND_MD5SUM="md5sum"

it works again. This seems to be an older error, see
https://bugzilla.redhat.com/show_bug.cgi?id=521090



Reproducible: Always
Comment 1 Bernard Cafarelli gentoo-dev 2010-07-19 15:14:57 UTC
How nice of them...

Thanks for the report! I've added -r5 to tree which falls back to md5sum, and blocked openssl 1.0 in current stable
Comment 2 Helmut Jarausch 2010-07-19 16:05:39 UTC
(In reply to comment #1)
> How nice of them...
> 
> Thanks for the report! I've added -r5 to tree which falls back to md5sum, and
> blocked openssl 1.0 in current stable
> 

I should have added that
 openssl md5
might work but generates different output then before (see the redhat bug report)
Comment 3 Bernard Cafarelli gentoo-dev 2010-07-19 20:06:46 UTC
Yes it prepends the source file name now, while it behaved like md5sum before

FWIW, with the configuration file you can probably set a command that works ("openssl md5 -r" could work, but only with openssl 1.0), but at least setting back to md5sum makes sure it works for all versions, and does not change a lot