Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 32890 - k3b 0.10.1 doesnt make audio cds from mp3s
Summary: k3b 0.10.1 doesnt make audio cds from mp3s
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2003-11-06 10:11 UTC by Rincewind
Modified: 2004-06-07 15:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rincewind 2003-11-06 10:11:15 UTC
after upgrading to k3b 0.10.1 I wasnt able to burn an audio projekt from mp3 files. 
the erroro message was "unsupported format". 
K3b emerged without errors and i tried to remege it several times with only 
machr=i386 -O2 but that didnt change anything. 
After downgrading to 0.10.0 everything works fine. 

Reproducible: Always
Steps to Reproduce:

Portage 2.0.49-r15 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r8, 2.6.0-test9) 
System uname: 2.6.0-test9 i686 AMD Athlon(tm) XP 
Gentoo Base System version 
CFLAGS="-mcpu=athlon-xp -mfpmath=sse,387 -msse -mmmx -m3dnow -O2 -pipe 
-s -funroll-loops -fno-strict-aliasing" 
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/
share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.2/share/config /usr/kde/3.1/share/
config /usr/share/config" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d" 
CXXFLAGS="-mcpu=athlon-xp -mfpmath=sse,387 -msse -mmmx -m3dnow -O2 
-pipe -s -funroll-loops -fno-strict-aliasing" 
FEATURES="sandbox autoaddcvs ccache buildpkg" 
USE="x86 oss apm avi crypt cups encode foomaticdb gif jpeg libg++ mad mikmod 
mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv zlib directfb 
alsa gdbm berkdb slang readline arts aalib svga tcltk java guile X sdl gpm tcpd pam 
libwww ssl perl python esd imlib oggvorbis gnome gtk qt kde motif opengl mozilla 
cdr samba scanner 3dnow acpi acpi4linux amd dv dvb dvd dvdr fbcon ffmpeg gtk2 
gtkhtml imagemagick imap ipv6 javascript jikes joystick lcms mbox nptl 
moznocompose moznoxft mmx tiff transcode usb xine xinerama xvid"
Comment 1 Gregorio Guidi (RETIRED) gentoo-dev 2003-11-06 11:13:39 UTC
Take a look at Settings -> Plugins and see if you have an audio decoder for
mp3 (it should be there if you compiled against libmad (mad USE flag)).
Can you play mp3s from k3b?
Comment 2 Gregorio Guidi (RETIRED) gentoo-dev 2003-11-06 11:13:50 UTC
Take a look at Settings -> Plugins and see if you have an audio decoder for
mp3 (it should be there if you compiled against libmad (mad USE flag)).
Can you play mp3s from k3b?
Comment 3 Rincewind 2003-11-06 11:19:10 UTC
I didnt change my useflags from 10.0 > 10.1 and back to 10.0 again and yes
i could play mp3 inside k3b.
Comment 4 Nicolai Lissner 2003-11-07 09:53:43 UTC
Problem existed here, too - when I started k3b it told me it would not find
some libs - it searched for them in /usr/lib - but actually they are in /usr/kde3.1/lib

That means: 

for name in /usr/kde/3.1/lib/libk3b* ; do ln -s $name /usr/lib ; done

fixes this. (actually i haven't digged deeper for the cause of this yet -
there might be better fixes - but this one works fine)
Comment 5 Caleb Tennis (RETIRED) gentoo-dev 2003-11-12 09:33:01 UTC
0.10.2 is out now, you may want to check that.
Comment 6 Andrea Cerrito 2003-11-19 17:29:41 UTC
The bug persist.
Comment 7 Andrea Cerrito 2003-12-05 09:23:55 UTC
Even in 0.10.3.
Comment 8 Dennis Cheung 2003-12-15 18:49:09 UTC
the script:

for name in /usr/kde/3.1/lib/libk3b* ; do ln -s $name /usr/lib ; done

worked for me
Comment 9 Heinrich Wendel (RETIRED) gentoo-dev 2004-01-27 06:19:26 UTC
please try a fresh k3b 0.11 installation
Comment 10 Heinrich Wendel (RETIRED) gentoo-dev 2004-02-09 12:24:07 UTC
please test it with 0.11.1
Comment 11 Rincewind 2004-02-21 04:01:09 UTC
solved with k3b 011 versions
Comment 12 FieldySnuts 2004-06-07 15:08:45 UTC
I am seeing this issue with k3b-0.11.10

Others have reported this recently:

Other forums entries were along the lines of including the mad USE flag, but i have that anyway.