Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 328793 - dev-lang/perl-5.12.1 fails test (op/filetest.t)
Summary: dev-lang/perl-5.12.1 fails test (op/filetest.t)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 331055 (view as bug list)
Depends on:
Blocks: perl-5.12.1
  Show dependency tree
 
Reported: 2010-07-18 09:00 UTC by Xake
Modified: 2015-02-07 14:31 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (dev-lang:perl-5.12.1:20100718-084707.log,908.17 KB, text/plain)
2010-07-18 09:01 UTC, Xake
Details
minimal example (328793.pl,231 bytes, text/plain)
2010-08-03 19:24 UTC, Torsten Veller (RETIRED)
Details
build.log (perl-5.20.1-r4:20150207-141318.log,487.68 KB, text/plain)
2015-02-07 14:31 UTC, abandoned account
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xake 2010-07-18 09:00:51 UTC
I get the following when trying to merge perl:


op/filetest_t.t ................................................... ok  
===(   30833;4    0/942  10/24    0/942  10/11  672/?  0/?  1352... )===ACCESS DENIED  open_rd:      ../lib/lib/Config_heavy.pl
ISE:write_logfile unable to append logfile
ISE open_rd(../lib/Config_heavy.pl): Permission denied
	abs_path: ../lib/lib/Config_heavy.pl
	res_path: ../lib/lib/Config_heavy.pl
/usr/lib/libsandbox.so(+0x3342)[0x254bd3ba342]
/usr/lib/libsandbox.so(+0x33d3)[0x254bd3ba3d3]
/usr/lib/libsandbox.so(+0x4cd6)[0x254bd3bbcd6]
/usr/lib/libsandbox.so(open64+0xbd)[0x254bd3c1a3d]
/var/tmp/portage/dev-lang/perl-5.12.1/work/perl-5.12.1/libperl.so.5.12(PerlIOUnix_open+0xa3)[0x254bd7b1943]
/var/tmp/portage/dev-lang/perl-5.12.1/work/perl-5.12.1/libperl.so.5.12(PerlIOBuf_open+0xc7)[0x254bd7af987]
/var/tmp/portage/dev-lang/perl-5.12.1/work/perl-5.12.1/libperl.so.5.12(PerlIO_openn+0x202)[0x254bd7b0672]
/var/tmp/portage/dev-lang/perl-5.12.1/work/perl-5.12.1/libperl.so.5.12(PerlIO_open+0x44)[0x254bd7b0834]
/var/tmp/portage/dev-lang/perl-5.12.1/work/perl-5.12.1/libperl.so.5.12(+0x16b786)[0x254bd737786]
/var/tmp/portage/dev-lang/perl-5.12.1/work/perl-5.12.1/libperl.so.5.12(+0x16b7d4)[0x254bd7377d4]
/proc/13029/cmdline: ./perl -I.. -MTestInit op/filetest.t 

op/filetest.t ..................................................... No subtests run 


Portage 2.2_rc67 (hardened/linux/amd64/10.0, gcc-4.4.4, glibc-2.11.2-r0, 2.6.34-hardened x86_64)
=================================================================
System uname: Linux-2.6.34-hardened-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 17 Jul 2010 14:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb -mtune=native"
DISTDIR="/var/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.sunet.se/pub/os/Linux/distributions/gentoo"
INSTALL_MASK="*.la"
LANG="sv_SE.UTF-8"
LC_ALL="C"
LDFLAGS="-Wl,--as-needed -Wl,-O1 -Wl,--sort-common -Wl,--warn-once,--hash-style=gnu"
LINGUAS="sv en"
MAKEOPTS="-j10 -l10"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/var/overlays/layman/java-overlay /var/overlays/layman/hardened-development /var/overlays/layman/gamerlay /var/overlays/layman/x11 /var/overlays/mine"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa amd64 amr amrnb amrwb applet archive asyncns avahi bash-completion bluetooth branding bzip2 cairo ccache cdaudio cdda cdr cleartype cli consolekit coverart cracklib crypt cups cxx dbus device-mapper devicekit devkit dhcpcd digitalradio dirac djvu dmraid dri dts dvd dvdr dvi eds encode eselect evo exif faac faad fat fbcondecor ffmpeg fftw flac fontconfig fuse gdbm gdm gdu gif gimp glib gmp gnome gnome-keyring gphoto2 gpm grammar graphite gsf gsm gstreamer gtk gudev hal hardened hpn ical iconv iconvacl icq icu id3tag idn ieee1394 iptc jabber jack java6 jingle jpeg jpeg2k justify kate kvm lcms libffi libnotify libsamplerate logrotate lvm lvm2 lzma mad maps math matroska md mdadm midi mms mmx mmxext mng moonlight mp2 mp3 mpeg mpi msn mtp mudflap multilib musepack musicbrainz nautilus ncurses network-cron networkmanager nfs nls nntp nptl nptlonly ntfs offensive ogg openal opencore-amr opengl openmp openntpd ots pam pango parted pcre pdf perl pic pidgin playlist png policykit pppd pulseaudio python quicktime raw readline reflection rrdcgi rtmp samba sensord session smp sms speex spell spl sse sse2 ssl ssse3 startup-notification subversion svg sysfs test tex theora thesaurus threads tiff totem truetype udev unicode upnp urandom usb userlocales v4l2 vaapi vdpau vhook videos vim-syntax vorbis vpx webkit wmf x264 xcb xcomposite xmp xmpp xorg xrandr xscreensaver xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="sv en" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Xake 2010-07-18 09:01:35 UTC
Created attachment 239225 [details]
build.log
Comment 2 Torsten Veller (RETIRED) gentoo-dev 2010-08-03 15:26:20 UTC
*** Bug 331055 has been marked as a duplicate of this bug. ***
Comment 3 Torsten Veller (RETIRED) gentoo-dev 2010-08-03 19:24:02 UTC
Created attachment 241307 [details]
minimal example

I can confirm with FEATURES=-userpriv.

Attached is a condensed example. If I uncomment the first print there is no sandbox violation.
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-06-12 12:06:44 UTC
This version of perl was removed from the tree. I can't confirm this bug in new versions of perl.

Closed.

Re-open, if we have questions.
Comment 5 abandoned account 2015-02-07 14:31:53 UTC
Created attachment 395788 [details]
build.log

reporting here because of this line:
 * Test fails with a sandbox error (#328793) if run as root. Skipping tests...


...
 * Removing /var/tmp/portage/dev-lang/perl-5.20.1-r4/image/ from /var/tmp/portage/dev-lang/perl-5.20.1-r4/image/usr/lib/perl5/5.20.1/x86_64-linux/Config.pm...
>>> Completed installing perl-5.20.1-r4 into /var/tmp/portage/dev-lang/perl-5.20.1-r4/image/


 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * pp_sys.c:4302:5: warning: implicit declaration of function 'getpgid' [-Wimplicit-function-declaration]

 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: http://www.perl.org/
 * ERROR: dev-lang/perl-5.20.1-r4::gentoo failed:
 *   install aborted due to severe warnings shown above
 * 
 * Call stack:
 *   misc-functions.sh, line 558:  Called install_qa_check
 *   misc-functions.sh, line 181:  Called source 'install_symlink_html_docs'
 *      90gcc-warnings, line 165:  Called gcc_warn_check
 *      90gcc-warnings, line 159:  Called die
 * The specific snippet of code:
 *   				has stricter ${FEATURES} && \
 *   					die "install aborted due to severe warnings shown above"
 * 
 * If you need support, post the output of `emerge --info '=dev-lang/perl-5.20.1-r4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/perl-5.20.1-r4::gentoo'`.
 * The complete build log is located at '/var/log/portage/ebuild.logs/build/dev-lang/perl-5.20.1-r4:20150207-141318.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-lang/perl-5.20.1-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/perl-5.20.1-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/perl-5.20.1-r4/image'
 * S: '/var/tmp/portage/dev-lang/perl-5.20.1-r4/work/perl-5.20.1'
!!! post install failed; exiting.

>>> Failed to emerge dev-lang/perl-5.20.1-r4, Log file:

>>>  '/var/log/portage/ebuild.logs/build/dev-lang/perl-5.20.1-r4:20150207-141318.log'

 * Messages for package dev-lang/perl-5.20.1-r4:

 * UPDATE THE PERL MODULES:
 * After updating dev-lang/perl you must reinstall
 * the installed perl modules.
 * Use: perl-cleaner --all
 * Test fails with a sandbox error (#328793) if run as root. Skipping tests...
 * ERROR: dev-lang/perl-5.20.1-r4::gentoo failed:
 *   install aborted due to severe warnings shown above
 * 
 * Call stack:
 *   misc-functions.sh, line 558:  Called install_qa_check
 *   misc-functions.sh, line 181:  Called source 'install_symlink_html_docs'
 *      90gcc-warnings, line 165:  Called gcc_warn_check
 *      90gcc-warnings, line 159:  Called die
 * The specific snippet of code:
 *   				has stricter ${FEATURES} && \
 *   					die "install aborted due to severe warnings shown above"
 * 
 * If you need support, post the output of `emerge --info '=dev-lang/perl-5.20.1-r4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/perl-5.20.1-r4::gentoo'`.
 * The complete build log is located at '/var/log/portage/ebuild.logs/build/dev-lang/perl-5.20.1-r4:20150207-141318.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-lang/perl-5.20.1-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/perl-5.20.1-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/perl-5.20.1-r4/image'
 * S: '/var/tmp/portage/dev-lang/perl-5.20.1-r4/work/perl-5.20.1'


# emerge --info '=dev-lang/perl-5.20.1-r4::gentoo'
Portage 2.2.14 (python 2.7.9-final-0, hardened/linux/uclibc/amd64, gcc-4.9.2, uclibc-0.9.33.2-r13, 3.18.5-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.18.5-hardened-x86_64-AMD_A6-3400M_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.2
KiB Mem:     8169268 total,   5646388 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Thu, 05 Feb 2015 00:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.9.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/uclibc:          0.9.33.2-r13
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-gentoo-linux-uclibc"
CFLAGS="-O2 -pipe -march=native -Wstack-protector -fstack-protector-all"
CHOST="x86_64-gentoo-linux-uclibc"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -Wstack-protector -fstack-protector-all"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs cgroup collision-protect config-protect-if-modified distlocks downgrade-backup ebuild-locks fakeroot fixlafiles force-mirror ipc-sandbox keeptemp keepwork merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install prelink-checksums preserve-libs sandbox sfperms split-elog split-log strict stricter test unknown-features-warn unmerge-backup unmerge-logs userfetch usersandbox webrsync-gpg"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
INSTALL_MASK="/lib/systemd /lib32/systemd /lib64/systemd /usr/lib/systemd /usr/lib32/systemd /usr/lib64/systemd /etc/systemd"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://127.0.0.3/"
USE="3dnow 3dnowext X amd64 bindist btrfs cli cracklib crypt cscope cxx dri gpm hardened iconv libav mmx mmxext modules ncurses nptl openmp pax_kernel pcre pic pie readline session sse sse2 sse3 ssl ssp strong-security tcpd uclibc xattr zlib" ABI_X86="64" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 sse3" ELIBC="uclibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="dummy fbdev v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



the relevant part from the build.log is:
make[1]: Leaving directory '/var/tmp/portage/dev-lang/perl-5.20.1-r4/work/perl-5.20.1/x2p'
 
        Everything is up to date. Type 'make test' to run test suite.
>>> Source compiled.
>>> Test phase: dev-lang/perl-5.20.1-r4
 * Test fails with a sandbox error (#328793) if run as root. Skipping tests...
>>> Completed testing dev-lang/perl-5.20.1-r4

>>> Install perl-5.20.1-r4 into /var/tmp/portage/dev-lang/perl-5.20.1-r4/image/ category dev-lang