Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 328537 - dev-lang/perl-5.12.1 fails tests (op/while_readdir.t)
Summary: dev-lang/perl-5.12.1 fails tests (op/while_readdir.t)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: perl-testfailure perl-5.12.1
  Show dependency tree
 
Reported: 2010-07-16 08:05 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2013-12-23 17:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (perl-5.12.1:20100715-191126.log,1.14 MB, text/plain)
2010-07-16 08:08 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-07-16 08:05:16 UTC
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.5.0-asneeded, glibc-2.11.2-r0, 2.6.34.1 i686)
=================================================================
System uname: Linux-2.6.34.1-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.1
Timestamp of tree: Thu, 15 Jul 2010 18:30:10 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 2.7, 3.1.2-r4
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.4_p6-r1, 1.5-r1, 1.6.3-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.5.0
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/lib/tomoyo/conf /usr/share/X11/xkb /usr/share/bufrtables /usr/share/config /usr/share/qpsmtpd/plugins /var/bind /var/lib/hsqldb /var/phxd /var/qmail/alias /var/qmail/control /var/spool/torque /var/vpopmail/etc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree-tinderbox"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap ncurses nls nostatic nptl nptlonly openmp pam pcre perl pppd python qt3support readline reflection ruby session spl ssl sysfs tcpd unicode vhosts x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest cgi" ELIBC="glibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18 jruby ruby19 ree18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-07-16 08:08:00 UTC
Created attachment 239005 [details]
Build log
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2010-07-16 11:25:27 UTC
It looks like more than just a test failure to me, looks like install failure.
Its a failure also that it proceeds to install even after 'test' has returned a failure code.

Sampled some of the line that look relevant to me to make it easier for others to work out:


op/ver.t .......................................................... ok

===(   74316;13  791/942  709/942   188/1452  10906/?  5/5  10/2... )===# Failed at op/while_readdir.t line 73

===(   74392;13  797/942  714/942   188/1452  10922/?  5/5  10/2... )===
                                                                        

op/while_readdir.t ................................................ Failed 1/10 subtests 

===(   74428;13  801/942  717/942   188/1452  10927/?  5/5  10/2... )===

../lib/FindBin.t .................................................. ok

===(  136202;152   6/16    384/10837 )==================================
===(  136297;152   6/16    478/10837  1/4 )=============================Unquoted string "c" may clash with future reserved word at _h2ph_pre.ph line 162.
Compilation failed in require at lib/h2ph.pht line 1.
Compilation failed in require at -e line 1.

                                                                        

../lib/h2ph.t ..................................................... ok

Test Summary Report
-------------------
op/stash.t                                                      (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   26
op/while_readdir.t                                              (Wstat: 0 Tests: 10 Failed: 1)
  Failed test:  6
Files=1805, Tests=357666, 182 wallclock secs (66.39 usr 12.36 sys + 508.06 cusr 58.40 csys = 645.21 CPU)
Result: FAIL
make: *** [test_harness] Error 1



 require Encode::ConfigLocal;
Can't require Encode::ConfigLocal: Can't locate Encode/ConfigLocal.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.1/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.12.1 /usr/lib/perl5/vendor_perl/5.12.1/i686-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.1 /usr/lib/perl5/5.12.1/i686-linux-thread-multi /usr/lib/perl5/5.12.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl .) at (eval 61) line 1.

 * Converting C header files to the corresponding Perl format ...
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-64.h: No such file or directory
Can't open gnu/stubs-64.h: No such file or directory
Can't open gnu/stubs-64.h: No such file or directory
Can't open gnu/stubs-64.h: No such file or directory
Use of "goto" to jump into a construct is deprecated at /usr/bin/h2ph line 349, <IN> line 12820.
Use of "goto" to jump into a construct is deprecated at /usr/bin/h2ph line 349, <IN> line 12869.
Use of "goto" to jump into a construct is deprecated at /usr/bin/h2ph line 349, <IN> line 12963.
Use of "goto" to jump into a construct is deprecated at /usr/bin/h2ph line 349, <IN> line 13012.
Use of "goto" to jump into a construct is deprecated at /usr/bin/h2ph line 349, <IN> line 13321.
Use of "goto" to jump into a construct is deprecated at /usr/bin/h2ph line 349, <IN> line 13370.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-07-16 11:38:21 UTC
test-fail-continue is designed to work that way, otherwise the tinderbox would have 1% of the packages installing
Comment 4 Torsten Veller (RETIRED) gentoo-dev 2010-07-16 12:44:40 UTC
(In reply to comment #2)
> # Failed at op/while_readdir.t line 73

> op/while_readdir.t ................................................ Failed 1/10
> subtests 

> op/while_readdir.t                                              (Wstat: 0
> Tests: 10 Failed: 1)
>   Failed test:  6

 27 opendir my $dirhandle, '.'
 28     or die "Failed test: unable to open directory: $!\n";
 29 
 30 my @dir = readdir $dirhandle;
 31 rewinddir $dirhandle;
 32 

 67 {
 68     my @list;
 69     my $sub = sub{
 70         push @list, $_;
 71     };
 72     $sub->($_) while readdir $dirhandle;
 73     ok( eq_array( \@dir, \@list ), '$sub->($_) while readdir' );
 74     rewinddir $dirhandle;
 75 }




| * Generating ConfigLocal.pm (ignore any error) ...
                               ^^^^^^^^^^^^^^^^
This has always been in there. If someone wants to tackle it, fame and fortune are waiting

>  require Encode::ConfigLocal;
> Can't require Encode::ConfigLocal: Can't locate Encode/ConfigLocal.pm in @INC
> (@INC contains: /usr/lib/perl5/site_perl/5.12.1/i686-linux-thread-multi
> /usr/lib/perl5/site_perl/5.12.1
> /usr/lib/perl5/vendor_perl/5.12.1/i686-linux-thread-multi
> /usr/lib/perl5/vendor_perl/5.12.1 /usr/lib/perl5/5.12.1/i686-linux-thread-multi
> /usr/lib/perl5/5.12.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl .) at
> (eval 61) line 1.




>  * Converting C header files to the corresponding Perl format ...
> Can't open machine/ansi.h: No such file or directory
> Can't open sys/_types.h: No such file or directory
> Can't open gnu/stubs-64.h: No such file or directory

h2ph is dumb (See the BUGS section in h2ph.1).
We could hide it or add another comment "Ignore missing headers..."
Or do not create the Perl headers at all.



> Use of "goto" to jump into a construct is deprecated at /usr/bin/h2ph line 349,
> <IN> line 12820.

h2ph should be fixed to not use deprecated constructs *shrug*
Comment 5 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-12-23 17:00:56 UTC
5.12.1 no longer in the tree. I can't reproduce it on new versions