Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 328489 - lxde-base/lxappearance-0.4.0 does not close properly, have to use killall
Summary: lxde-base/lxappearance-0.4.0 does not close properly, have to use killall
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2010-07-15 22:31 UTC by Marcus Schätzle
Modified: 2010-07-16 10:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Schätzle 2010-07-15 22:31:44 UTC
lxappearance does not close properly when I close its window, the windows is indeed closed but lxappearance remains active as a process, so I have to use killall. I don't use LXDE, but openbox with some Xfce components, lxappearance is the only LXDE component I use. I tried with Lubuntu, and lxappearance is closing properly there. The remaining lxappearance process doesn't "go wild" and uses much cpu time and memory, but it simply remains active.

Reproducible: Always

Steps to Reproduce:
1. Start lxappearance
2. Close lxappearance via closing the window
3. Check via pidof if lxappearance is still active

Actual Results:  
lxappearance window is closed, but the process isn't

Expected Results:  
lxappearance process should have been terminated

Output of emerge --info:

Portage (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r1 i686)
System uname: Linux-2.6.34-gentoo-r1-i686-Intel-R-_Core-TM-2_Quad_CPU_Q9505_@_2.83GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 15 Jul 2010 15:30:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests collision-protect distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS=" rsync:// rsync:// rsync:// rsync:// rsync://"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl acpi alsa berkdb bzip2 cairo cleartype cli consolekit cracklib crypt cups cxx dbus dri dvd ffmpeg flac fortran gdbm gif glitz gpm gtk hal iconv ipv6 java jpeg jpeg2k mmx modules mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre perl png policykit pppd pulseaudio python readline reflection sdl session spl sse sse2 ssl ssse3 svg symlink sysfs tcpd theora tiff truetype unicode vorbis x264 x86 xcb xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vmware vesa svga fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Marcus Schätzle 2010-07-16 08:43:04 UTC
I wanted to test this now with a test installation of LXDE inside Gentoo (not just others like Lubuntu). The issue is not happening inside LXDE, it happens only when I run lxappearance outside an LXDE session, in my case when I start an openbox session via startx.
I am not sure if this bugreport should better be done upstream then, but I leave it here for now, since I did not have any such comparison (starting lxappearance outside and inside an lxde session) with another distribution yet.
Comment 2 Marcus Schätzle 2010-07-16 08:55:19 UTC
OK I saw now that there is an option for an openbox session login inside Lubuntu and I could reproduce the bug there. So this is something for upstream and I set the status accordingly.