Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 328391 - Ebuild for Bitcoin
Summary: Ebuild for Bitcoin
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 10 votes (vote)
Assignee: Anthony Basile
URL: https://www.bitcoin.org/
Whiteboard: sunrise-suggested
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-15 13:19 UTC by Arsen Shnurkov
Modified: 2011-12-27 19:27 UTC (History)
30 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Bitcoin live build error (bitcoin-9999,6.39 KB, text/plain)
2011-01-13 00:19 UTC, Samu Voutilainen
Details
Bitcoin 0.3.21 ebuild (bitcoin-0.3.21.ebuild,3.91 KB, text/plain)
2011-05-14 11:04 UTC, Myckel Habets
Details
Updated Makefile starting bitcoin-0.3.21 (Makefile.gentoo,1.67 KB, text/plain)
2011-05-14 11:05 UTC, Myckel Habets
Details
New Makefile.gentoo for bitcoin (Makefile.gentoo,1.70 KB, application/octet-stream)
2011-05-19 11:27 UTC, Rune Juhl
Details
net-p2p/wxbitcoin-0.3.22.ebuild (wxbitcoin-0.3.22.ebuild,2.39 KB, text/plain)
2011-06-12 00:03 UTC, Luke-Jr
Details
net-p2p/bitcoind-0.3.22 (bitcoind-0.3.22.ebuild,2.39 KB, text/plain)
2011-06-12 00:03 UTC, Luke-Jr
Details
files/Makefile.gentoo (Makefile.gentoo,1.75 KB, text/x-makefile)
2011-06-12 00:04 UTC, Luke-Jr
Details
Bitcoin 0.3.24 ebuild, needs new Makefile (bitcoin-0.3.24.ebuild,3.83 KB, text/plain)
2011-07-10 17:34 UTC, Myckel Habets
Details
Makefile for bitcoin-0.3.24 (Makefile.gentoo,1.62 KB, text/plain)
2011-07-10 17:35 UTC, Myckel Habets
Details
net-p2p/bitcoind-0.3.24 (bitcoind-0.3.24.ebuild,2.41 KB, text/plain)
2011-07-10 18:04 UTC, Luke-Jr
Details
net-p2p/wxbitcoin-0.3.24 (wxbitcoin-0.3.24.ebuild,2.41 KB, text/plain)
2011-07-10 18:05 UTC, Luke-Jr
Details
backtrace (bitcoin-qt.gdb.log,6.97 KB, text/plain)
2011-12-01 22:23 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arsen Shnurkov 2010-07-15 13:19:16 UTC
Description of software idea:
http://www.bitcoin.org/sites/default/files/bitcoin.pdf
Comment 1 redneb 2010-07-16 08:02:39 UTC
The biggest problem is that there is no configure script. You have to manually edit the makefile. Moreover, the makefile refers to wxGTK-2.9 which is the development version of wxGTK and it not available in portage. I tried to compiled it against wxGTK-2.8 but that didn't work.
Comment 2 Sergey 'L29Ah' Alirzaev 2010-07-17 10:35:37 UTC
http://github.com/l29ah/booboo/tree/master/net-p2p/bitcoin/ ← here you are
requires wxGTK:2.9 (i used the one from dirtyepic overlay)
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2010-07-17 17:13:02 UTC
Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Thanks,
On behalf of the Gentoo Sunrise Team,
Markos.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 4 Sergey 'L29Ah' Alirzaev 2010-07-17 19:31:52 UTC
(In reply to comment #3)
> Hello, The Gentoo Team would like to firstly thank you for your ebuild 
> submission. We also apologize for not being able to accommodate you in a timely
> manner. There are simply too many new packages.

thank you, mr. bot
i'd prefer the inclusion of booboo to `layman -L` ☺
Comment 5 Mizery De Aria 2010-07-18 07:55:37 UTC
Any assistance with producing svn ebuild is greatly appreciated. http://forums.gentoo.org/viewtopic-p-6348826.html#6348826
Comment 6 Sergey 'L29Ah' Alirzaev 2010-07-18 10:06:29 UTC
(In reply to comment #5)
> Any assistance with producing svn ebuild is greatly appreciated.
> http://forums.gentoo.org/viewtopic-p-6348826.html#6348826
> 
done
Comment 7 Myckel Habets 2010-09-12 16:09:08 UTC
An implementation of the ebuild exists at:
http://github.com/mizerydearia/bitcoin_gentoo_ebuild

I've worked on it (the non-live version) and it contains an init.d script for running it as daemon (gui is still possible). Please post issues with this ebuild here and I'll look at it.
Comment 8 Myckel Habets 2010-10-01 06:35:26 UTC
Pushed bitcoin-0.3.13 ebuild to github.
Comment 9 Myckel Habets 2010-10-21 21:48:27 UTC
Pushed bitcoin-0.3.14 ebuild to github.
Comment 10 Myckel Habets 2010-11-15 08:28:41 UTC
Pushed bitcoin-0.3.15 ebuild to github.
Comment 11 Matija "hook" Šuklje 2010-12-10 19:26:37 UTC
You might want to add ~amd64 to KEYWORDS. It works for me using the 0.3.15 ebuild from GitHub.
Comment 12 Myckel Habets 2010-12-10 19:37:17 UTC
(In reply to comment #11)
> You might want to add ~amd64 to KEYWORDS. It works for me using the 0.3.15
> ebuild from GitHub.
> 

I will do that with the next version of the ebuild (0.3.18 was released yesterday, no ebuild yet).
Comment 13 Myckel Habets 2011-01-09 19:55:51 UTC
I've been investigating a bug that causes bitcoind to segfault on hardened gentoo systems.(See http://www.bitcoin.org/smf/index.php?topic=2062.0 for details). Did anyone else experience this? Or has an idea how to fix it?
Comment 14 Myckel Habets 2011-01-09 20:57:24 UTC
Pushed the 0.3.19 ebuild to github. Now contains ~amd64 keyword.
Comment 15 Samu Voutilainen 2011-01-13 00:19:34 UTC
Created attachment 259671 [details]
Bitcoin live build error

(In reply to comment #14)
> Pushed the 0.3.19 ebuild to github. Now contains ~amd64 keyword.
>
Comment 16 Myckel Habets 2011-01-13 19:01:33 UTC
(In reply to comment #15)
> Created an attachment (id=259671) [details]
> Bitcoin live build error
> 
> (In reply to comment #14)
> > Pushed the 0.3.19 ebuild to github. Now contains ~amd64 keyword.
> > 
> 

Live ebuilds (the 9999 ebuild) can break. I only take care of the released ones (the ones that have source code tar balls and a version number).
Comment 17 Vaclav Dvorsky 2011-02-23 10:35:14 UTC
(In reply to comment #7)
> An implementation of the ebuild exists at:
> http://github.com/mizerydearia/bitcoin_gentoo_ebuild
> 
> I've worked on it (the non-live version) and it contains an init.d script for
> running it as daemon (gui is still possible). Please post issues with this
> ebuild here and I'll look at it.
> 

I try bitcoin-9999 from this overlay, but it contains outdated and incompatiblethe patches, ebuild bitcoin-git works good.
Comment 18 Myckel Habets 2011-02-26 07:59:50 UTC
(In reply to comment #17)
> (In reply to comment #7)
> 
> I try bitcoin-9999 from this overlay, but it contains outdated and
> incompatiblethe patches, ebuild bitcoin-git works good.
> 

That is the live ebuild. Live ebuilds tend to break (and I don't know if Mizerydearia is putting time in it to keep it working).

Just pushed the bitcoin-0.3.20.01 ebuild to github.

Comment 19 Myckel Habets 2011-03-19 17:44:34 UTC
Lets change the name a bit to reflect the status of this bug... Also we're not AMD64-only any more.
Comment 20 Erik Quaeghebeur 2011-03-23 21:46:07 UTC
(In reply to comment #18)
> Just pushed the bitcoin-0.3.20.01 ebuild to github.

I just tried installing it:
* it seems 0.3.20.01 does not have any keywords (not an insurmountable problem)
* it tells me:

A file listed in the Manifest could not be found: /usr/local/portage/net-p2p/bitcoin/files/bitcoin-http-json-rpc-bind-any.patch

(I got the ebuild in my local /usr/local/portage overlay by copying the net-p2p directory to it, which I got out of the tarball I downloaded from github.)
Comment 21 Myckel Habets 2011-03-24 06:05:01 UTC
(In reply to comment #20)
> (In reply to comment #18)
> > Just pushed the bitcoin-0.3.20.01 ebuild to github.
> 
> I just tried installing it:
> * it seems 0.3.20.01 does not have any keywords (not an insurmountable problem)

Oops, I guess they got lost.

> * it tells me:
> 
> A file listed in the Manifest could not be found:
> /usr/local/portage/net-p2p/bitcoin/files/bitcoin-http-json-rpc-bind-any.patch
> 
> (I got the ebuild in my local /usr/local/portage overlay by copying the net-p2p
> directory to it, which I got out of the tarball I downloaded from github.)

That ebuild doen't need that patch (I think it is used by the broken live ebuild). Make a new digest by doing "ebuild <ebuild_file_name> digest". That will fix it.
Comment 22 Mizery De Aria 2011-04-01 09:04:13 UTC
I am no longer contributing towards the ebuild for Bitcoin.  I do not have time or expertise for it.  I only established it to allow for 'properly' installing Bitcoin onto my gentoo linux environments, which I have accomplished.  Feel free to make it better.
Comment 23 Mizery De Aria 2011-04-01 10:23:33 UTC
Okay, maybe I changed my mind and that now can be considered april fools joke or whatever (originally unintended).  Anyhow, I just considered idea of establishing ebuilds for each of the clients at https://en.bitcoin.it/wiki/Category:Clients and will work on that.  Also, feel free to come to freenode #bitcoin-gentoo for collaborating
Comment 24 Myckel Habets 2011-05-14 11:04:36 UTC
Created attachment 273185 [details]
Bitcoin 0.3.21 ebuild

Updated ebuild to 0.3.21, use also the Makefile attached to this bug due to changes.
Comment 25 Myckel Habets 2011-05-14 11:05:19 UTC
Created attachment 273187 [details]
Updated Makefile starting bitcoin-0.3.21

Updated Makefile
Comment 26 Rune Juhl 2011-05-19 11:27:37 UTC
Created attachment 273937 [details]
New Makefile.gentoo for bitcoin

Added "-DBOOST_FILESYSTEM_DEPRECATED" to CXXFLAGS as per https://aur.archlinux.org/packages.php?ID=39313 .
Fixes compile error "ui.cpp:1584: error: 'class boost::filesystem3::path' has no member named 'native_file_string'" when compiling with use flag "+gui".
Comment 27 Florian Schmaus 2011-06-04 12:28:23 UTC
@Rune: I don't see a reference for the DBOOST CXX flag in the link you provided. Just curious why it's needed, because the ebuild compiles fine here on i686 and x64 without.

Also note that there is a Overlay including the latest bitcoin ebuilds and many other bitcoin related packages @ https://gitorious.org/bitcoin/gentoo 
Feel free to help developing the bitcoin ebuilds.
Comment 28 Matija "hook" Šuklje 2011-06-04 14:28:06 UTC
(In reply to comment #27)
> Also note that there is a Overlay including the latest bitcoin ebuilds and many
> other bitcoin related packages @ https://gitorious.org/bitcoin/gentoo 
> Feel free to help developing the bitcoin ebuilds.

Thanks for the link. Just added the Bitcoin overlay and the wxBitcoin client seems to work just fine.

Unless/until Portage starts offering an option to mask/keyword/whatever (in /etc/portage/package*) packages by overlay like e.g. Paludis does, I feel kinda twitchy when I see an overlay that uses stable arches.
Comment 29 Rune Juhl 2011-06-07 12:19:46 UTC
(In reply to comment #27)
> @Rune: I don't see a reference for the DBOOST CXX flag in the link you
> provided. Just curious why it's needed, because the ebuild compiles fine here
> on i686 and x64 without.

Hm, that's weird. I couldn't compile until I added the flag. The full reference:
"Comment by: magical on Sun, 08 May 2011 20:56:57 +0000

    I was able to build against boost-1.46 with the following modifications to makefile.archlinux:

    1. Change "-l boost_thread-mt" to "-l boost_thread"
    2. Add "-DBOOST_FILESYSTEM_DEPRECATED" to CCFLAGS"
 
> Also note that there is a Overlay including the latest bitcoin ebuilds and many
> other bitcoin related packages @ https://gitorious.org/bitcoin/gentoo 
> Feel free to help developing the bitcoin ebuilds.

Thanks!
Comment 30 Luke-Jr 2011-06-12 00:03:06 UTC
Created attachment 276715 [details]
net-p2p/wxbitcoin-0.3.22.ebuild

Latest version of wxbitcoin/bitcoind ebuilds from the overlay. Obsoletes all older attachments, but bugzilla won't let me flag them
Comment 31 Luke-Jr 2011-06-12 00:03:36 UTC
Created attachment 276717 [details]
net-p2p/bitcoind-0.3.22
Comment 32 Luke-Jr 2011-06-12 00:04:06 UTC
Created attachment 276719 [details]
files/Makefile.gentoo
Comment 33 Myckel Habets 2011-07-10 17:34:30 UTC
Created attachment 279657 [details]
Bitcoin 0.3.24 ebuild, needs new Makefile

Updated ebuild for Bitcoin-0.3.24. Needs a new Makefile (will be uploaded next).
Obsoleting all other attachments.
Comment 34 Myckel Habets 2011-07-10 17:35:27 UTC
Created attachment 279659 [details]
Makefile for bitcoin-0.3.24

This is the updated makefile.
Comment 35 Luke-Jr 2011-07-10 18:04:56 UTC
Created attachment 279665 [details]
net-p2p/bitcoind-0.3.24

Myckel, FYI the Bitcoin community has proper ebuilds already (in the 'bitcoin' overlay). bitcoind and wxbitcoin are separate by design, and the latter won't even exist with the upcoming 0.4 version.

Here's the current (0.3.24) bitcoind and wxbitcoin ebuilds...
Comment 36 Luke-Jr 2011-07-10 18:05:28 UTC
Created attachment 279667 [details]
net-p2p/wxbitcoin-0.3.24
Comment 37 Myckel Habets 2011-07-10 19:45:04 UTC
(In reply to comment #35)
> Created attachment 279665 [details]
> net-p2p/bitcoind-0.3.24
> 
> Myckel, FYI the Bitcoin community has proper ebuilds already (in the 'bitcoin'
> overlay). bitcoind and wxbitcoin are separate by design, and the latter won't
> even exist with the upcoming 0.4 version.

Yes, I'm aware of that. I always considered the overlay ebuilds bleeding edge and more targeted at ~ARCH instead of ARCH. Plus it does a few strange things that I not feel comfortable with (extra patch while upstream tarball works fine, 2 ebuilds for the same thing, too strict dependencies, vars in creating users and groups and a few other things).

Also, the ebuilds you just attached don't work without an updated Makefile compared to attachment 276719 [details] (missing build targets).

There are however a few things that I might take over when I'm going to give my ebuild a bit more TLC (has been lacking for some versions now, so it has collected some outdated stuff that can be removed).
Comment 38 Luke-Jr 2011-07-10 20:04:22 UTC
The overlay has both ARCH and ~ARCH versions. The "extra patches" are bugfixes, and one for a feature only enabled with a USE flag. bitcoind and wxbitcoin are *not* the same thing, nor share any build steps, and there is no reason to try to combine them.

Anyhow, the main point of my comment was that it'd be better to work on the existing ebuilds, rather than try to replace them from scratch creating numerous regressions the community has already addressed in the current ebuilds. :p
Comment 39 Dennis New 2011-08-13 13:22:49 UTC
A minor annoyance, but there seems to be an issue either with start-stop-daemon or bitcoind. When I try to init.d start it, I get:

bitcoind        | * Starting Bitcoin daemon ...
bitcoind        | * WARNING: -c/--chuid is deprecated and will be removed in the future, please use -u/--user instead
bitcoind        | * start-stop-daemon: caught an interrupt
bitcoind        | * start-stop-daemon: /usr/bin/bitcoind died                             [ !! ]
bitcoind        | * ERROR: bitcoind failed to start

... Although it does start -- so it's nothing serious.
Comment 40 Dennis New 2011-08-13 13:26:47 UTC
(I should add that my current init.d script, and ebuild, is from the gitorious.org/bitcoin/gentoo overlay :p)
Comment 41 Luke-Jr 2011-08-13 14:16:11 UTC
Try syncing. The latest init script uses --user instead of --chuid, and will give you a friendly/helpful error message when you have failed to configure bitcoind instead of that vague one :)

I also added a preliminary net-p2p/bitcoin-qt-9999 (which will replace wxbitcoin in 0.4) for testing.
Comment 42 Fabian Köster 2011-11-24 08:34:49 UTC
Any chance of getting bitcoin-0.5.0 into main portage tree? The version from the overlay works perfectly for me.
Comment 43 Dennis New 2011-11-25 13:14:40 UTC
Upgrading (from 0.3.24) to 0.5 corrupted my blockchain (I'm not exactly sure what is to blame), but otherwise, 0.5 works great on ~x86. It would be great to see it in portage.
Comment 44 Luke-Jr 2011-11-25 14:25:10 UTC
Be sure to report that upstream.
Comment 45 Dennis Schridde 2011-12-01 21:52:27 UTC
I just tried the overlay: It cointains live ebuilds with keywords. Afaik live ebuilds (-9999) should always have empty keywords, so the user has to explicitly select them.
Comment 46 Luke-Jr 2011-12-01 22:01:27 UTC
Fixed. Only ebuilds with only live versions contain keywords now. If you want to test/try the main-portage-tree prototypes, checkout the "maintree" branch.
Comment 47 Dennis Schridde 2011-12-01 22:23:08 UTC
Created attachment 294461 [details]
backtrace

bitcoin-qt crashes for me immediately at the start. Backtrace attached (the db_cxx libary contained no symbols, despite -g in CXXFLAGS).
Comment 48 Luke-Jr 2011-12-01 22:28:49 UTC
(In reply to comment #47)
> bitcoin-qt crashes for me immediately at the start. Backtrace attached (the
> db_cxx libary contained no symbols, despite -g in CXXFLAGS).

What are your CXXFLAGS? Probably best to move this to an upstream bug report, since it's not related to the ebuild: https://github.com/bitcoin/bitcoin/issues/new
Comment 49 Marcin Mirosław 2011-12-01 22:35:19 UTC
(In reply to comment #47)
> bitcoin-qt crashes for me immediately at the start. Backtrace attached (the
> db_cxx libary contained no symbols, despite -g in CXXFLAGS).

Debug symbols are stripped whike installing, you sholud use FEATURES=splitdebut to preserve them.
Comment 50 Dennis Schridde 2011-12-01 22:40:43 UTC
(In reply to comment #49)
> (In reply to comment #47)
> > bitcoin-qt crashes for me immediately at the start. Backtrace attached (the
> > db_cxx libary contained no symbols, despite -g in CXXFLAGS).
> 
> Debug symbols are stripped whike installing, you sholud use FEATURES=splitdebut
> to preserve them.
Did that. Turns out that apparently gdb still used the last version of the library and "forgot" to reload it. The bt actually attached contains info about db_cxx.
Comment 51 Dennis Schridde 2011-12-01 22:49:00 UTC
(In reply to comment #48)
> (In reply to comment #47)
> > bitcoin-qt crashes for me immediately at the start. Backtrace attached (the
> > db_cxx libary contained no symbols, despite -g in CXXFLAGS).
> 
> What are your CXXFLAGS? Probably best to move this to an upstream bug report,
> since it's not related to the ebuild:
> https://github.com/bitcoin/bitcoin/issues/new
https://github.com/bitcoin/bitcoin/issues/672

CFLAGS="-pipe -O2 -march=athlon64-sse3 -ftree-vectorize"
CXXFLAGS="${CFLAGS}"

Built as:
(. /etc/make.conf && FEATURES=splitdebug CFLAGS="${CFLAGS} -g" CXXFLAGS="${CXXFLAGS} -g" emerge -1 sys-libs/db net-p2p/bitcoin-qt)
Comment 52 Myckel Habets 2011-12-04 18:02:54 UTC
BTW, what does this eligius use flag/patch do? Nowhere I can find what it does, but seems to make some changes to the transaction fee calculation.
Comment 53 Luke-Jr 2011-12-04 18:08:43 UTC
It allows you to send transactions with lower fees accepted by the Eligius pool.
Comment 54 Anthony Basile gentoo-dev 2011-12-23 17:12:56 UTC
I was in the middle of writing a bitcoin ebuild when I came across the Luke's overlay.  I'll proxy maintain this.

@Luke, okay?
Comment 55 Anthony Basile gentoo-dev 2011-12-23 19:46:50 UTC
Okay net-p2p/bitcoind 0.4.2 and 0.5.1, net-p2p/bitcoin-qt-0.5.1 have been added to the tree.  I'll wait an bit and then close this bug as done.  If there are any problems with the versions on the tree, open up an new bug report.
Comment 56 Fabian Köster 2011-12-23 22:32:43 UTC
(In reply to comment #55)
> Okay net-p2p/bitcoind 0.4.2 and 0.5.1, net-p2p/bitcoin-qt-0.5.1 have been added
> to the tree.  I'll wait an bit and then close this bug as done.  If there are
> any problems with the versions on the tree, open up an new bug report.

net-p2p/bitcoin-qt-0.5.1 from tree seems to be good. Thanks for your work!
Comment 57 Anthony Basile gentoo-dev 2011-12-24 12:41:14 UTC
(In reply to comment #56)
> (In reply to comment #55)
> > Okay net-p2p/bitcoind 0.4.2 and 0.5.1, net-p2p/bitcoin-qt-0.5.1 have been added
> > to the tree.  I'll wait an bit and then close this bug as done.  If there are
> > any problems with the versions on the tree, open up an new bug report.
> 
> net-p2p/bitcoin-qt-0.5.1 from tree seems to be good. Thanks for your work!

Thank Luke, he did most of the work.  Anyhow, I tested bitcoin-qt and its running fine.  I got some free coins from the bitcoin faucet :)  Of course if anyone would also like to donate some coins I wouldn't refusee .... j/k

Closing this one.  Please don't reopen it if there's a problem, open a bug specific to the issue and we'll take care of it.
Comment 58 Frederik Schmid 2011-12-27 18:17:19 UTC
net-p2p/bitcoin-qt-0.5.1 fails for me:

>>> Source compiled.
>>> Test phase [not enabled]: net-p2p/bitcoin-qt-0.5.1

>>> Install bitcoin-qt-0.5.1 into /tmp/portage/net-p2p/bitcoin-qt-0.5.1/image/ category net-p2p
make -j3 INSTALL_ROOT=/tmp/portage/net-p2p/bitcoin-qt-0.5.1/image/ DESTDIR=/tmp/portage/net-p2p/bitcoin-qt-0.5.1/image/ install 
make: Nothing to be done for `install'.
install: cannot stat `/tmp/portage/net-p2p/bitcoin-qt-0.5.1/work/bitcoin-qt-0.5.1/doc/README': No such file or directory
!!! dodoc: /tmp/portage/net-p2p/bitcoin-qt-0.5.1/work/bitcoin-qt-0.5.1/doc/README does not exist


Portage 2.1.10.41 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 2.6.37.6 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.37.6-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 27 Dec 2011 01:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo kde-sunset
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -g -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.ing.umu.se/linux/gentoo/ http://trumpetti.atm.tut.fi/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-sunset"
SYNC="rsync://deadx/gentoo-portage"
USE="32bit X a52 aac accessibility acl acpi alisp alsa amd64 archive arts asf aspell audio audiofile avi berkdb bluetooth branding bzip2 bzlib cairo cdda cddb cdparanoia cdr cli codecs consolekit cracklib crypt cups curl cvs cxx dbus divx4linux dlloader dri dts dvd dvdr dvdread emboss encode exif extrafilters fam ffmpeg firefox flac fortran freetype gcj gdbm gdu geoip gif glib gpm gtk gtk2 handbook iconv imlib ipv6 java jpeg kde kipi lcms ldap libnotify lm_sensors logitech-mouse lzma mad matroska midi mime mjpeg mmx mng modplug modules motif mozbranding mozilla moznocompose moznoirc moznomail mozp3p mozplaintext mozsvg mp3 mp4 mpeg mpeg4 msn mudflap multilib multiuser musepack mysql ncurses network nis nls nptl nptlonly nsplugin ogg oggvorbis opengl openmp oscar oss pam pango pcap pcre pdf pdflib perl png policykit ppds pppd python qalculate qt qt3 qt3support qt4 quicktime raptor readline redland rss rtc samba sdl semantic-desktop session smbclient sndfile spell sse sse2 ssl ssse3 startup-notification subversion svg sysfs tcltk tcpd tetex theora threads threadsafe tiff truetype truetype-fonts type1-fonts udev udisks unicode upower usb v4l v4l2 vcd video virtuoso vorbis wma wma-fixed x264 xcb xine xml xml2 xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 59 Luke-Jr 2011-12-27 19:21:41 UTC
This bug is resolved. Please make new reports for new bugs.

This particular error was created by a recent change to the qt4-2 eclass. It affects packages other than bitcoin-qt (such as x11-libs/qt-mobility), so IMO it should be treated as a bug in the eclass.
Comment 60 Luke-Jr 2011-12-27 19:27:08 UTC
See bug 396227