Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 328327 - net-wireless/prism54-firmware-2.1.3 version bump (installs wrong firmware for recent kernels)
Summary: net-wireless/prism54-firmware-2.1.3 version bump (installs wrong firmware for...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mobile Herd (OBSOLETE)
URL: http://wireless.kernel.org/en/users/D...
Whiteboard:
Keywords:
: 328329 (view as bug list)
Depends on:
Blocks: 307767
  Show dependency tree
 
Reported: 2010-07-15 00:34 UTC by David J Cozatt
Modified: 2012-06-14 00:05 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
adjusted elog output as suggested in comment#3 (prism54-firmware-2.13.ebuild,1.46 KB, text/plain)
2011-07-09 19:31 UTC, David J Cozatt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David J Cozatt 2010-07-15 00:34:50 UTC
Prism54 is deprecated and the driver is in the kernel as p54. The firmware version that the current stable ebuild in portage installs will not working with any recent kernels. 

I keyworded it and it installed and worked 
ACCEPT_KEYWORDS="~amd64"

Was running stable and it installed the wrong firmware O-O firmware version installed for stable is for kernel 2.6.28 or less. 

Reproducible: Always



Expected Results:  
Expected to install firmware that would work with a current kernel
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2010-07-15 00:43:02 UTC
*** Bug 328329 has been marked as a duplicate of this bug. ***
Comment 2 David J Cozatt 2010-07-23 19:09:04 UTC
david@random ~ $ dmesg | grep p54
p54pci 0000:00:09.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
p54pci 0000:00:09.0: firmware: requesting isl3886pci
phy0: p54 detected a LM86 firmware
p54: rx_mtu reduced from 3240 to 2376
p54pci 0000:00:09.0: is registered as 'phy0'
david@random ~ $ dmesg | grep phy0
phy0: p54 detected a LM86 firmware
phy0: FW rev 2.13.12.0 - Softmac protocol 5.9
phy0: cryptographic accelerator WEP:YES, TKIP:YES, CCMP:YES
phy0: hwaddr xx.xx.xx.xx, MAC:isl3890 RF:Duette3
phy0: Selected rate control algorithm 'minstrel'
p54pci 0000:00:09.0: is registered as 'phy0'

david@random ~ $ dmesg | grep wlan0
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: authenticate with xxxxxxxxx (try 1)
wlan0: authenticated
wlan0: associate with xxxxxxxxxxx (try 1)
wlan0: RX AssocResp from xxxxxxxxxxxx (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Comment 3 David J Cozatt 2010-07-24 11:15:36 UTC
suggesting here a name change for the ebuild to p54-firmware
this would follow the name change the kernel has made for support

A link to the kernel webpage would be nice in the log say 

echo "see http://wireless.kernel.org/en/users/Drivers/p54 for supported devices"
Comment 4 David J Cozatt 2010-08-07 15:51:48 UTC
Current recommended firmware for the pci version @http://wireless.kernel.org/en/users/Drivers/p54#firmware

2.13.22.0.arm 

provided by ebuild is 

2.13.12.0.arm
Comment 5 David J Cozatt 2010-09-17 01:46:38 UTC
further note the firmware currently installed by the ebuild works with 
more cards than the newer version. Also wireless.kernel.org has stepped 
back the default firmware version since I reported there.
Comment 6 David J Cozatt 2010-12-15 14:20:32 UTC
setting summary to the version that needs to be stable and is working for me. Has been for months. My bad not reporting the version. Changelog does not mention keywording. 

04 Mar 2010; Fabio Erculiani <lxnay@gentoo.org>
  prism54-firmware-2.13.ebuild:
  move elog calls to preinst

*prism54-firmware-2.13 (04 Mar 2010)

  04 Mar 2010; Fabio Erculiani <lxnay@gentoo.org>
  +prism54-firmware-2.13.ebuild:
  add new firmware version, for Linux >=2.6.29, update SLOT, to allow
  installation side-by-side with deprecated (older) ebuild, reset KEYWORDS

  17 Oct 2009; Thilo Bangert <bangert@gentoo.org>
  prism54-firmware-1.0.4.3.ebuild:
  fix SRC_URI (bug #241744)

Note it says in the Changelog the kernel versions package is in tree since March please bump mark stable or at least keyword for testing on arch's This firmware adds support for a large set of cards not just mine and the stable version unless you have bumped it will not even work with a current gentoo-sources on a new install. think this one will later be in kernel anyway ...but for now.
Comment 7 Fabio Erculiani (RETIRED) gentoo-dev 2010-12-15 14:37:12 UTC
add STABLEREQ to Keywords and assing to arches.
Comment 8 p4u 2011-01-18 20:01:35 UTC
The actual version of prism54-firmware package does not work because ebuild tries to download a file not avaiable. To solve this you have to change the next:

SRC_URI="http://daemonizer.de/prism54/prism54-fw/fw-softmac/2.13.12.0.arm
	http://daemonizer.de/prism54/prism54-fw/fw-usb/2.13.1.0.lm86.arm
	http://daemonizer.de/prism54/prism54-fw/fw-usb/2.13.24.0.lm87.arm
	http://daemonizer.de/prism54/prism54-fw/stlc4560/2.13.12.0.a.5.2.arm"

And:

src_install() {
	dodir /lib/firmware
	insinto /lib/firmware
	newins "${DISTDIR}"/2.13.12.0.a.5.2.arm 3826.arm
	newins "${DISTDIR}"/2.13.24.0.lm87.arm isl3887usb
	newins "${DISTDIR}"/2.13.1.0.lm86.arm isl3886usb
	newins "${DISTDIR}"/2.13.12.0.arm isl3886pci
}

It works for me.
Comment 9 David J Cozatt 2011-07-09 19:31:53 UTC
Created attachment 279531 [details]
adjusted elog output as suggested in comment#3

This ebuild worksforme as is without any changes.(and has for over a year) not sure what comment #8 is about unless the ebuild was already updated 

Granted I have the pci version and cannot test the usb stuff for a lack of hardware
Comment 10 Michael Weber (RETIRED) gentoo-dev 2012-06-14 00:05:19 UTC
This issue was adressed in bug 371015