Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 328115 - dev-db/libdbi-0.8.3 fails to build with doc USE flag because X00E1 is not a function name in /usr/share/sgml/docbook/xml-simple-dtd-4.1.2.4/ent/iso-lat1.ent
Summary: dev-db/libdbi-0.8.3 fails to build with doc USE flag because X00E1 is not a f...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-13 15:14 UTC by Juergen Rose
Modified: 2013-03-02 11:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---
robbat2: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2010-07-13 15:14:32 UTC
'emerge libdbi' fails with:
...
make[2]: Entering directory `/var/tmp/portage/dev-db/libdbi-0.8.3/work/libdbi-0.8.3/doc'
Converting programmers-guide.sgml to HTML...
mkdir -p programmers-guide && cd programmers-guide && openjade -t sgml -d ../../doc/include/doc-html.dsl ../../doc/programmers-guide.sgml
openjade:/usr/share/sgml/docbook/xml-simple-dtd-4.1.2.4/ent/iso-lat1.ent:6:19:E: "X00E1" is not a function name
openjade:/usr/share/sgml/docbook/xml-simple-dtd-4.1.2.4/ent/iso-lat1.ent:7:19:E: "X00C1" is not a function name
...
openjade:/usr/share/sgml/docbook/xml-simple-dtd-4.1.2.4/ent/iso-lat1.ent:67:17:E: "X00FF" is not a function name
make[2]: *** [programmers-guide/x278.html] Error 1

I tried also to reinstall several packages, but I am not succesfull:
 1059  emerge -1 sgml-common
 1060  emerge -1 jadetex
...
 1064  for p in `qlist -ICv dtd` ; do emerge -v1 "=$p" ; done
...
 1081  emerge -v1 openjade


Reproducible: Always




oot@inspironM12:/root(91)# emerge --info libdbi
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.4.4, glibc-2.11.2-r0, 2.6.30-gentoo-r4 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.30-gentoo-r4-i686-Intel-R-_Atom-TM-_CPU_Z520_@_1.33GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 02 Jul 2010 14:00:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -mtune=generic -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -mtune=generic -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/science /var/lib/layman/x11 /var/lib/layman/zugaina /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi administrator afs alsa ao aotuv apache2 asf aspell atlas audacious audiofile automount bash-completion beagle berkdb blas bluetooth boo boost branding bzip2 c++ cairo cardbus cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt cups curl cxx daap dbus dell device-mapper dga dia djvu doc dri ds2490 dts dv dvb dvd dvdr dvi eds elf emacs emboss encode epiphany evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk foomaticdb fortran fpx fts3 fuse galago garmin gd gdal gdbm geolocation geos gif gimp ginac git glade glib glitz gml gmp gnokii gnome gnome-keyring gnuplot gnutls gphoto2 gpm graphics graphtft graphviz gs gsl gsm gstreamer gtk guile hal harness hddtemp hdf hdf5 hlapi http httpd hvm iconv icq icu id3 ide imagemagick imap innodb ipod ipv6 irda ithreads jabber jadetex java java5 java6 jbig john jpeg jpeg2k kdrive kerberos kexi kpathsea kvm ladspa lame lapack laptop latex lcms ldap libffi libgda libnotify libsamplerate lirc lm_sensors lua lzo mad mail maildir mailwrapper math matroska mikmod mmx mmxext mng modules mono moonlight motif mozdevelop mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numarray numeric obex objc ocaml octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio pymol python qhull qt3 qt3support qt4 quicktime readline reflection reiserfs rle romio rpc rrdcgi rrdtool samba sasl science sdl secure-delete semantic-desktop server session slang slp smbclient smp sndfile snmp soup sox speex spell spl sql sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs theora threads thunderbird tidy tiff tk tntc tools truetype udev unicode usb userlocales utempter v4l2 virtualbox vorbis wav webdav webdav-serf webkit wifi wmf wxwidgets x264 x86 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse                evdev                synaptics               " KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="psb intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-db/libdbi-0.8.3 was built with the following:
USE="-doc"
Comment 1 Juergen Rose 2010-07-20 16:12:51 UTC
I get the same problem with dev-db/postgresql-docs-9.0_beta2 and dev-libs/libusb-0.1.12-r7. Any news?
Comment 2 Juergen Rose 2010-07-20 16:13:58 UTC
I forget to mention, that also 'emerge -uvDNe texlive' did not helped.
Comment 3 Juergen Rose 2010-09-01 15:10:31 UTC
More than a month later, any news?
Comment 4 David Abbott gentoo-dev 2011-01-05 20:57:37 UTC
I ran into this also, while searching for a fix i ran across bug 111041 and 281672.