Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 324629 - New ebuild request: net-misc/googlecl
Summary: New ebuild request: net-misc/googlecl
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Alex Alexander (RETIRED)
URL: http://code.google.com/p/googlecl/
Whiteboard:
Keywords: EBUILD, InVCS
: 324639 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-18 18:58 UTC by srunni
Modified: 2010-06-21 19:02 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-python/googlecl/googlecl-0.9.5.ebuild (googlecl-0.9.5.ebuild,577 bytes, text/plain)
2010-06-19 02:34 UTC, David Abbott
Details
constrained python, relaxed gdata requirements (googlecl-0.9.5.ebuild,578 bytes, text/plain)
2010-06-19 05:01 UTC, Nick Howell
Details
added ~x86, changed description, removed some default definitions (googlecl-0.9.5.ebuild,482 bytes, text/plain)
2010-06-19 09:59 UTC, Nao Nakashima
Details
Add doman for manuals (googlecl-doman.patch,253 bytes, patch)
2010-06-21 14:22 UTC, Nao Nakashima
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description srunni 2010-06-18 18:58:05 UTC
So the folks over at Google have created a Google Command Line Tool (googlecl), which allows you to interact with various Google services from the command line. Introductory blog post is at http://google-opensource.blogspot.com/2010/06/introducing-google-command-line-tool.html

Reproducible: Always

Steps to Reproduce:
1. Open terminal.
2. Run 'google'.
3. Observe "google: command not found"
Comment 1 David Abbott gentoo-dev 2010-06-19 02:34:22 UTC
Created attachment 235897 [details]
dev-python/googlecl/googlecl-0.9.5.ebuild

seems to install ok;
qlist dev-python/googlecl
/usr/bin/google-2.6
/usr/bin/google
/usr/lib64/python2.6/site-packages/googlecl-0.9.5-py2.6.egg-info
/usr/lib64/python2.6/site-packages/googlecl/docs/__init__.py
/usr/lib64/python2.6/site-packages/googlecl/docs/service.py
/usr/lib64/python2.6/site-packages/googlecl/__init__.py
/usr/lib64/python2.6/site-packages/googlecl/picasa/__init__.py
/usr/lib64/python2.6/site-packages/googlecl/picasa/service.py
/usr/lib64/python2.6/site-packages/googlecl/contacts/__init__.py
/usr/lib64/python2.6/site-packages/googlecl/contacts/service.py
/usr/lib64/python2.6/site-packages/googlecl/youtube/__init__.py
/usr/lib64/python2.6/site-packages/googlecl/youtube/service.py
/usr/lib64/python2.6/site-packages/googlecl/service.py
/usr/lib64/python2.6/site-packages/googlecl/blogger/__init__.py
/usr/lib64/python2.6/site-packages/googlecl/blogger/service.py
/usr/lib64/python2.6/site-packages/googlecl/calendar/__init__.py
/usr/lib64/python2.6/site-packages/googlecl/calendar/service.py
/usr/share/doc/googlecl-0.9.5/README.packaging-new-releases.bz2
/usr/share/doc/googlecl-0.9.5/README.config.bz2
/usr/share/doc/googlecl-0.9.5/README.txt.bz2
/usr/share/doc/googlecl-0.9.5/MANIFEST.in.bz2
Comment 2 Nick Howell 2010-06-19 05:01:44 UTC
Created attachment 235903 [details]
constrained python, relaxed gdata requirements
Comment 3 Nick Howell 2010-06-19 05:03:05 UTC
Is there a reason for requiring dev-python/gdata-2.0.10? WFM with 2.0.9 and
according to http://code.google.com/p/googlecl/wiki/SystemRequirements you can
get functionality with any gdata version down to 1.2, inclusive, though 2.0.*
is required for editing.

Also, according to comments on that page, Python 2.6 is required, not just 2.x.

Attached an e-build with those changes. Sorry if that's irritating.
Comment 4 David Abbott gentoo-dev 2010-06-19 08:37:01 UTC
> Attached an e-build with those changes. Sorry if that's irritating.
Not at all, it is encouraged ++ 

Comment 5 f 2010-06-19 09:41:19 UTC
tested on my x86 box after adding ~x86 keyword, it works .
thank you both.
Comment 6 Nao Nakashima 2010-06-19 09:59:59 UTC
Created attachment 235923 [details]
added ~x86, changed description, removed some default definitions

Some minor changes:
* gdata is only RDEPEND
* src_install phase removed because it is default when distutils inherited
* PYTHON_MODNAME removed because PYTHON_MODNAME == ${PN}
* Changed description
* Added ~x86 keyword

And question: Do we really need to specify SUPPORT_PYTHON_ABIS=1 ?
googlecl support only 2.6 as far as I understand.
Comment 7 Stefan Behte (RETIRED) gentoo-dev Security 2010-06-19 18:35:11 UTC
*** Bug 324639 has been marked as a duplicate of this bug. ***
Comment 8 Samuli Suominen gentoo-dev 2010-06-20 15:26:31 UTC
*googlecl-0.9.7 (20 Jun 2010)

  20 Jun 2010; Alex Alexander <wired@gentoo.org> +googlecl-0.9.7.ebuild,
  +metadata.xml:
  new ebuild for google command line tools
Comment 9 Nao Nakashima 2010-06-21 14:22:40 UTC
Created attachment 236143 [details, diff]
Add doman for manuals

Please, install manuals also.
Comment 10 Alex Alexander (RETIRED) gentoo-dev 2010-06-21 19:02:12 UTC
(In reply to comment #9)
> Created an attachment (id=236143) [details]
> Add doman for manuals
> 
> Please, install manuals also.

fixed, nice catch ;)

to everyone: I actually hadn't noticed this bug when I added the ebuild ;p

closing, if you need/spot anything else feel free to open another bug!