Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 324377 - dev-util/catalyst: Verify and potentially improve Python-related code
Summary: dev-util/catalyst: Verify and potentially improve Python-related code
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Catalyst Developers
Depends on:
Blocks: 308257
  Show dependency tree
Reported: 2010-06-16 20:32 UTC by Arfrever Frehtes Taifersar Arahesis (RETIRED)
Modified: 2012-04-22 16:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

e (catalyst.patch,3.75 KB, patch)
2011-11-12 15:48 UTC, Ian Delaney (RETIRED)
Details | Diff
ebuild patch revised (catalyst.patch,3.74 KB, patch)
2011-11-14 09:27 UTC, Ian Delaney (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-06-16 20:32:56 UTC
- If this package can be used as a library and installs Python modules
  (*.so or *.py) into site-packages directories, then consider supporting
  installation for multiple Python versions.
  Please read section "Types of packages" in documentation [1] to decide
  if this package can support installation for multiple Python versions.

- Ensure that the ebuilds do not use deprecated functions or variables.

- Please check if Python 3 is supported by this package. You can temporarily
  set Python 3 as main active version of Python to properly test if this
  package supports Python 3.

- If this package does not support Python 3:
  - Specify dependency on Python 2.
    You can use PYTHON_DEPEND helper variable, which should be set before
    inheriting of python eclass.
    Please read section "Specification of dependency on Python" in
    documentation [1].

  - If this package cannot support installation for multiple versions of
    Python, then set active version of Python using

  - Ensure that shebangs in installed scripts specify correct version of
    Python. If shebangs are too generic (e.g. '#!/usr/bin/python'), then you
    can use python_convert_shebangs() to convert shebangs.
    (Wrapper scripts generated by python_generate_wrapper_scripts() do not
    require any changes.)
    Please read section "Shebangs in installed scripts" in documentation [1].

  - To ensure that changes applied to the ebuilds are sufficient, please
    temporarily set Python 3 as main active version of Python and test if
    this package can be properly installed and if it works at run time.

Please see documentation [1] for more details.
Comment 1 Ian Delaney (RETIRED) gentoo-dev 2011-11-12 15:48:09 UTC
Created attachment 292291 [details, diff]

good for ABI {2.6 2.7 3.1 3.2}
All tested, all AOK
Comment 2 Arfrever Frehtes Taifersar Arahesis 2011-11-13 02:25:48 UTC
(In reply to comment #1)

Portage itself requires Python >=2.6 and it has no relation to Python version
required by other packages. If you install sys-apps/portage with USE="python3",
then you will be able to set active version of Python 2 to 2.4 or 2.5 and still
use Portage (Portage will use active version of Python 3 regardless of active
version of Python 2).

Comment 3 Ian Delaney (RETIRED) gentoo-dev 2011-11-14 09:27:12 UTC
Created attachment 292495 [details, diff]
ebuild patch revised

Comment 4 Raúl Porcel (RETIRED) gentoo-dev 2012-04-22 16:54:26 UTC