Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 324191 - new portage option: FEATURES=compress-build-logs
Summary: new portage option: FEATURES=compress-build-logs
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Configuration (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 328063 (view as bug list)
Depends on:
Blocks: 335925
  Show dependency tree
 
Reported: 2010-06-16 00:19 UTC by Zac Medico
Modified: 2010-09-04 08:32 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2010-06-16 00:19:33 UTC
The idea is to compress build logs as they are written, in order to facilitate the publishing of compressed tinderbox logs on a web server. Since the portage code opens the build log many times in many places, it's not very convenient to pass an open file descriptor to all those places. However, it's possible to open the file in append mode with the gzip.GzipFile() class. A helper function can be used to open the file based on the current FEATURES settings.
Comment 1 SpanKY gentoo-dev 2010-06-16 00:38:47 UTC
probably best to not encode a compression schema in the feature name
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2010-06-20 12:30:32 UTC
(In reply to comment #1)
> probably best to not encode a compression schema in the feature name
> 

I agree; otherwise, we could end up in collision. One feature for compression, and one extra variable for the algo (default to gz please, to easily use zcat and zgrep).
Comment 3 DEMAINE Benoît-Pierre, aka DoubleHP 2010-06-20 12:34:57 UTC
Different approach proposed in bug 324729 .
Comment 4 Sebastian Luther (few) 2010-07-13 08:13:17 UTC
*** Bug 328063 has been marked as a duplicate of this bug. ***
Comment 6 Zac Medico gentoo-dev 2010-08-23 06:24:55 UTC
This is in 2.2_rc68, but I'll leave this bug open until it's in an unmasked version.
Comment 7 Zac Medico gentoo-dev 2010-09-04 08:32:58 UTC
This is fixed in 2.1.9.