Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 324069 - media-sound/amarok-2.3.1 just loads its splash screen and then hangs (after upgrade from stable)
Summary: media-sound/amarok-2.3.1 just loads its splash screen and then hangs (after u...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-15 07:25 UTC by Andreas K. Hüttel
Modified: 2010-07-10 23:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of amarok --debug --nofork (amarok-debug.txt,44.94 KB, text/plain)
2010-06-15 19:01 UTC, Oliver Schwabedissen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2010-06-15 07:25:36 UTC
see summary
Comment 1 Andreas K. Hüttel gentoo-dev 2010-06-15 07:27:53 UTC
see bug 314775 comment 11 for the "original" of this report
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-06-15 12:37:22 UTC
We need some info to be able to understand what's going on.
Get the user to attach emerge --info output and to start amarok with amarok --debug --nofork and check the debug output - this needs to be done twice, if memory serves me right.
Comment 3 Oliver Schwabedissen 2010-06-15 18:50:11 UTC
emerge --info:

Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.4.3, glibc-2.10.1-r1, 2.6.32-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r7-i686-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 14 Jun 2010 23:00:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.2-r3
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fno-delete-null-pointer-checks -fwrapv"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fno-delete-null-pointer-checks -fwrapv"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LC_ALL="POSIX"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi alsa apache2 apm arts artswrappersuid asf aspell audiofile bash-completion binary-drivers branding bzip2 cairo caps cdparanoia cdr chm clamav cli consolekit cracklib crypt css ctype cups cxx dbm dbus dmi doc dri dts dvd dvdnav dvdr dvdread emacs embedded emboss encode esd exif expat extrafilters extras fam fbcon ffmpeg firefox flac fontconfig foomaticdb fortran ftp gcj gd gdbm gif gimp glitz glut gmp gnutls gocr gphoto2 gpm graphviz gs gstreamer gtk hal hddtemp iconv icq id3 idn ieee1394 imagemagick imap imlib inotify jadetex java javascript jpeg jpeg2k kde kdehiddenvisibility kipi kpathsea lame lastfm lcms libnotify lm_sensors logitech-mouse logrotate logwatch lzo mad mbox mikmod mime mjpeg mmx mmxext mng modules moneyplex mono motif mp3 mp4 mpeg mpeg2 mplayer msn mudflap musicbrainz mysql mysqli ncurses nls npp nptl nptlonly nsplugin ocrad offensive ogg ole openexr opengl openmp oss pam pango pcre pda pdf perl plasma pmu png posix ppds pppd print python pyzord qt3support qt4 quicktime raster razor rdesktop readline reflection rtc samba sasl scanner sdl semantic-desktop sensord session sharedmem slang smp snmp sockets sox spell spl sql sqlite3 sse sse2 ssl startup-notification svg sysfs syslog tcl tcpd tidy tiff tk toolbar tools truetype udev unicode usb userlocales v4l v4l2 vcd vim-syntax vim-with-x visualization vorbis webkit win32codecs wxwindows x264 x86 xcb xcomposite xft xine xinetd xml xorg xosd xpm xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev vga v4l v4l2" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Oliver Schwabedissen 2010-06-15 19:01:15 UTC
Created attachment 235459 [details]
Output of amarok --debug --nofork

I was already using amarok-2.3.1 when I updated KDE from 4.3.5 to 4.4.4.

After finishing the KDE update I re-emerged amarok-2.3.1 and amarok-utils-2.3.1.

Nevertheless, Amarok doesn't start.

I'm attaching the output of "amarok --debug --nofork" as it is too large.

That's all I get. Splash screen is still there, but can be closed by clicking on it.

I was able to fix the problem by deleting ~/.kde4/share/config/amarokrc. I'm still trying to find out which entry causes Amarok to hang.
Comment 5 Oliver Schwabedissen 2010-06-15 20:03:54 UTC
Ok, found the culprit. For some reason the following 3 lines cause amarok-2.3.1 to crash on my system after updating KDE 4.3.5 to KDE 4.4.4:

[Session]
LastPlaying=5
Resume Time=316994


I restored 

~/.kde4/share/apps/amarok/*
~/.kde4/share/config/amarok*

removed the 3 lines and Amarok starts fine. If I don't remove the lines, Amarok hangs at the splash screen.

More interesting: after playing some tracks in Amarok I quit Amarok and checked amarokrc again.

It now contained
[Session]
LastPlaying=5

However I don't have that "Resume Time=" entry anymore...
Comment 6 Alex Barker 2010-07-06 20:50:59 UTC
My issue is totally unrelated to [Session] section.  Deleted both config paths and it works again.
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-07-10 23:24:04 UTC
Given the last comments this seems to be caused by some config file settings.
Whenever you update, if you hit any issues, move away the amarok config settings to ensure it's not caused by that.