Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 323805 - media-libs/libvpx-0.9.0_p20100612 fails to compile: parallel-make issue
Summary: media-libs/libvpx-0.9.0_p20100612 fails to compile: parallel-make issue
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-13 17:03 UTC by Dennis Schridde
Modified: 2011-06-23 16:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,26.01 KB, text/plain)
2010-06-13 17:03 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2010-06-13 17:03:09 UTC
media-libs/libvpx-0.9.0_p20100612 fails to compile, probably because of a parallel make issue:
    [LN]      /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.so
    [INSTALL] /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.a
ln: creating symbolic link `/var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.so': No such file or directory

libvpx.so should depend on libvpx.so.0.9.0, so that the latter is created before the former. This will solve the problem that /usr/lib64 does not exist when the symlink is created.

Reproducible: Always
Comment 1 Dennis Schridde 2010-06-13 17:03:58 UTC
Created attachment 235197 [details]
build.log
Comment 2 Dennis Schridde 2010-06-13 17:07:48 UTC
The next run yielded:
    [INSTALL] /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.a
    [INSTALL] /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/include/vpx/vpx_encoder.h
    [LN]      /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.so
    [LN]      /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.so.0
    [LN]      /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.so.0.9
    [INSTALL] /var/tmp/portage/media-libs/libvpx-0.9.0_p20100612/image//usr/lib64/libvpx.so.0.9.0

This time libvpx.a was created (by chance, not due to a fix/workaround) before libvpx.so, which also made the issue not appear.
-> This really is a parallel-make issue.
Comment 3 Petteri Räty (RETIRED) gentoo-dev 2010-10-22 14:43:29 UTC
Committed a workaround until media-video gets to add a proper patch.
Comment 4 Alexis Ballier gentoo-dev 2011-06-23 16:04:58 UTC
fixed in upstream git; workaround removed in -9999, not worth backporting imho -> fixed