Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 323555 - fortran.eclass forbids FC=${CHOST}-gfortran
Summary: fortran.eclass forbids FC=${CHOST}-gfortran
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Kacper Kowalik (Xarthisius) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: portage-multilib 339465
  Show dependency tree
 
Reported: 2010-06-11 12:41 UTC by Nathan Phillip Brink (binki) (RETIRED)
Modified: 2011-04-01 11:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (blas-atlas-3.8.0-build.log,1.53 KB, text/plain)
2010-06-11 12:44 UTC, Nathan Phillip Brink (binki) (RETIRED)
Details
die.env (blas-atlas-3.8.0-die.env,228.60 KB, text/plain)
2010-06-11 12:46 UTC, Nathan Phillip Brink (binki) (RETIRED)
Details
emerge --info (blas-atlas-3.8.0-emerge-info.txt,17.08 KB, text/plain)
2010-06-11 12:46 UTC, Nathan Phillip Brink (binki) (RETIRED)
Details
allows programs to compile if FC=$(portageq envvar CHOST)-gfortran (fortran.eclass-CHOST.patch,1.25 KB, patch)
2010-07-16 01:35 UTC, Nathan Phillip Brink (binki) (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-06-11 12:41:48 UTC
Reproducable on portage with
$ FC=$(portageq envvar CHOST)-gfortran emerge -v blas-atlas

Would also cause problems with the -gfortran that tc-getPROG() returns. ${CHOST}-gfortran is valid and must be supported by the eclass.

Perhaps the eclass can automatically strip ${CHOST} from FC or just ignore everything before and including the last `-' in FC.
Comment 1 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-06-11 12:44:55 UTC
Created attachment 234939 [details]
build.log
Comment 2 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-06-11 12:46:18 UTC
Created attachment 234941 [details]
die.env
Comment 3 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-06-11 12:46:32 UTC
Created attachment 234943 [details]
emerge --info
Comment 4 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-07-16 01:35:03 UTC
Created attachment 238971 [details, diff]
allows programs to compile if FC=$(portageq envvar CHOST)-gfortran

This patch causes the ebuilds not to die just because FC=$(portageq envvar CHOST)-gfortran.

Some packages, like xfoil, test ${FOTRANC} = "gfortran" instead of using fortran_patch(). I couldn't find a test-case for my modified fortran_patch() in the time I gave myself.
Comment 5 Justin Lecher gentoo-dev 2011-04-01 11:01:11 UTC
fortran.eclass not used anymore in the tree