Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 32355 - net-libs/linc no dependancy in gnome ebuild
Summary: net-libs/linc no dependancy in gnome ebuild
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2003-10-30 17:51 UTC by flo
Modified: 2004-07-14 02:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description flo 2003-10-30 17:51:58 UTC
ok, i did the following:

emerge depclean (hardcore)

then e.g. evolution did not work... (somehow expected)

revdep-rebuild -- -pv showed following commandline for fixing my system:
.... (lots of lines like the following deleted)
broken /usr/bin/evolution-1.4 (requires
emerge --oneshot --nodeps -pv =app-arch/file-roller-
=app-editors/gedit-2.4.0 =app-office/gnumeric-1.2.0 =app-office/mdbtools-0.5
=app-pda/gnome-pilot-2.0.10-r1 =app-text/ggv-2.0.1 =app-text/ggv-
=app-text/gnome-spell-1.0.5 =app-text/gpdf-0.110
=gnome-base/control-center-2.4.0 =gnome-base/gdm-
=gnome-base/gnome-applets-2.4.0 =gnome-base/gnome-desktop-2.4.0
=gnome-base/gnome-panel-2.4.0-r1 =gnome-base/gnome-session-2.4.0
=gnome-base/gnome-vfs-2.4.0 =gnome-base/libbonoboui-2.4.0
=gnome-base/libgnome-2.4.0 =gnome-base/libgnomeui-
=gnome-base/nautilus-2.4.0 =gnome-extra/gcalctool-4.3.3
=gnome-extra/gnome-games-2.4.0 =gnome-extra/gnome-media-2.4.0
=gnome-extra/gucharmap-1.0.0 =gnome-extra/nautilus-cd-burner-0.5.3
=gnome-extra/nautilus-media- =gnome-extra/yelp-2.4.0
=media-sound/alsa-tools-0.9.8 =media-video/totem-0.99.5
=net-mail/evolution-1.4.5 =net-print/gnome-cups-manager-0.17
=net-www/epiphany-1.0 =x11-terms/gnome-terminal-

emerge evolution showed no dependancy to reinstall:
lap root # emerge -pv evolution

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] net-mail/evolution-1.4.5  +ssl +mozilla +ldap +doc +spell +pda
-ipv6 +kerberos +kde +crypt

ok. so i did:
emerge linc

programs work now again but:
linc is stored in world file now instead of being a dependency of gnome (?).

emerge -pve gnome | grep linc says nothing...

hope my problem is clear!

-- flo

Reproducible: Always
Steps to Reproduce:

emerge info:
Portage 2.0.49-r15 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1, 2.4.22-ac4)
System uname: 2.4.22-ac4 i686 Intel(R) Pentium(R) M processor 1500MHz
Gentoo Base System version
distcc 2.11.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
CFLAGS="-march=pentium3 -O2 -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=pentium3 -O2 -pipe"
FEATURES="sandbox ccache autoaddcvs"
USE="x86 oss apm avi crypt cups encode foomaticdb gif jpeg libg++ mad mikmod
mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv zlib directfb
alsa gdbm berkdb slang readline arts tetex aalib nas bonobo svga ggi tcltk java
guile mysql postgres X sdl gpm tcpd pam libwww ssl perl python esd imlib
oggvorbis gnome gtk qt kde motif opengl mozilla gphoto2 ldap cdr scanner acl
acpi apache2 artswrappersuid clanJavaScript clanVoice curl dga doc dv dvd emacs
ethereal evo fbcon firebird flash freetds gb gd gnomedb gps gstreamer gtk2
gtkhtml imap innodb jack javascript joystick justify kerberos krb4 ladcca lcms
libgda lirc maildir mbox mcal mdb mmx modif mpi mule oav odbc parse-clocks
pcmcia pda plotutils pnp ppds radeon ruby samba sasl slp snmp socks5 sqlite sse
tiff usb wmf Xaw3d xinerama xml zeo"
Comment 1 Spider (RETIRED) gentoo-dev 2003-10-30 18:45:57 UTC
well thats expected when using depclean blindly ;)

Actually linc is -no longer- a dependency of gnome, nor evolution. However,
once it was, and things that haven't been rebuilt against the newer versions
of ORBit2 / libbonobo will realize that things don't work as expected since
they still need it.

So, yes. the current dependencies are correct, and you were bitten in the
leg by depclean.

Your problem is easiest solved by tracing down the things that link to linc,
and rebuilding those.
Comment 2 flo 2003-10-31 04:35:05 UTC
ok, everything clear...
Comment 3 foser (RETIRED) gentoo-dev 2003-10-31 05:08:01 UTC
spiders is correct

closing as invalid, cause it's not a gnome bug 
Comment 4 flo 2003-10-31 14:19:24 UTC
emerge unmerge linc


emerge --oneshot --nodeps -pv =gnome-base/libgnome-2.4.0 =gnome-base/libgnomeui-
=app-arch/file-roller- =app-editors/gedit-2.4.0 =app-office/mdbtools-0.5
=app-office/gnumeric-1.2.0 =app-pda/gnome-pilot-2.0.10-r1 =app-text/ggv-
=app-text/gpdf-0.110 =net-print/gnome-cups-manager-0.17 =gnome-base/control-center-2.4.0
=gnome-base/gdm- =gnome-base/gnome-applets-2.4.0 =gnome-base/gnome-desktop-2.4.0
=gnome-base/gnome-panel-2.4.0-r1 =gnome-base/gnome-session-2.4.0 =gnome-base/libbonoboui-2.4.0
=gnome-base/nautilus-2.4.0 =gnome-extra/gcalctool-4.3.3 =gnome-extra/gnome-games-2.4.0
=gnome-extra/gnome-media-2.4.0 =gnome-extra/gucharmap-1.0.0 =gnome-extra/nautilus-cd-burner-0.5.3
=gnome-extra/nautilus-media- =gnome-extra/yelp-2.4.0 =media-video/totem-0.99.5
=net-mail/evolution-1.4.5 =net-www/epiphany-1.0 =x11-terms/gnome-terminal-

breaks with:

-DGNOMEUIPIXMAPDIR=\"/usr/share/pixmaps\" -DGNOMEUIICONDIR=\"/usr/share/icons\"
-DGNOMEUISERVERDIR=\"/usr/libexec\" -DGNOMEUILOCALSTATEDIR=\"/var/lib\" -DGNOMEUILOCALEDIR=\"/usr/share/locale\"
-DSYSCONFDIR=\"/etc\" -DG_LOG_DOMAIN=\"GnomeUI\" -Wall -Wmissing-prototypes
-DORBIT2=1 -pthread -I/usr/include/libgnome-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gconf/2
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0
-I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/pango-1.0
-I/usr/include/freetype2 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/X11R6/include -I/usr/include/libbonoboui-2.0
-I/usr/include/libxml2 -march=pentium3 -O2 -pipe -c gnome-client.c -o gnome-client.o
>/dev/null 2>&1
/bin/sh ../libtool --mode=link gcc  -march=pentium3 -O2 -pipe  -o
-rpath /usr/lib -version-info 400:0:400  -no-undefined   -export-symbols-regex
"^[^_].*" libgnomeui-access.lo gnometypebuiltins.lo gnome-about.lo gnome-app.lo
gnome-app-helper.lo gnome-app-util.lo gnome-appbar.lo gnome-stock-icons.lo
gnome-color-picker.lo gnome-dateedit.lo gnome-dialog.lo gnome-dialog-util.lo
gnome-druid.lo gnome-druid-page.lo gnome-druid-page-edge.lo gnome-druid-page-standard.lo
gnome-entry.lo gnome-file-entry.lo gnome-font-picker.lo gnome-gconf-ui.lo
gnome-href.lo gnome-ice.lo gnome-marshal-main.lo gnome-messagebox.lo gnome-mdi.lo
gnome-mdi-child.lo gnome-mdi-generic-child.lo gnome-mdi-session.lo gnome-pixmap.lo
gnome-pixmap-entry.lo gnome-popup-menu.lo gnome-propertybox.lo gnome-scores.lo
gnome-theme-parser.lo gnome-thumbnail.lo gnome-thumbnail-pixbuf-utils.lo
gnome-ui-init.lo gnometypes.lo gnome-icon-entry.lo gnome-icon-item.lo gnome-icon-list.lo
gnome-icon-lookup.lo gnome-icon-sel.lo gnome-icon-theme.lo gnome-vfs-util.lo
gnome-window.lo gnome-window-icon.lo gnome-password-dialog.lo gnome-authentication-manager.lo
gnome-client.lo -pthread -Wl,--export-dynamic -lbonoboui-2 -lxml2 -lpthread
-lz -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0
-lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lbonobo-2
-lgnomevfs-2 -lbonobo-activation -lgconf-2 -lORBit-2 -lgthread-2.0 -lm -lpango-1.0
-lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -ljpeg                    
    -L/usr/X11R6/lib -lSM -lICE -lpopt
grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file or directory
libtool: link: `/usr/lib/' is not a valid libtool archive
make[3]: *** [] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libgnomeui-'
make: *** [all-recursive-am] Error 2

!!! ERROR: gnome-base/libgnomeui- failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure

how to continue?
Comment 5 Spider (RETIRED) gentoo-dev 2003-10-31 14:31:28 UTC
cd /usr/lib
grep linc *.la

qpkg -f on matching files.. rebuild 

Comment 6 flo 2003-10-31 14:56:03 UTC
emerge unmerge linc
lap lib # qpkg -f -v
gnome-base/gnome-panel-2.4.0-r1 *
lap lib # emerge --oneshot =gnome-base/gnome-panel-2.4.0-r1
/bin/sh ../libtool --mode=link gcc  -march=pentium3 -O2 -pipe  -o gnome-panel
-export-dynamic GNOME_Panel-stubs.o GNOME_Panel-skels.o GNOME_Panel-common.o
egg-screen-exec.o egg-screen-help.o egg-screen-url.o eggaccelerators.o panel-typebuiltins.o
panel-marshal.o main.o panel-widget.o button-widget.o xstuff.o panel-session.o
panel-compatibility.o disclosure-widget.o panel.o applet.o drawer.o panel-config-global.o
panel-util.o panel-gconf.o panel-properties-dialog.o distribution.o panel-run-dialog.o
menu.o menu-util.o menu-ditem.o menu-fentry.o launcher.o panel-applet-frame.o
panel-shell.o quick-desktop-reader.o panel-background.o panel-background-monitor.o
panel-stock-icons.o panel-action-button.o panel-menu-bar.o panel-menu-button.o
panel-recent.o panel-gdk-pixbuf-extensions.o panel-action-protocol.o panel-toplevel.o
panel-struts.o panel-frame.o panel-xutils.o panel-multiscreen.o panel-a11y.o
panel-bindings.o panel-profile.o panel-force-quit.o egg-recent-model.o egg-recent-item.o
egg-recent-view.o egg-recent-view-gtk.o egg-recent-util.o -lSM -lICE  -L/usr/X11R6/lib
-lX11    -pthread -Wl,--export-dynamic -L/usr/X11R6/lib -lgnome-desktop-2
-lgnomeui-2 -lSM -lICE -lstartup-notification-1 -lbonoboui-2 -lgnomecanvas-2
-lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lbonobo-2 -lgnomevfs-2 -lbonobo-activation
-lglade-2.0 -lgtk-x11-2.0 -lxml2 -lpthread -lz -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0
-lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgconf-2 -lORBit-2 -lgobject-2.0
-lgthread-2.0 -lm -lgmodule-2.0 -ldl -lglib-2.0               -lXinerama
mkdir .libs
libtool: link: cannot find the library `/usr/lib/'
make[2]: *** [gnome-panel] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-panel-2.4.0-r1/work/gnome-panel-2.4.0'
make: *** [all-recursive-am] Error 2

!!! ERROR: gnome-base/gnome-panel-2.4.0-r1 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure
Comment 7 foser (RETIRED) gentoo-dev 2003-11-03 08:52:25 UTC
hi, please leave it closed, it's not our problem if you want to remove linc
for no reason. We suggest you leave it in for the forseeable future, it doesn't

If you don't want it and can't find out how to recompile stuff correctly
(spiders suggestions should help you most of the way), then start from scratch.
Comment 8 foser (RETIRED) gentoo-dev 2003-11-03 08:52:36 UTC
and closing
Comment 9 Bill Skellenger 2004-07-13 16:27:33 UTC
Hm, I had the same problem as the reporter when trying to upgrade evolution.
However, I did not emerge depclean.  I did, however, unmerge Gnome a few weeks

Would unmerging Gnome remove linc?

I did not make an effort to remove it, as was suggested to the reporter --
perhaps by unmerging Gnome it was removed automatically?  In this case,
perhaps gal should depend on it as well...?

"emerge linc" solved this problem for me.

My output from gal (truncated):

grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file or directory
libtool: link: `/usr/lib/' is not a valid libtool archive
make[4]: *** [] Error 1
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gal-1.99.11/work/gal-1.99.11/gal'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gal-1.99.11/work/gal-1.99.11'
make: *** [all-recursive-am] Error 2

!!! ERROR: gnome-extra/gal-1.99.11 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure

Comment 10 Spider (RETIRED) gentoo-dev 2004-07-14 02:18:23 UTC
yes, linc was part of gnome, but the error you see is a libtool one where libtool wrote down the dependencies inside files belonging to a package.  When theese files were then removed from the system, libtool bails, wether or not it needs it "for real" or not.

Leaving as CLOSED.