Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 321373 - lxde-meta (more specific lxmenu-data-0.1.1) requires XML-Parser to compile but it is not checked for before building resulting in a build fail
Summary: lxde-meta (more specific lxmenu-data-0.1.1) requires XML-Parser to compile bu...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-24 22:40 UTC by Daniel Witzel
Modified: 2013-12-19 15:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Witzel 2010-05-24 22:40:46 UTC
emerging XML-Parser then continueing onto lxde-meta resulted in a succesfull build. Propose XML-Parser checking be added to the lxde-meta dependency list (or lx-menu in paticular)

Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2010-05-24 22:48:01 UTC
lxde-base/lxmenu-data has depend on dev-util/intltool, and intltool has runtime depend on XML-Parser... in others words, it's impossible to install the package without having XML-Parser installed as is. I guess you upgraded perl, and forgot to run "perl-cleaner --reallyall" ? Then re-emerging XML-Parser would have fixed this one issue...
Comment 2 Daniel Witzel 2010-05-24 22:53:08 UTC
thanks, still feeling out gentoo. did log dump and saw it nagging about xml-parser so i emerged it and cured problem. will do that next time. 
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-05-24 23:25:35 UTC
Probably a dupe of bug 41124 ;)
Comment 4 Jeroen Roovers gentoo-dev 2013-12-19 15:28:30 UTC

*** This bug has been marked as a duplicate of bug 41124 ***