Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 319461 - www-apps/mantisbt-1.2.1 "requires" ezc-Graph-1.4.3 & ezc-Base-1.7
Summary: www-apps/mantisbt-1.2.1 "requires" ezc-Graph-1.4.3 & ezc-Base-1.7
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Peter Volkov (RETIRED)
Depends on: 320547
  Show dependency tree
Reported: 2010-05-12 20:12 UTC by Philippe Chaintreuil
Modified: 2010-05-25 19:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Chaintreuil 2010-05-12 20:12:49 UTC
Contrary to what library/README.libs claims, Mantis 1.2.1 is actually distributed with and requires* ezc-Graph-1.4.3 & ezc-Base-1.7.

* Mantis doesn't strictly require ecz-* at all.  The only reference to them is in the Graph plugin which is *not* enabled (although it *is* distributed) by default.  The Graph plugin can also be configured to use jpgraph instead of the ezc-* libraries.

Given that knowledge, I don't know how you'd want to proceed.  Get the required ezc components into the tree and require them?  Even then, should there be a use flag that just removes the Graph plugin?  Should we just switch the default to jpgraph?  Should we just remove the Graph plugin for now?  Remove the ezc requirements at all?  Put the bundled version for now? ...
Comment 1 Philippe Chaintreuil 2010-05-12 20:23:24 UTC
> Contrary to what library/README.libs claims[...]

I guess that's incorrect.  It looks like ecz component versions are unrelated to the major version, so the mantis README.libs contains the correct information.
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2010-05-19 11:19:41 UTC
Philippe, but is it broken for you? How to reproduce that breakage since I was able to build graphs...

And yes, I'd better put newer versions of ezc-* into the tree.
Comment 3 Philippe Chaintreuil 2010-05-19 11:51:02 UTC
Unfortunatly I'm not planning on being able to access the machine I have it installed on until next week.  But this is what I remember:

(Footnote: I didn't have any ezc-* packages installed before this upgrade.)

- Enable Graph plugin
- "Built-in" is selected (not jpgraph)
- View a bug with a relationship, click to see relationship graph if necessary
- Nothing shows up

- Go back to graph plugin settings
- Change to jpgraph
- Supply path to jpgraph
- Go back to bug with relationship
- Graph is there.

If this doesn't work for you, I'll be sure to double check what I did first thing on Monday morning.
Comment 4 Philippe Chaintreuil 2010-05-24 18:12:24 UTC
Okay, sorry, that last comment was completely wrong.  It's not the relation graphs that are broken by this, it's the summary graphs.

To reproduce:

- Log in as admin
- Make sure the graph plugin is enabled/installed.
  - Click on Manage
  - Click on Manage Plugins
  - Make sure "Mantis Graphs 1.0" is in the "Installed Plugins" list.
    - if it's not, click "install" on the right of it.

- Click "summary"
- Click on any of the square-bracketed "sub categories" under summary with the little bar-chart icons.  (Eg, "Per State", "Per Priority", ...)
- Nothing shows up in the box on the new page.

- Click on Manage
- Click on Manage Plugins
- Click on the plugin name link "Mantis Graphs 1.0"
- Click on "jpgraph" (instead of "Bundled")
- Click "save"
- Go back to beginning, charts will show up now in the box.
Comment 5 Peter Volkov (RETIRED) gentoo-dev 2010-05-25 13:40:22 UTC
Thank you for perfect explanation Philippe! I've bumped ezc-* components in the tree. Could you upgrade them and tell me if that fixes this problem? It looks like with new components everything works here, but since I haven't tried to downgrade ezc-Graph I'm unsure if mantisbt just always worked here or dev-php5/ezc-Graph-1.5 fixes the problem.
Comment 6 Philippe Chaintreuil 2010-05-25 15:42:14 UTC
Yes, updating to ezc-Graph-1.5 and ezc-Base-1.8 fixes the problem.

So if you just update the Mantis 1.2.1 ebuild to require the proper versions of those plugins, we'll be all set and can mark this fixed!

Thanks Peter!
Comment 7 Peter Volkov (RETIRED) gentoo-dev 2010-05-25 17:38:17 UTC
Thank you Philippe again! I've updated dependencies. FIXED.