Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 318935 (CVE-2010-1455) - <net-analyzer/wireshark-1.2.8-r1: DOCSIS dissector could crash (CVE-2010-1455)
Summary: <net-analyzer/wireshark-1.2.8-r1: DOCSIS dissector could crash (CVE-2010-1455)
Status: RESOLVED FIXED
Alias: CVE-2010-1455
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B4 [glsa]
Keywords:
Depends on: 316835
Blocks:
  Show dependency tree
 
Reported: 2010-05-07 23:50 UTC by Hanno Böck
Modified: 2010-06-02 21:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log on x86 with use=profile (config.log,98.42 KB, text/plain)
2010-05-11 05:08 UTC, Andreas Schürch
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck gentoo-dev 2010-05-07 23:50:16 UTC
wireshark 1.2.8 is already in the tree, so only stabilization is needed. pva, stabilization for 1.2.8 ok?
Comment 1 Peter Volkov (RETIRED) gentoo-dev 2010-05-08 06:10:36 UTC
There are some patches from upstream to test, so I'd like to resolve bug 316835 first.
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2010-05-10 05:09:06 UTC
Arch teams, please, stabilize net-analyzer/wireshark-1.2.8-r1.
Comment 3 Brent Baude (RETIRED) gentoo-dev 2010-05-10 15:36:56 UTC
ppc64 done
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2010-05-10 20:41:59 UTC
Stable for HPPA.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2010-05-10 23:01:41 UTC
Stable for PPC.
Comment 6 Andreas Schürch gentoo-dev 2010-05-11 05:08:51 UTC
Created attachment 231043 [details]
config.log on x86 with use=profile

It fails terribly during configure when USE=profile is set on x86! Everything else looks good.

checking for GNU sed as first sed in PATH... yes                                                                                        
checking if profile builds must be generated... yes 
checking for pkg-config... /usr/bin/pkg-config                                                                                          
checking for GLIB - version >= 2.4.0... no                                                                                              
*** Could not run GLIB test program, checking why...                                                                                    
*** The test program failed to compile or link. See the file config.log for the                                                         
*** exact error that occured. This usually means GLIB is incorrectly installed.                                                         
configure: error: GLib 2.4 or later distribution not found.
Comment 7 Peter Volkov (RETIRED) gentoo-dev 2010-05-11 06:09:37 UTC
(In reply to comment #6)
> It fails terribly during configure when USE=profile is set on x86! Everything
> else looks good.

Andreas, next time, please, use the force! (google)

This is bug 318385 or many others same way invalid bugs. Don't set USE=profile until you know what it is.
Comment 8 Andreas Schürch gentoo-dev 2010-05-11 07:04:56 UTC
Ok, i see... Sorry for the noise.

As this really seems often reported... How about "die", as the other message just flashed by to fast for me in the early morning! ;-)

if use profile && is-flag -fomit-frame-pointer; then
  die "USE=\"profile\" doesn't work with fomit-frame-pointer... "
fi
Comment 9 Markus Meier gentoo-dev 2010-05-15 13:18:31 UTC
amd64/x86 stable
Comment 10 Raúl Porcel (RETIRED) gentoo-dev 2010-05-15 16:29:39 UTC
alpha/ia64/sparc stable
Comment 11 Stefan Behte (RETIRED) gentoo-dev Security 2010-05-21 22:55:57 UTC
CVE-2010-1455 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-1455):
  The DOCSIS dissector in Wireshark 0.9.6 through 1.0.12 and 1.2.0
  through 1.2.7 allows user-assisted remote attackers to cause a denial
  of service (application crash) via a malformed packet trace file.

Comment 12 Stefan Behte (RETIRED) gentoo-dev Security 2010-05-22 10:40:41 UTC
glsa together with 297388
Comment 13 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-06-02 21:28:10 UTC
GLSA 201006-05