Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 316377 - dev-libs/libxml2-2.7.7 fails due to gzopen64' implicitly converted to pointer w/ zlib-1.2.5
Summary: dev-libs/libxml2-2.7.7 fails due to gzopen64' implicitly converted to pointer...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo's Team for Core System packages
: 317073 (view as bug list)
Depends on:
Reported: 2010-04-20 16:17 UTC by Edward Hervey
Modified: 2010-04-26 15:19 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---

Patch to fix zlib LFS defines (zlib-1.2.5-lfs-defines.patch,1.62 KB, patch)
2010-04-21 08:22 UTC, Arun Raghavan (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Edward Hervey 2010-04-20 16:17:25 UTC
This is on a fresh install of gentoo, I get the following when emerging libxml2:

 * QA Notice: Package has poor programming practices which may compile
 *            but will almost certainly crash on 64bit architectures.
 * Function `gzopen64' implicitly converted to pointer at xmlIO.c:1175
 *  Please file a bug about this at
 *  with the maintaining herd of the package.
 * ERROR: dev-libs/libxml2-2.7.7 failed:
 *   install aborted due to poor programming practices shown above
 * Call stack:
 *, line 804:  Called install_qa_check
 *, line 479:  Called die
 * The specific snippet of code:
 *                              die "install aborted due to" \
 * If you need support, post the output of 'emerge --info =dev-libs/libxml2-2.7.7',
 * the complete build log and the output of 'emerge -pqv =dev-libs/libxml2-2.7.7'.
 * The complete build log is located at '/var/tmp/portage/dev-libs/libxml2-2.7.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/libxml2-2.7.7/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/libxml2-2.7.7/work/libxml2-2.7.7'
!!! post install failed; exiting.

>>> Failed to emerge dev-libs/libxml2-2.7.7, Log file:

>>>  '/var/tmp/portage/dev-libs/libxml2-2.7.7/temp/build.log'

Reproducible: Always

Portage (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.11-r1, 2.6.33-gentoo-r1 x86_64)
System uname: Linux-2.6.33-gentoo-r1-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.0.1
Timestamp of tree: Tue, 20 Apr 2010 14:00:01 +0000
app-shells/bash:     4.1_p5
dev-lang/python:     2.6.4-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.10.3
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Q3AEULA dlj-1.1 sun-bcla-java-vm"
CFLAGS="-march=native -pipe -g2 -O2 -DG_DISABLE_CAST_CHECKS"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -pipe -g2 -O2 -DG_DISABLE_CAST_CHECKS"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="en en_GB es_ES es fr it de"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri emacs fortran gdbm gnome gpm gstreamer gtk iconv ipv6 mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB es_ES es fr it de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" 
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2010-04-20 16:21:05 UTC
With what version of zlib? Note that 1.2.5 was added to tree today.
Comment 2 Edward Hervey 2010-04-20 16:29:12 UTC
with zlib-1.2.5

And indeed, I updated it on my other machine... and libxml2 fails in exactly the same way (other machine is also ~amd64)
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2010-04-20 17:40:23 UTC
reproduced also here
Comment 4 SpanKY gentoo-dev 2010-04-20 20:46:35 UTC
libxml.h should perhaps add to the top of it:
Comment 5 Arun Raghavan (RETIRED) gentoo-dev 2010-04-21 08:22:31 UTC
Created attachment 228589 [details, diff]
Patch to fix zlib LFS defines

I think the fix for this should go into zlib. zlib.h does a #define gzopen gzopen64 but then conditionally declares the function (based on _LARGEFILE64_SOURCE). The define and the declaration should be controlled by the same condition.

Attaching a patch that does this (and fixes the problem here).
Comment 6 Edward Hervey 2010-04-21 08:52:23 UTC
fwiw, debian experimental have applied this patch :
Comment 7 Brandon Penglase 2010-04-21 16:14:24 UTC
Patch applied to zlib worked for me (which ended up fixing some other issues once libxml2 was recompiled).
Comment 8 Adam Stylinski 2010-04-23 14:17:38 UTC
Worked for me too, please commit to portage.
Comment 9 Steve Warren 2010-04-24 01:42:57 UTC
This problem also occurs with zlib-1.2.4

Comment 10 Arun Raghavan (RETIRED) gentoo-dev 2010-04-24 06:38:54 UTC
Reassigning to base-system, as mentioned in comment #5, I believe this needs to be fixed in zlib.
Comment 11 Samuli Suominen (RETIRED) gentoo-dev 2010-04-25 06:37:09 UTC
*** Bug 317073 has been marked as a duplicate of this bug. ***
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-04-25 22:41:39 UTC
Fixed by adding the patch attached here to -r1.

Arun, I'll assume you sent that upstream already; if not please do it, thanks!
Comment 13 Samuli Suominen (RETIRED) gentoo-dev 2010-04-26 14:34:39 UTC
(In reply to comment #12)
> Fixed by adding the patch attached here to -r1.

Thanks, it solved also bug 316855 (luatex failed to compile).
Comment 14 Arun Raghavan (RETIRED) gentoo-dev 2010-04-26 15:19:46 UTC
I'm trying to get on zlib-devel to discuss this fix. Fwiw, Ubuntu/Debian have this issue as well, and Debian alludes to some upstream fix ca. 1.2.4. Let's see what upstream has to say.