Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 314895 - sys-cluster/apache-hadoop-common (new package)
Summary: sys-cluster/apache-hadoop-common (new package)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
Depends on:
Blocks: 318085 318167
  Show dependency tree
Reported: 2010-04-12 22:07 UTC by Tim Cera
Modified: 2018-01-05 16:52 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---

sys-cluster/apache-hadoop-common-0.20.2.ebuild (apache-hadoop-common-0.20.2.ebuild,1.24 KB, text/plain)
2010-04-12 22:09 UTC, Tim Cera

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Cera 2010-04-12 22:07:59 UTC
Hadoop Common includes FileSystem, RPC, and serialization libraries.
Comment 1 Tim Cera 2010-04-12 22:09:45 UTC
Created attachment 227539 [details]
Comment 2 Chris Gianelloni 2010-06-18 10:09:31 UTC
Tim, you saved me a good bit of time.  I was about to write an ebuild set for this.  The only thing that I still want to do is switch away from using the precompiled version and build it, instead.  Just for reference, I used to be a Gentoo developer, and I currently work for Yahoo in the Grid SE organization.  We have the largest Hadoop grids on the planet, so I'm pretty familiar with it.  ;]
Comment 3 Chris Gianelloni 2010-06-18 10:16:51 UTC
Added to my overlay (wolf31o2 in layman)...;a=commit;h=a26250180721283653a12c857710b9c6a797bf32
Comment 4 Tim Cera 2010-06-18 22:12:55 UTC

I am glad I could help.

Started first trying to compile, but it was rather daunting process with little documentation or examples.  I tried 'ant', but wasn't compiling - it wasn't finding a required jar file or resource.  Unfortunately I can't remember details.

Points out that I really named the package poorly.  It should end in -bin I think to differentiate it from the compile from scratch version.

Kindest regards,
Comment 5 Ultrabug gentoo-dev 2012-07-05 16:26:52 UTC
Hello guys,

Just wanted to let you know that I've tried to work on a more friendly ebuild for apache hadoop (with init script support etc).

It is present for version 1.0.3 of Hadoop as sys-cluster/apache-hadoop-bin in the ultrabug overlay.

Maybe you'll have some time to check it out, cheers.
Comment 6 Ultrabug gentoo-dev 2018-01-05 16:52:51 UTC
Closing obsolete proposal. Clearly the Hadoop ecosystem packaging is too much for the manpower we have I'm afraid.