Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 314249 - dev-ruby/gruff should depend on || (media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick])
Summary: dev-ruby/gruff should depend on || (media-gfx/imagemagick media-gfx/graphicsm...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 314431
  Show dependency tree
 
Reported: 2010-04-09 21:33 UTC by Wojciech Porczyk
Modified: 2010-04-12 18:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Porczyk 2010-04-09 21:33:23 UTC
GraphicsMagick is a replacement for ImageMagick. Now dev-ruby/gruff depends only on media-gfx/imagemagick.
Comment 1 Hans de Graaff gentoo-dev 2010-04-12 18:27:54 UTC
This is a false positive. dev-ruby/gruff depends on rmagick, which in turn can only use imagemagick. The explicit dependency on imagemagick in the ebuild is to ensure that imagemagick is built with the truetype USE flag.

Thanks for filing this, thought, because otherwise I might not have found out that this extra dependency got dropped by accident in the last version.