Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 314181 - mail-client/claws-mail-3.7.5 fails with libetpan 1.0
Summary: mail-client/claws-mail-3.7.5 fails with libetpan 1.0
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Christian Faulhammer (RETIRED)
URL: http://www.thewildbeast.co.uk/claws-m...
Whiteboard:
Keywords:
Depends on:
Blocks: 313097
  Show dependency tree
 
Reported: 2010-04-09 17:05 UTC by Didier Barvaux
Modified: 2010-05-09 15:18 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix check for libetpan version in configure.ac (claws-mail-3.7.5-fix-libetpan-check.patch,1.94 KB, patch)
2010-04-09 17:08 UTC, Didier Barvaux
Details | Diff
Patch to apply the bugfix in the claws-mail/claws-mail-3.7.5 ebuild (claws-mail-3.7.5.ebuild.diff,1.08 KB, patch)
2010-04-09 17:09 UTC, Didier Barvaux
Details | Diff
Ebuild updates for claws-mail-3.7.5-r1 (claws-mail-3.7.5-to-3.7.5-r1.diff,2.32 KB, patch)
2010-04-10 10:18 UTC, Tim Harder
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Didier Barvaux 2010-04-09 17:05:51 UTC
With net-libs/libetpan-1.0 (not in the tree yet but available in bug #313097), mail-client/claws-mail-3.7.5 fails to build.

The problem comes from a faulty check in the configure that does not handle well the new 1.0 version string. The bug was reported upstream (see URL field) but it would be great to have this patch applied by the Gentoo ebuild.

I'm going to attach the bugfix patch and an ebuild diff for mail-client/claws-mail-3.7.5 that applies the patch.

Reproducible: Always

Steps to Reproduce:
1. emerge '=net-libs/libetpan-1.0'
2. emerge '=mail-client/claws-mail-3.7.5'
3. configure fails

Actual Results:  
checking for libetpan-config... /usr/bin/libetpan-config
checking libetpan/libetpan.h usability... yes
checking libetpan/libetpan.h presence... yes
checking for libetpan/libetpan.h... yes
checking whether libetpan-config hints compiles and links fine... yes
*** Claws Mail requires libetpan 0.57 or newer. See http://www.etpan.org/
*** You can use --disable-libetpan if you don't need IMAP4 and/or NNTP support.
configure: error: libetpan 0.57 not found

Expected Results:  
The configure script should detect that version 1.0 is greater than 0.57.

$ emerge --info
Portage 2.1.7.17 (default/linux/x86/10.0/desktop/gnome, gcc-4.4.3, glibc-2.10.1-r1, 2.6.33 i686)
=================================================================
System uname: Linux-2.6.33-i686-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 08 Apr 2010 17:45:03 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.6.4-r1
dev-python/pycrypto: 2.1.0_beta1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.1.2, 4.3.4, 4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=prescott -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict test test-fail-continue unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://mirror.ovh.net/gentoo-distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb branding bzip2 cairo cdr cjk cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif gnome gnome-print gpm gstreamer gtk2 hal iconv ipv6 jpeg laptop lcms libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd pulseaudio python qt3support readline reflection sdl session spell spl sse ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 x86 xcb xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Didier Barvaux 2010-04-09 17:08:24 UTC
Created attachment 227149 [details, diff]
Fix check for libetpan version in configure.ac
Comment 2 Didier Barvaux 2010-04-09 17:09:37 UTC
Created attachment 227151 [details, diff]
Patch to apply the bugfix in the claws-mail/claws-mail-3.7.5 ebuild
Comment 3 Tim Harder gentoo-dev 2010-04-09 18:19:30 UTC
We could also take this opportunity to use at least EAPI 2 for the src_prepare and src_configure phases instead of using the src_unpack and src_compile phases.

In addition, we might consider setting some decent IUSE defaults (supported by EAPI 1 and later) so things like imap support are included by default.
Comment 4 Tim Harder gentoo-dev 2010-04-10 10:18:01 UTC
Created attachment 227227 [details, diff]
Ebuild updates for claws-mail-3.7.5-r1

Ebuild updates for claws-mail-3.7.5-r1:
  * Use EAPI 2 for src_prepare and src_configure phases
  * Use autotools eclass for eautoreconf call
  * Add a couple IUSE defaults
  * Use src_prepare phase to apply the attached patch to fix the configure bug with >libetpan-0.57
  * Use src_configure instead of src_compile (use default src_compile phase so the emake call is unnecessary)
  * Organize code that sets libetpan and gnutls configure flags -- adds a few more lines to the ebuild, but the code seems clearer rather than always setting the disable flags and then tacking enable flags on top if the correct USE flags are enabled
  * Explicit die for econf is unnecessary since it automatically calls die if the configure script fails
Comment 5 Didier Barvaux 2010-04-10 12:08:21 UTC
(In reply to comment #4)
> Created an attachment (id=227227) [details]
> Ebuild updates for claws-mail-3.7.5-r1

Successfully tested on my system with libetpan-1.0. Thanks Tim.
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-15 03:14:02 UTC
mail@akhuettel.de: Please respect metadata.xml if you are going to wrangle bugs. Thanks in advance.

FWIW, I was just trying out claws-mail and also think that +imap would be a great improvement! re-compiles are not fun for what most people consider basic use of a mail-client! :)
Comment 7 Christian Faulhammer (RETIRED) gentoo-dev 2010-04-15 07:30:57 UTC
Thank you for Will do both packages soon.  Does libetpan 1.0 have anymore side-effects (like API/ABI change)?
Comment 8 Tim Harder gentoo-dev 2010-04-15 07:59:05 UTC
(In reply to comment #7)
> Thank you for Will do both packages soon.  Does libetpan 1.0 have anymore
> side-effects (like API/ABI change)?

I think there's a small API change and the soname version has changed.

Comment 9 Andreas K. Hüttel gentoo-dev 2010-04-15 09:14:12 UTC
(In reply to comment #6)
> mail@akhuettel.de: Please respect metadata.xml if you are going to wrangle
> bugs. Thanks in advance.

Oops sorry. Next time better. Seems I have not actually memorized the entire tree's metadata yet... :o)
Comment 10 Didier Barvaux 2010-04-17 17:42:00 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Thank you for Will do both packages soon.  Does libetpan 1.0 have anymore
> > side-effects (like API/ABI change)?
> 
> I think there's a small API change and the soname version has changed.
> 

You're right for the API change, see a fragment of the changelog below:

  2010-04-05 - libetpan-0.58cvs19 - hoa
   * build-mac/update.sh
     import of OpenSSL (prepare build for iPhone including OpenSSL)
   * src/driver/implementation/pop3/pop3driver.c
   * src/driver/implementation/pop3/pop3driver_cached.c
   * src/driver/implementation/pop3/pop3driver_tools.c
   * src/low-level/pop3/mailpop3.[ch]
       better error checking (2888850). Thanks to Alexander Shlemin.
         API change.

I've tracked the API change, it seems to be a change of return type for the mailpop3_list() functions provided in /usr/include/libetpan/mailpop3.h. See http://libetpan.cvs.sourceforge.net/viewvc/libetpan/libetpan/src/low-level/pop3/mailpop3.h?r1=1.18&r2=1.19 for a diff of the change.


You are also right for the soname version:
  0.57 -> libetpan.so.13.1.2
  0.58 -> libetpan.so.13.1.3
  1.0  -> libetpan.so.15.0.0
Comment 11 Christian Faulhammer (RETIRED) gentoo-dev 2010-04-20 19:05:12 UTC
Thank you for your support, I incorporated all of these changes.
Comment 12 Didier Barvaux 2010-05-09 15:18:56 UTC
Work without any problem with libetpan 1.0. I close the bug.