Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 313857 - --resume should work for sets as well
Summary: --resume should work for sets as well
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
Depends on:
Blocks: 144480
  Show dependency tree
Reported: 2010-04-08 12:00 UTC by Markos Chandras (RETIRED)
Modified: 2010-04-17 18:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

working test (emerge-set-test.txt,3.08 KB, text/plain)
2010-04-08 12:14 UTC, Alex Alexander (RETIRED)
second working test (emerge-set-test-2.txt,7.80 KB, text/plain)
2010-04-08 14:57 UTC, Alex Alexander (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras (RETIRED) gentoo-dev 2010-04-08 12:00:28 UTC
I recently noticed that --resume options doesn't work for sets. 


I rebuild a whole Qt set every day. I use emerge @qt-all-4.7-live-nokia set from qting-edge. If an ebuild fails to build, I manually fix it and try to run emerge --resume sto resume from the last interruption point. To my surprise, portage picks the last emerge command  before the emerge @qt-all-4.7-live-nokia command. 
It seems that --resume doesn't take into account set s so I would like to see this option get implemented

Im not sure if the problem is clear or if I made it clear to you. If not please let me know
Thank you
Comment 1 Alex Alexander (RETIRED) gentoo-dev 2010-04-08 12:14:06 UTC
Created attachment 227009 [details]
working test

hmm. this works fine here w/ portage-2.2_rc67 if I break emerge manually.

check out the attachment :)
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2010-04-08 12:29:06 UTC
I will try to break the emerge flow myself.  But what happens if the emerge stops due to an ebuild compilation error? Does this still work for you?
Comment 3 Alex Alexander (RETIRED) gentoo-dev 2010-04-08 14:57:17 UTC
Created attachment 227021 [details]
second working test

I added a "die" in qt-core's configure phase and tried again, it still works for me :)
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2010-04-12 20:29:26 UTC
Well it doesnt for me

I run emerge @qt-all-live-nokia

It failed on qt-assistant, and emerge --resume continues a very very very old emerge command

 * ERROR: x11-libs/qt-assistant-4.9999 failed:
 *   emake qch_docs failed
 * Call stack:
 *, line  48:  Called src_compile
 *   environment, line 3790:  Called die
 * The specific snippet of code:
 *       emake qch_docs || die "emake qch_docs failed";
 * If you need support, post the output of 'emerge --info =x11-libs/qt-assistant-4.9999',
 * the complete build log and the output of 'emerge -pqv =x11-libs/qt-assistant-4.9999'.
 * This ebuild used the following eclasses from overlays:
 *   /var/lib/portage/overlays/eclass/qt4-build-edge.eclass
 * This ebuild is from an overlay named 'qting-edge': '/var/lib/portage/overlays/'
 * The complete build log is located at '/var/tmp/portage/x11-libs/qt-assistant-4.9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/qt-assistant-4.9999/temp/environment'.
 * S: '/var/tmp/portage/x11-libs/qt-assistant-4.9999/work/qt-everywhere-opensource-src-4.9999'

>>> Failed to emerge x11-libs/qt-assistant-4.9999, Log file:

>>>  '/var/tmp/portage/x11-libs/qt-assistant-4.9999/temp/build.log'

 * GNU info directory index is up-to-date.

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

(qt-4.9999) chroot Mystical / # emerge --resume

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
 * One or more packages are either masked or have missing dependencies:
 *   >=kde-base/kdelibs-4 pulled in by:
 *     ('installed', '/', 'dev-util/subversion-1.6.9', 'nomerge')
 *   kde-base/kwalletd pulled in by:
 *     ('installed', '/', 'dev-util/subversion-1.6.9', 'nomerge')