Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 312161 - gnome-base/libbonobo-2.24.2 fails to build on hardened with
Summary: gnome-base/libbonobo-2.24.2 fails to build on hardened with
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-30 18:01 UTC by thomasg
Modified: 2013-03-03 20:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,165.52 KB, text/plain)
2010-03-30 18:04 UTC, thomasg
Details
Build log (build.log,175.20 KB, text/plain)
2013-02-19 07:04 UTC, Arackhaen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thomasg 2010-03-30 18:01:06 UTC
gnome-base/libbonobo-2.24.2 fails to build on AMD64 hardened.
Here's the fail log:

activation-server-main.c: In function 'main':
activation-server-main.c:672: warning: ignoring return value of 'chdir', declared with attribute warn_unused_result
mv -f .deps/activation-context-query-parser.Tpo .deps/activation-context-query-parser.Po
mv -f .deps/activation-server-main.Tpo .deps/activation-server-main.Po
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -Wl,-O1 -o .libs/activation-client client.o -Wl,--export-dynamic -pthread  ../bonobo/.libs/libbonobo-2.so /var/tmp/portage/gnome-base/libbonobo-2.24.2/work/libbonobo-2.24.2/bonobo-activation/.libs/libbonobo-activation.so ../bonobo-activation/.libs/libbonobo-activation.so -lname-server-2 /usr/lib64/libORBitCosNaming-2.so /usr/lib64/libORBit-2.so /usr/lib64/libgmodule-2.0.so /usr/lib64/libgthread-2.0.so /usr/lib64/libdbus-glib-1.so /usr/lib64/libdbus-1.so -lpthread -lrt /usr/lib64/libgobject-2.0.so /usr/lib64/libglib-2.0.so /usr/lib64/libxml2.so -ldl -lz -lm -pthread
mv -f .deps/activation-context-query-lexer.Tpo .deps/activation-context-query-lexer.Po
/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -O2 -pipe -march=native  -Wl,-O1 -o bonobo-activation-server activation-server-corba-extensions.o activation-context-query.o activation-context-query-lexer.o activation-context-query-parser.o activation-context-corba.o object-directory-corba.o object-directory-load.o object-directory-activate.o object-directory-config-file.o activation-server-main.o ../bonobo/libbonobo-2.la ../bonobo-activation/libbonobo-activation.la -lname-server-2 -Wl,--export-dynamic -pthread -lgmodule-2.0 -lORBitCosNaming-2 -lORBit-2 -lgthread-2.0 -ldbus-glib-1 -ldbus-1 -lpthread -lrt -lgobject-2.0 -lglib-2.0 -lxml2    
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -Wl,-O1 -o .libs/test-performance test-performance.o object-directory-load.o -Wl,--export-dynamic -pthread  ../bonobo/.libs/libbonobo-2.so /var/tmp/portage/gnome-base/libbonobo-2.24.2/work/libbonobo-2.24.2/bonobo-activation/.libs/libbonobo-activation.so ../bonobo-activation/.libs/libbonobo-activation.so -lname-server-2 /usr/lib64/libORBitCosNaming-2.so /usr/lib64/libORBit-2.so /usr/lib64/libgmodule-2.0.so /usr/lib64/libgthread-2.0.so /usr/lib64/libdbus-glib-1.so /usr/lib64/libdbus-1.so -lpthread -lrt /usr/lib64/libgobject-2.0.so /usr/lib64/libglib-2.0.so /usr/lib64/libxml2.so -ldl -lz -lm -pthread
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -Wl,-O1 -o .libs/bonobo-activation-server activation-server-corba-extensions.o activation-context-query.o activation-context-query-lexer.o activation-context-query-parser.o activation-context-corba.o object-directory-corba.o object-directory-load.o object-directory-activate.o object-directory-config-file.o activation-server-main.o -Wl,--export-dynamic -pthread  ../bonobo/.libs/libbonobo-2.so /var/tmp/portage/gnome-base/libbonobo-2.24.2/work/libbonobo-2.24.2/bonobo-activation/.libs/libbonobo-activation.so ../bonobo-activation/.libs/libbonobo-activation.so -lname-server-2 /usr/lib64/libORBitCosNaming-2.so /usr/lib64/libORBit-2.so /usr/lib64/libgmodule-2.0.so /usr/lib64/libgthread-2.0.so /usr/lib64/libdbus-glib-1.so /usr/lib64/libdbus-1.so -lpthread -lrt /usr/lib64/libgobject-2.0.so /usr/lib64/libglib-2.0.so /usr/lib64/libxml2.so -ldl -lz -lm -pthread
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../lib64/libname-server-2.a(orbit-name-server.o): relocation R_X86_64_32S against `.data' can not be used when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../lib64/libname-server-2.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [bonobo-activation-server] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/libbonobo-2.24.2/work/libbonobo-2.24.2/activation-server'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnome-base/libbonobo-2.24.2/work/libbonobo-2.24.2/activation-server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/libbonobo-2.24.2/work/libbonobo-2.24.2'
make: *** [all] Error 2
-------------------------------------------------------------
Find the full buildlog attached
-------------------------------------------------------------
emerge --info

Portage 2.2_rc67 (hardened/linux/amd64/10.0, gcc-4.3.4, glibc-2.11-r1, 2.6.33-gentoo x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-x86_64-AMD_Phenom-tm-_II_X4_925_Processor-with-gentoo-2.0.1
Timestamp of tree: Tue, 30 Mar 2010 12:15:01 +0000
app-shells/bash:     4.1_p2-r1
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.5-r1, 3.1.2-r1
dev-util/cmake:      2.8.1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ 		http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ 		ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo 		ftp://pandemonium.tiscali.de/pub/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="de en_US"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/efl /var/lib/layman/akoya /var/lib/layman/sunrise /var/lib/local_overlay"
SYNC="rsync://praetorian/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 berkdb bzip2 cairo cdda cddb cdparanoia cdr cli cracklib crypt cups curl curlwrappers cvs cxx dbus dri dts dv dvd dvdr emotion encode exchange exif extensions extras ffmpeg firefox flac gdbm gif gimp gpm gtk hal hardened iconv icu imagemagick imlib ipv6 jabber jpeg jpeg2k justify lame libnotify libsamplerate lm_sensors lua lzo mad matroska mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz ncurses nls nocd nptl nptlonly nsplugin ogg openal opengl openmp pam pcre pdf perl pic png policykit posix ppds pppd python qt3support qt4 raw readline reflection scanner sdl session slang smp sndfile speex spell spl sqlite sqlite3 sse sse2 ssl subvuersion svg sysfs taglib tcpd theora threads tiff truetype udev-acl unicode urandom usb videos vim-syntax vorbis weather webkit x264 xcomposite xine xml xorg xv xvid zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Reproducible: Always

Steps to Reproduce:
1. Use hardened profile
2. Build libbonobo
3. -> fail
Comment 1 thomasg 2010-03-30 18:04:05 UTC
Created attachment 225865 [details]
Build log

build.log of failing libbonobo build
Comment 2 Magnus Granberg gentoo-dev 2010-07-26 02:05:31 UTC
gnome-base/libbonobo-2.24.3 build fine for me.
make[1]: Leaving directory `/var/tmp/portage/gnome-base/libbonobo-2.24.3/work/libbonobo-2.24.3'
>>> Source compiled.
jasmin ~ # emerge --info
Portage 2.2_rc67 (hardened/linux/amd64/10.0, gcc-4.4.4, glibc-2.11.2-r0, 2.6.32-hardened-r4 x86_64)
=================================================================
System uname: Linux-2.6.32-hardened-r4-x86_64-Intel-R-_Xeon-R-_CPU_E5420_@_2.50GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 25 Jul 2010 21:45:01 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
Comment 3 Pacho Ramos gentoo-dev 2010-08-24 11:05:31 UTC
Are you still suffering this problem with 2.24.3 on a fully updated system?
Comment 4 Pacho Ramos gentoo-dev 2010-09-03 18:29:31 UTC
(In reply to comment #3)
> Are you still suffering this problem with 2.24.3 on a fully updated system?
> 

Feel free to reopen if still valid
Comment 5 Gilles Dartiguelongue gentoo-dev 2010-10-18 09:31:53 UTC
Thanks for taking the time to report this bug, however, since it has not been updated to provide the request information, we cannot help in resolving your issue.
Comment 6 Arackhaen 2013-02-19 07:01:38 UTC
I have the same issue as described here.

This is hardened non-multilib environment, trying to build libbonobo 2.24.3. Now there are some software that I can't emerge, because they are depending on libbonobo.

Tried to fix it adding -fPIC to global CFLAGS, but it didn't help.

Error message:
--- clip! ---
mv -f .deps/activation-context-query-lexer.Tpo .deps/activation-context-query-lexer.Po
/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -march=core2 -O2 -pipe -fPIC  -Wl,-O1 -Wl,--as-needed -o bonobo-activation-server activation-server-corba-extensions.o activation-context-query.o activation-context-query-lexer.o activation-context-query-parser.o activation-context-corba.o object-directory-corba.o object-directory-load.o object-directory-activate.o object-directory-config-file.o activation-server-main.o ../bonobo/libbonobo-2.la ../bonobo-activation/libbonobo-activation.la -lname-server-2 -Wl,--export-dynamic -pthread -lgmodule-2.0 -lORBitCosNaming-2 -lORBit-2 -lgthread-2.0 -lrt -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0 -lxml2    
libtool: link: x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fPIC -Wl,-O1 -o .libs/bonobo-activation-server activation-server-corba-extensions.o activation-context-query.o activation-context-query-lexer.o activation-context-query-parser.o activation-context-corba.o object-directory-corba.o object-directory-load.o object-directory-activate.o object-directory-config-file.o activation-server-main.o -Wl,--export-dynamic -pthread  -Wl,--as-needed ../bonobo/.libs/libbonobo-2.so -L/usr/lib64 /var/tmp/portage/gnome-base/libbonobo-2.24.3/work/libbonobo-2.24.3/bonobo-activation/.libs/libbonobo-activation.so ../bonobo-activation/.libs/libbonobo-activation.so -lname-server-2 /usr/lib64/libORBitCosNaming-2.so /usr/lib64/libORBit-2.so -lgmodule-2.0 -lgthread-2.0 -lrt -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0 -lxml2 -pthread
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/libname-server-2.a(orbit-name-server.o): relocation R_X86_64_32 against `.rodata.str1.8' can not be used when making a shared object; recompile with -fPIC
/usr/lib64/libname-server-2.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [bonobo-activation-server] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/libbonobo-2.24.3/work/libbonobo-2.24.3/activation-server'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnome-base/libbonobo-2.24.3/work/libbonobo-2.24.3/activation-server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/libbonobo-2.24.3/work/libbonobo-2.24.3'
make: *** [all] Error 2
emake failed
--- clip! ---

emerge info:
--- clip! ---
Portage 2.1.11.50 (hardened/linux/amd64/no-multilib/selinux, gcc-4.5.4, glibc-2.15-r3, 3.7.0-hardened-SAMA-smp x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.0-hardened-SAMA-smp-x86_64-Intel-R-_Core-TM-_i7_CPU_950_@_3.07GHz-with-gentoo-2.1
KiB Mem:     6082500 total,   1007264 free
KiB Swap:    2097148 total,   2090480 free
Timestamp of tree: Wed, 30 Jan 2013 21:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo java-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fPIC"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe -fPIC"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://trumpetti.atm.tut.fi/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/binary_packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay"
SYNC="rsync://rsync15.de.gentoo.org/gentoo-portage"
USE="X alsa amd64 apache2 berkdb bzip2 cairo cdr cli cracklib crypt cxx dri dvd gdbm glib gpm hardened iconv innodb ipv6 jpeg justify kde mmx modules mp3 mudflap mysql ncurses nls nptl open_perms opengl openmp pam pax_kernel pcre perl php pic png python qt3support qt4 readline selinux semantic-desktop session sse sse2 ssl svg tcpd unicode urandom xml xml2 zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_core authn_alias authn_anon authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest dumpio imagemap log_forensic proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi reqtimeout unixd slotmem_shm socache_shmcb" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="imps2 evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fi en en_US" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="agfafocus apple artec artec_eplus48u as6e avision bh canon canon630u canon_dr canon_pp coolscan coolscan2 coolscan3 dc210 dc240 dc25 dmc epjitsu epson epson2 fujitsu genesys gt68xx hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm1005 hpsj5s hs2p ibm kodak lexmark ma1509 magicolor matsushita microtek microtek2 mustek mustek_pp mustek_usb nec net niash p5 pie pixma plustek plustek_pp qcam ricoh snapscan stv680 {test} umax umax1220u umax_pp xerox_mfp" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
--- clip! ---

Emerge -pqv:
--- clip! ---
[ebuild  N    ] gnome-base/libbonobo-2.24.3  USE="-debug -doc -examples {-test}"
--- clip! ---


Note, I have not done sync and update deep after this problem or yet tried to solve it with those. I don't remember when I last did them, but it's not many months ago (could be like 1,5 months).
Comment 7 Arackhaen 2013-02-19 07:04:37 UTC
Created attachment 339344 [details]
Build log
Comment 8 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-19 13:28:21 UTC
(In reply to comment #6)

Thanks for the report! Three questions:

What version of gnome-base/orbit do you have, and with what USE flags?

If you are using orbit-2.14.19-r1, does the problem go away if you emerge orbit-2.14.19-r2? (You will need to add "gnome-base/orbit ~amd64" to your /etc/portage/package.accept_keywords)

Does re-emerging gnome-base/orbit with -fPIC added to CFLAGS solve the problem?
Comment 9 Arackhaen 2013-02-22 08:44:59 UTC
Orbit version:
Latest version available: 2.14.19-r1
Latest version installed: 2.14.19-r1

emerge -av =gnome-base/orbit-2.14.19-r2
These are the packages that would be merged, in order:
Calculating dependencies... done!
emerge: there are no ebuilds to satisfy "=gnome-base/orbit-2.14.19-r2".
Comment 10 Arackhaen 2013-02-22 08:49:44 UTC
(In reply to comment #9)
> Orbit version:
> Latest version available: 2.14.19-r1
> Latest version installed: 2.14.19-r1
> 
> emerge -av =gnome-base/orbit-2.14.19-r2
> These are the packages that would be merged, in order:
> Calculating dependencies... done!
> emerge: there are no ebuilds to satisfy "=gnome-base/orbit-2.14.19-r2".

Forgot to add this:

gnome-base/orbit-2.14.19-r1 was built with the following:
USE="-debug -doc -test"
CFLAGS="-march=core2 -O2 -pipe"
CXXFLAGS="-march=core2 -O2 -pipe"
(Didn't know correct command to extract these, so I copied them from emerge info of orbit.)
Comment 11 Arackhaen 2013-02-22 09:03:37 UTC
Nice!

You were right with your suggestion to reinstall orbit first with -fPIC in CFLAGS and then install libbonobo (while still having that -fPIC in CFLAGS).
Now it did install correctly and this is solved for me.

And I didn't get the new orbit version, so I know this wasn't fixed by that.

I actually have "pic" in my make.conf's USE flags, but don't know if it should have any relevance here.
Comment 12 Magnus Granberg gentoo-dev 2013-02-26 23:59:14 UTC
The main problem here is that the .libs/bonobo-activation-server is built
with -fPIE on hardened so any thing that link to it need to be built with
-fPIC and static libs is not build with -fPIC only shared libs is build with
-fPIC on amd64.
Comment 13 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-03-03 20:18:43 UTC
(In reply to comment #12)

Thanks; I've added a pic USE flag to orbit-2.14.19-r2 which should fix the problem properly.

+  03 Mar 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+  orbit-2.14.19-r2.ebuild, +files/orbit-2.14.19-fPIC.patch, metadata.xml:
+  Add pic USE flag to fix libbonobo build failure on hardened systems (bug
+  #312161, thanks to arackhaen and Magnus Granberg).