Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 312063 - [science overlay] sci-misc/freecad-0.9.2646 does not install PartGui
Summary: [science overlay] sci-misc/freecad-0.9.2646 does not install PartGui
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: InOverlay
Depends on:
Blocks:
 
Reported: 2010-03-30 12:05 UTC by Thomas Raschbacher
Modified: 2011-03-06 20:42 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---
jlec: Bugday+


Attachments
FreeCAD 0.10 ebuild (freecad-0.10.3205.ebuild,1.08 KB, text/plain)
2010-09-10 09:53 UTC, Per Öberg
Details
Ebuild for freecad-0.10 (freecad-0.10.3205.ebuild,1.10 KB, text/plain)
2010-09-10 10:17 UTC, Per Öberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Raschbacher gentoo-dev 2010-03-30 12:05:55 UTC
All i get is a message saying 'No module named PartGui' (python error message) no more help using FreeCADCmd either and manually importing.

There have been problems like this before:
http://sourceforge.net/apps/mediawiki/free-cad/index.php?title=Talk:User_hub#Cannot_load_PartGui
and http://sourceforge.net/tracker/index.php?func=detail&aid=1952771&group_id=49159&atid=455298 (i tried replacing econf (which adds --host and --build) with a manual --configure call but still same problem.

equery files freecad | grep -i partgui  gives me nothing either.

maybe the latest 0.10 version works better?

btw I am using python2.6 atm
Comment 1 Henryk Rychlik 2010-04-16 07:29:51 UTC
The problem is /opt/ location of openacascade (OCC) add --with-occ-include and --with-occ-lib, like I wrote in this link from post 47 or simply copy EBULD and Manifest.
Comment 2 tman 2010-05-27 06:45:14 UTC
there are a new releas of this software, plz bump and fix

thanks

http://sourceforge.net/apps/mediawiki/free-cad/index.php?title=Main_Page
Comment 3 Chris Brown 2010-05-31 07:33:56 UTC
(In reply to comment #1)
> The problem is /opt/ location of openacascade (OCC) add --with-occ-include and
> --with-occ-lib, like I wrote in this link from post 47 or simply copy EBULD and
> Manifest.
> 

Which link?
Comment 4 tman 2010-06-08 21:37:25 UTC
yes atm this application is really useless
Comment 5 tman 2010-06-08 21:42:17 UTC
"No module named PartGui
Pivy and PyQt4 python modules must be installed on your system to use the 2D Drafting module."


this mus addon to depency 
Comment 6 Per Öberg 2010-09-10 09:53:14 UTC
Created attachment 246674 [details]
FreeCAD 0.10 ebuild

I fixed the old ebuild and updated it from 0.9 to 0.10.

I simply added 

--with-occ-include=${CASROOT}/inc 
--with-occ-lib=${CASROOT}/lib

and removed some of the version specific dependencies.

However, I failed to make it download the source so you need to download it manually and put it in "/usr/portage/distfiles/" with the name FreeCAD-0.10.3205.tar.gz
Comment 7 Per Öberg 2010-09-10 10:17:18 UTC
Created attachment 246676 [details]
Ebuild for freecad-0.10

This ebuild also downloads stuff correctly

The download problem was actually easy to solve. The first time I tried i made a simple typo and not beeing an ebuild expert i didn't know what to do. 

This ebuild comes with worksforme support.
Comment 8 Chris Brown 2011-01-29 22:42:13 UTC
Any new update for freecad 11?
Comment 9 tman 2011-03-06 13:34:50 UTC
ther u will help:

http://bugs.gentoo.org/show_bug.cgi?id=291161


it iht in the science overlay
Comment 10 Andreas K. Hüttel gentoo-dev 2011-03-06 20:42:01 UTC
and now it is in the main tree and PartGui is installed. so resolving.