Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 311293 - Kaffeine corrupts X after full screen and movie finishes
Summary: Kaffeine corrupts X after full screen and movie finishes
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-25 11:50 UTC by Piotrek Juzwiak
Modified: 2011-03-08 19:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
emerge --info (emerge.txt,3.28 KB, text/plain)
2010-03-25 11:50 UTC, Piotrek Juzwiak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotrek Juzwiak 2010-03-25 11:50:21 UTC
I am using kernel 2.6.33, mesa 7.8_rc2, xorg-server 1.7.6, Intel driver 2.10-r1.

Everything works just fine, system hibernates and suspends BUT if i had kaffeine turned on and fullscreen when the system suspended i get a black screen after waking the system up.

Reproducible: Always

Steps to Reproduce:
1.Open a movie in kaffeine full screen
2.Suspend the system
3.Wake the system up

Actual Results:  
When i wake up the system i get a black screen with only my mouse cursor.

Expected Results:  
System wakes up with kaffeine which i can double click to change it's size and after that i can normally use the system without restarting xdm
Comment 1 Piotrek Juzwiak 2010-03-25 11:50:37 UTC
Created attachment 225215 [details]
emerge --info
Comment 2 Panagiotis Christopoulos (RETIRED) gentoo-dev 2010-03-27 10:22:15 UTC
Can you attach your Xorg.0.log and give some more informative specs about this failure(eg. any console (error) output? We cannot proccess this bug as-it-is.
Comment 3 Piotrek Juzwiak 2010-03-27 16:59:43 UTC
Now as i was testing it i found out it is not the waking up that causes the problem. Kaffeine by itself does it when the movie finishes (last second of the movies no matter what it is). 
Comment 4 Piotrek Juzwiak 2010-03-27 17:06:23 UTC
When the movie finishes it leaves a black screen with which i can't do much except moving the mouse cursor which changes in upper left corner (i got some folders setup there, KDE 4.4.1). If i the movie finishes on the first screen and i was on the second i can normally double click it to turn it off. Could you tell me what log files you would need? Because it looks to me it's kwin or kaffeine itself...
Comment 5 Andreas K. Hüttel gentoo-dev 2010-04-20 21:27:10 UTC
Just start kaffeine from a konsole with 
kaffeine &> mynewlogfile.txt
for a start...
Comment 6 Piotrek Juzwiak 2010-05-14 16:52:26 UTC
Sorry for not posting anything but i was abroad for a while. Now going back to the bug, i updated xorg-server to version 1.8, now the problem doesn't exist anymore, instead it is worse. If i have kaffeine fullscreen and the movie finishes then after that i get completely garbled desktop and eventually it will freeze. 
Comment 7 Andreas K. Hüttel gentoo-dev 2010-11-12 22:51:56 UTC
Moving this to the x11 team since it is more likely a problem there. 
Do you still have these problems with current x11 and kaffeine versions?
Comment 8 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-31 01:24:02 UTC
report it upstream plz and attach the upstream bug here so we can track it