Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 311149 - xfce4-battery-plugin-0.5.1 does not find any battery info (on PowerPC)
Summary: xfce4-battery-plugin-0.5.1 does not find any battery info (on PowerPC)
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-24 17:03 UTC by matt
Modified: 2010-12-18 18:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matt 2010-03-24 17:03:43 UTC
using xfce4-battery-plugin and it always shows 0 for percentage and time remaining.

matt@ssbook ~ $ zcat /proc/config.gz | grep -i apm
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
CONFIG_APM_EMULATION=y
CONFIG_PMAC_APM_EMU=y
CONFIG_APM_POWER=y

matt@ssbook ~ $ cat /proc/version 
Linux version 2.6.31-gentoo-r6

matt@ssbook ~ $ ls -l /dev/apm_bios 
crw-r----- 1 root users 10, 134 Mar 17 18:26 /dev/apm_bios

the only tool i know of now that works is ibam.

matt@ssbook ~ $ emerge --info
Portage 2.1.7.17 (unavailable, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 ppc)
=================================================================
System uname: Linux-2.6.31-gentoo-r6-ppc-7447A,_altivec_supported-with-gentoo-1.12.13
Timestamp of tree: Unknown
dev-lang/python:     2.6.4-r1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.6.3, 1.9.6-r2, 1.10.3
sys-devel/binutils:  2.18-r3
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_LICENSE="* -@EULA"
CFLAGS="-O2 -pipe -mcpu=7400 -maltivec -mabi=altivec"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mcpu=7400 -maltivec -mabi=altivec"
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-03-24 18:16:13 UTC
It suddenly doesn't work or it never worked?
Comment 2 matt 2010-03-24 21:47:56 UTC
i have been out of school for over 2 years now and it has always worked then.  it has been sometime since it suddenly stopped working.
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2010-12-18 18:39:19 UTC
Last I checked, this was still working fine on x86_64 and ACPI
Please do some more debugging on your own. Only you have access to the specific hardware + kernel combination. 
For example, using `strace` to see what's it doing... accessing exactly what in /proc, /sys or /dev?