Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310829 - x11-drivers/xf86-video-intel-2.10.0-r1: slowdown then freeze
Summary: x11-drivers/xf86-video-intel-2.10.0-r1: slowdown then freeze
Status: RESOLVED DUPLICATE of bug 314935
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-23 08:15 UTC by Joel
Modified: 2010-04-14 06:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info,3.99 KB, text/plain)
2010-03-23 08:16 UTC, Joel
Details
Xorg log (Xorg.0.log,32.07 KB, text/plain)
2010-03-23 17:23 UTC, Joel
Details
My Xorg.0.log.old which was written at the time of the freeze (Xorg.0.log.old,37.30 KB, text/plain)
2010-04-12 11:19 UTC, Tassilo Horn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel 2010-03-23 08:15:36 UTC
Hi, I'm using an up to date Gentoo Linux amd64 testing, and sometimes Xorg freezes (and mouse gets very slow). I'm using:
- xf86-video-intel-2.10.0-r1
- mesa-7.7.1_rc1 (I've masked 7.8)
- xorg-server-1.7.6
- KDE 4.4.1
- libdrm 2.4.19

In the log I attach the emerge --info 

Reproducible: Always
Comment 1 Joel 2010-03-23 08:16:01 UTC
Created attachment 224813 [details]
emerge --info
Comment 2 Rémi Cardona gentoo-dev 2010-03-23 15:36:34 UTC
Please also attach your Xorg.0.log

Thanks
Comment 3 Joel 2010-03-23 17:23:43 UTC
Created attachment 224917 [details]
Xorg log
Comment 4 Joel 2010-03-23 17:24:15 UTC
Xorg log attached
Comment 5 Joel 2010-03-23 22:37:32 UTC
I think I've found the problem. This happens everytime I start JDownloader (I don't know how I didn't realize before), so when launching it, I've added this to the args: "-Dsun.java2d.opengl=true" and everything works fine. Thanks and sorry.
Comment 6 Joel 2010-03-24 01:59:53 UTC
Sorry again, the same problem happens (sometimes) when I login, so this is not only Java related.
Comment 7 Rémi Cardona gentoo-dev 2010-03-24 13:03:24 UTC
Could you attach the full output of dmesg when the freeze happens? (assuming you can still log in via ssh from another nearby box.)

Thanks
Comment 8 Tassilo Horn 2010-04-12 11:18:05 UTC
I also get random K freezes on my ~amd64 system since about one week ago where a bunch of X updates arrived (xorg-server, mesa, xf86-video-intel,...).

Unfortunately, when I get such a freeze, the system seems to be really dead.  I get a blank screen with a "_" cursor in the top left corner.  The I cannot switch to a console using Ctrl-Alt-Fx, nor can I ssh into the system anymore.  Even Magic SysRQ key don't work!

I usually get those freezes when the screensaver (the ASCII art aquarium from kscreensaver) is running or when I activate the screen after the notebook lid was closed.

I also attach my Xorg.0.log.old which was written when the last freeze occured, although there's nothing really suspicious in it...
Comment 9 Tassilo Horn 2010-04-12 11:19:13 UTC
Created attachment 227485 [details]
My Xorg.0.log.old which was written at the time of the freeze
Comment 10 Tassilo Horn 2010-04-13 18:11:05 UTC
Bug 314935 seems related or a duplicate of this one.
Comment 11 Rémi Cardona gentoo-dev 2010-04-13 20:15:02 UTC
There isn't much I can do about such bugs, they're beyond my knowledge of the
driver.

Please file a bug upstream [1] and paste the URL here so I can track the issue.

Thanks

[1] http://intellinuxgraphics.org/how_to_report_bug.html
Comment 12 Tassilo Horn 2010-04-14 05:53:16 UTC
There's already an upstream bug.  See

  http://bugs.freedesktop.org/show_bug.cgi?id=27497
Comment 13 Rémi Cardona gentoo-dev 2010-04-14 06:32:20 UTC
Reopening
Comment 14 Rémi Cardona gentoo-dev 2010-04-14 06:33:04 UTC
Alright, I've CCed myself on the upstream bug, let's track it there directely.

Thanks

*** This bug has been marked as a duplicate of bug 314935 ***