Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 31034 - realone-1 ebuild fails with a sandbox violation
Summary: realone-1 ebuild fails with a sandbox violation
Status: RESOLVED LATER
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on: 40469
Blocks:
  Show dependency tree
 
Reported: 2003-10-13 06:16 UTC by Peter Simons
Modified: 2004-03-17 06:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Simons 2003-10-13 06:16:33 UTC
[...]
>>> Completed installing into /var/tmp/portage/realone-1/image/

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-realone-1-26105.log"

mkdir:     /root/.realnetworks
mkdir:     /root/.realnetworks
mkdir:     /root/.realnetworks
mkdir:     /root/.realnetworks
mkdir:     /root/.realnetworks
mkdir:     /root/.realnetworks
mkdir:     /root/.realnetworks
mkdir:     /root/.realnetworks
--------------------------------------------------------------------------------


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Peter Simons 2003-10-16 15:26:23 UTC
In case it helps, here is the "emerge info" output from my system:

Portage 2.0.49-r13-2 (selinux-x86-1.4, gcc-3.3.1, glibc-2.3.2-r6, 2.4.21-hardened)
=================================================================
System uname: 2.4.21-hardened i686 AMD Athlon(tm) Processor
Gentoo Base System version 1.4.3.11
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-mcpu=athlon -O3 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/config
/usr/kde/3/share/config /var/bind /usr/X11R6/lib/X11/xkb /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=athlon -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache autoaddcvs sandbox userpriv notitles"
GENTOO_MIRRORS="http://212.219.247.20/sites/www.ibiblio.org/gentoo/ http://212.219.247.10/sites/www.ibiblio.org/gentoo/
http://212.219.247.13/sites/www.ibiblio.org/gentoo/ http://212.219.247.15/sites/www.ibiblio.org/gentoo/
http://212.219.247.17/sites/www.ibiblio.org/gentoo/"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 crypt ncurses selinux zlib gdbm berkdb readline pam libwww ssl perl
opengl mozilla altcolors curl dga doc dvd emacs ethereal leim mbox moznocompose
moznoirc moznomail moznoxft rage128 Xaw3d -arts -cups -gpm -java -kde -motif
-nls -qt -svga -xmms -tcpd -python -esd -spell -slang X png gtk gif tiff
mmx xml xml2 truetype oss tetex jpeg avi oggvobis"
Comment 2 Martin Holzer (RETIRED) gentoo-dev 2003-10-18 10:24:36 UTC
try without userpriv
Comment 3 Peter Simons 2003-10-18 10:48:18 UTC
Yes, that did the trick. Thanks for the suggestion!
Comment 4 Philippe Lafoucrière 2003-12-13 00:49:18 UTC
Or simply :

mkdir /root/.realnetworks

it works for me
Comment 5 Patrick Kursawe (RETIRED) gentoo-dev 2004-03-17 06:59:26 UTC
I'd prefer to leave this ebuild alone for now (it's masked anyway for security reasons, see bug #40469)