Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310315 - games-strategy/wormux-0.9.0 configure fails
Summary: games-strategy/wormux-0.9.0 configure fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
: 310781 (view as bug list)
Depends on:
Reported: 2010-03-20 05:49 UTC by Doktor Notor
Modified: 2010-03-23 05:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

config.log (config.log,29.27 KB, text/plain)
2010-03-20 05:50 UTC, Doktor Notor
generated configure script (configure,426.21 KB, text/plain)
2010-03-21 06:28 UTC, Doktor Notor

Note You need to log in before you can comment on or make changes to this bug.
Description Doktor Notor 2010-03-20 05:49:32 UTC
checking for rotozoomSurfaceXY in -lSDL_gfx... yes
checking SDL_rotozoom.h usability... yes
checking SDL_rotozoom.h presence... yes
checking for SDL_rotozoom.h... yes
./configure: line 8552: syntax error near unexpected token `('
./configure: line 8552: `  $as_echo_n "(cached) " >&6'

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/games-strategy/wormux-0.9.0/work/wormux-0.9.0/config.log
 * ERROR: games-strategy/wormux-0.9.0 failed:
 *   econf failed
 * Call stack:
 *, line   48:  Called src_configure
 *   environment, line 3152:  Called egamesconf '--disable-dependency-tracking' '--with-localedir-name=/usr/share/locale' '--with-datadir-name=/usr/share/games/wormux' '--with-font-path=/usr/share/fonts/dejavu/DejaVuSans.ttf' '--disable-debug' '--enable-nls' '--enable-fribidi'
 *   environment, line 1088:  Called econf '--prefix=/usr/games' '--libdir=/usr/games/lib' '--datadir=/usr/share/games' '--sysconfdir=/etc/games' '--localstatedir=/var/games' '--disable-dependency-tracking' '--with-localedir-name=/usr/share/locale' '--with-datadir-name=/usr/share/games/wormux' '--with-font-path=/usr/share/fonts/dejavu/DejaVuSans.ttf' '--disable-debug' '--enable-nls' '--enable-fribidi'
 *, line  538:  Called die
 * The specific snippet of code:
 *   			die "econf failed"

Portage 2.2_rc67 (default/linux/x86/10.0/desktop, gcc-4.4.3, glibc-2.11-r1, 2.6.33-gentoo-ck1 i686)
                        System Settings
System uname: Linux-2.6.33-gentoo-ck1-i686-AMD_Athlon-tm-_XP_2800+-with-gentoo-2.0.1
Timestamp of tree: Sat, 20 Mar 2010 04:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p2
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-python/pycrypto: 2.1.0
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1,
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
EMERGE_DEFAULT_OPTS="--alphabetical --binpkg-respect-use y --keep-going --with-bdeps y"
FEATURES="assume-digests buildsyspkg ccache distlocks fakeroot fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms split-elog split-log strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="cs en"
PORTAGE_RSYNC_EXTRA_OPTS="--prune-empty-dirs --omit-dir-times"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/php-testing /var/lib/layman/php-experimental /var/lib/layman/sunrise /var/lib/layman/enlightenment /usr/local/portage"
USE="3dnow 3dnowext X X509 a52 aac aalib acl acpi alsa amr ao bash-completion berkdb bluetooth branding bzip2 cairo caps cdda cddb cdparanoia cdr cleartype cli cracklib crypt css cups curl cvs cxx dbus directfb djvu dri dts dv dvd dvdr encode exif faac faad fam fat fbcon ffmpeg firefox flac flash fontconfig ftp fuse gd gdbm ggi gif git gnome-keyring gnutls gpm gs gsm gstreamer gtk hal iconv icu id3tag idn ieee1394 imagemagick imap ipv6 irda jbig jpeg jpeg2k ladspa lame lcms libcaca libnotify libsamplerate lirc lm_sensors lock lua lzo mad maildir matroska mikmod mmx mmxext mng modules mp3 mp4 mpeg mudflap musepack musicbrainz ncurses network network-cron nfs nfsv3 nfsv4 nls nptl nptlonly nsplugin ntfs offensive ogg openal openexr opengl openmp pam pch pcre pdf perl pkcs11 plotutils png portaudio ppds pppd python quicktime raw readline reflection reiserfs rss schroedinger sdl session shorten skey sndfile sox speex spell spl sqlite sqlite3 sse ssl startup-notification subversion svg symlink sysfs system-sqlite taglib tcl tcpd theora thunar tiff tk truetype unicode usb v4l v4l2 vcd vorbis wavpack webkit win32codecs wmf wxwidgets x264 x86 xattr xcb xinerama xinetd xml xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="emu10k1 bt87x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev joystick keyboard lirc mouse vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs en" LIRC_DEVICES="cph06x devinput" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia v4l vmware" 
Comment 1 Doktor Notor 2010-03-20 05:50:48 UTC
Created attachment 224325 [details]
Comment 2 Mr. Bones. (RETIRED) gentoo-dev 2010-03-21 01:12:57 UTC
works fine for me on stable x86.

attach your configure script so I can see what the lines around 8552 look like. 
Comment 3 Doktor Notor 2010-03-21 06:28:28 UTC
Created attachment 224471 [details]
generated configure script

(In reply to comment #2)
> attach your configure script so I can see what the lines around 8552 look like. 

Well, it worked fine even on ~arch until I upgraded portage to 2.2 and did emerge -e world. This was the only thing that failed (out of ~1000 ebuild). Kinda a mystery to me. But it fails reliably now *g*
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2010-03-21 06:57:59 UTC
Well your configure is broken so it's clearly a problem with your autotools.  I can't say I recommend running ~x86 unless you're able to deal with the occasional breakage.

I'd say, downgrade to stable x86 for related packages (ones that appear in emerge -evp wormux) until it works.
Comment 5 Doktor Notor 2010-03-21 07:12:19 UTC
(In reply to comment #4)
> Well your configure is broken so it's clearly a problem with your autotools.  I
> can't say I recommend running ~x86 unless you're able to deal with the
> occasional breakage.

Ok, let me explain in more detail - it worked fine until portage-2.2 upgrade. Then I did emerge -e world as recommended and this was the *only* ebuild that failed to re-emerge. The remaining ~1000 of them worked fine. games-strategy/wormux worked before on fully ~arch system, I still have it installed. Downgraded to autoconf-2.63-r1 and it didn't help. Anyway, I don't care whether this is a wormux bug or autotools bug, merely suggesting that broken autotools would probably manifest itself on more ebuilds than 1/1000. It even might be portage-related bug, if you think so then re-assign as appropriate. I merely care about getting the underlying problem fixed, I can still play the game since it's installed *g*
Comment 6 Mr. Bones. (RETIRED) gentoo-dev 2010-03-21 07:15:43 UTC
yes, I understand your situation but I can't reproduce it so I can't really track it down.

If you're interested in getting at the underlying problem you're going to have to do some detective work on your end by downgrading packages to try to determine where the problem is.

If you're not interested, please go ahead and close this bug out since I'm not going to be able to just guess where the problem is occurring.  Thanks.
Comment 7 Doktor Notor 2010-03-21 07:28:38 UTC
Ok, would this give you a hint? Bug 294366
Comment 8 Doktor Notor 2010-03-21 08:06:14 UTC
Well, this clearly bombs out on eautoreconf...  It works fine w/o the gentoo patch plus related eautoreconf, it fails otherwise. NFC why. I'm not alone having this issue - see
Comment 9 Tupone Alfredo gentoo-dev 2010-03-21 15:15:00 UTC
It looks as a problem in curl.
It should be fixed now as soon as dev-libs/curl-7.20.0-r2 hits the trees (some hours from now).
Thanks for report
Comment 10 Doktor Notor 2010-03-21 16:42:10 UTC
(In reply to comment #9)
> It looks as a problem in curl.

Great job, works now! Thanks!
Comment 11 Mr. Bones. (RETIRED) gentoo-dev 2010-03-22 19:45:15 UTC
*** Bug 310781 has been marked as a duplicate of this bug. ***
Comment 12 Azamat H. Hackimov 2010-03-23 05:08:49 UTC
Ehh, >=dev-libs/curl-7.20.0-r2 to RDEPEND for wormux-0.9.1?