Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310257 - media-video/gpac-0.4.5-r1 does not respect LDFLAGS
Summary: media-video/gpac-0.4.5-r1 does not respect LDFLAGS
Status: RESOLVED DUPLICATE of bug 258331
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2010-03-19 16:52 UTC by Doktor Notor
Modified: 2010-08-09 21:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for modules/alsa/Makefile (Makefile.diff,397 bytes, patch)
2010-03-19 16:54 UTC, Doktor Notor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Doktor Notor 2010-03-19 16:52:54 UTC
* QA Notice: Files built without respecting LDFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/lib/gpac/gm_alsa.so
Comment 1 Doktor Notor 2010-03-19 16:54:03 UTC
Created attachment 224259 [details, diff]
patch for modules/alsa/Makefile

This could be it, but... untested. Didn't check the rest for LDFLAGS either. Also, this seems to use some non-autotools stuff, yet using econf and such in ebuild.
Comment 2 Alexis Ballier gentoo-dev 2010-03-23 22:50:20 UTC
(In reply to comment #1)
> Created an attachment (id=224259) [details]
> patch for modules/alsa/Makefile
> 
> This could be it, but... untested. Didn't check the rest for LDFLAGS either.
> Also, this seems to use some non-autotools stuff, yet using econf and such in
> ebuild.
> 

ldflags should come right after shflags here otherwise they make, eg, as-needed still useless
Comment 3 Samuli Suominen gentoo-dev 2010-04-29 18:16:25 UTC
bug 258331 had better patch for this...

*** This bug has been marked as a duplicate of bug 258331 ***