Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310193 - app-misc/lirc-0.8.6-r2 does not respect LDFLAGS
Summary: app-misc/lirc-0.8.6-r2 does not respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Television related Applications in Gentoo's Portage
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2010-03-19 11:21 UTC by Doktor Notor
Modified: 2012-07-19 18:54 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doktor Notor 2010-03-19 11:21:22 UTC
QA Notice: Files built without respecting LDFLAGS have been detected
 Please include the following list of files in your report:
/usr/bin/irw
/usr/bin/ircat
/usr/bin/irpty
/usr/bin/mode2
/usr/bin/lircrcd
/usr/bin/irexec
/usr/bin/irsend
/usr/bin/irrecord
/usr/bin/irxevent
/usr/bin/xmode2
/usr/lib/liblirc_client.so.0.2.1
/usr/sbin/lircd
/usr/sbin/lircmd
Comment 1 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-03-19 12:18:35 UTC
Which version?
Comment 2 Doktor Notor 2010-03-19 12:30:48 UTC
Well, the above is with the latest app-misc/lirc-0.8.6-r2 (no point to report similar bugs against old ones) but all versions fail in this respect pretty likely.
Comment 3 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-03-19 15:26:57 UTC
Build system of lirc is perfectly sane and respects LDFLAGS. It's linux-mod.eclass that's causing this.
default src_compile look like that:
emake ... LDFLAGS="$(get_abi_LDFLAGS)" ...

I don't know whether it's intended behaviour. I see two ways of fixing it:
1. change linux-mod.eclass
2. use handcrafted src_compile instead of default linux-mod_src_compile

CCing kernel-misc to consider 1.

Comment 4 Samuli Suominen gentoo-dev 2010-03-19 15:32:10 UTC
sounds like LDFLAGS="$(get_abi_LDFLAGS)" should be LDFLAGS="${LDFLAGS} $(get_abi_LDFLAGS)" instead in the eclass
Comment 5 Doktor Notor 2010-03-20 23:02:31 UTC
Considering that this affects any ebuild using default src_compile from linux-mod.eclass and actually installs anything beyond kernel modules, fixing this in ebuilds doesn't make sense. 
Comment 6 Ian Stakenvicius gentoo-dev 2012-07-19 18:54:03 UTC
Actually yes it does, because most of lirc shouldn't be build from linux-mod.eclass but on its own.

Fixed in lirc-0.9.0-r1

Also, this is essentially a duplicate of bug 160134 , since the reason for that bug was that LDFLAGS were being overridden by linux-mod.eclass also.